aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorarrowd <arrowd@FreeBSD.org>2018-10-04 16:34:09 +0800
committerarrowd <arrowd@FreeBSD.org>2018-10-04 16:34:09 +0800
commit9d1cccc832041645df315ea0b508ef9bd26605ef (patch)
treee378c88cdf1f7266c116e9c79b58a3ad5770efb4 /lang
parente3ab7fb6482aa18d52c56e8f11f9d6db850deab6 (diff)
downloadfreebsd-ports-gnome-9d1cccc832041645df315ea0b508ef9bd26605ef.tar.gz
freebsd-ports-gnome-9d1cccc832041645df315ea0b508ef9bd26605ef.tar.zst
freebsd-ports-gnome-9d1cccc832041645df315ea0b508ef9bd26605ef.zip
lang/ghc: Remove BOOTH option.
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D17372
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile30
1 files changed, 8 insertions, 22 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index cb2cf404396c..0870908f9539 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -6,8 +6,12 @@ PORTVERSION= ${GHC_VERSION}
PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
- LOCAL/arrowd/:boot
-DISTFILES= ghc-${PORTVERSION}-src${EXTRACT_SUFX}:source
+ LOCAL/arrowd/:boot \
+ ${HACKAGE_SITE}hscolour-${HSCOLOUR_VERSION}/:docs
+
+EXTRACT_ONLY= ${_DISTFILES:C/hscolour.*$//g}
+DISTFILES= ghc-${PORTVERSION}-src${EXTRACT_SUFX}:source \
+ hscolour-${HSCOLOUR_VERSION}.tar.gz:docs
MAINTAINER= haskell@FreeBSD.org
COMMENT= Compiler for the functional language Haskell
@@ -53,7 +57,7 @@ SUB_LIST= GHC_VERSION=${GHC_VERSION} \
OPTIONS_GROUP= BOOTSTRAP
BOOTSTRAP_DESC= Bootsrap using installed ghc
-OPTIONS_GROUP_BOOTSTRAP=BOOT BOOTH
+OPTIONS_GROUP_BOOTSTRAP=BOOT
OPTIONS_DEFINE= DYNAMIC PROFILE DOCS
OPTIONS_SUB= yes
@@ -64,7 +68,6 @@ OPTIONS_EXCLUDE_armv7= DYNAMIC
OPTIONS_EXCLUDE_aarch64= DYNAMIC
BOOT_DESC= Use installed GHC for bootstrapping
-BOOTH_DESC= Use installed HsColour for bootstrapping
PROFILE_DESC= Add support for performance profiling
DYNAMIC_DESC= Add support for dynamic linking
DOCS_DESC= Install HTML documentation
@@ -161,29 +164,12 @@ TMPDIR= ${WRKSRC}/tmp
# the build tree, without needing to install it. At the end
# you could view the output of: ${BOOT_GHC} describe hscolour
-.if ${PORT_OPTIONS:MDOCS}
-
-. if empty(PORT_OPTIONS:MBOOTH)
-
-MASTER_SITES+= ${HACKAGE_SITE}hscolour-${HSCOLOUR_VERSION}/:docs
-DISTFILES+= hscolour-${HSCOLOUR_VERSION}.tar.gz:docs
-
-EXTRACT_ONLY= ${_DISTFILES:C/hscolour.*$//g}
-
-. endif # MBOOTH
-
-. if empty(PORT_OPTIONS:MBOOTH)
-
SLAVES_PREFIX= ${WRKDIR}/slaves_prefix
SLAVES_WRKDIRPREFIX= ${WRKDIR}/slaves_wrkdirprefix
MAKE_ENV+= PATH=${SLAVES_PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${SLAVES_PREFIX}/bin:${PATH}
-. endif # MBOOTH
-
-.endif # MDOCS
-
post-extract:
# don't use the "wrap" trick on arches that use post-ino64 bootstrap binaries (arm*)
.if empty(PORT_OPTIONS:MBOOT) && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200031 && \
@@ -252,7 +238,7 @@ pre-configure: apply-slist
@(cd ${BOOT_DIR} && PACKAGES='' ${MAKE_CMD} install)
.endif
-.if ${PORT_OPTIONS:MDOCS} && empty(PORT_OPTIONS:MBOOTH)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -e "\a"
@${ECHO_MSG} "======================================================================"
@${ECHO_MSG} " WARNING: Now HsColour will be built, the respective port will not "