aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
committerjbeich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
commita38a1342f01b1ae5edb99580dc83310e9ab5e404 (patch)
tree3d66af70b6fe803c5deca7c6f3517c47fc018d8b /lang
parentf8ad3798f3a69930e2b4c1496c67056c1f2b3d7c (diff)
downloadfreebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.tar.gz
freebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.tar.zst
freebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.zip
lang/rust: avoid LLVM targeting SSE2 on i386 by default
This may help ports like textproc/ripgrep to run on old hardware. Rust itself still requires SSE2 until bootstrap is regenerated. PR: 223415 Approved by: rust (dumbbell)
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile1
-rw-r--r--lang/rust/files/patch-src_librustc__back_target_i686__unknown__freebsd.rs11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 82120402d5ae..05fd74132c90 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rust
PORTVERSION?= 1.22.1
+PORTREVISION?= 1
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
LOCAL/dumbbell/rust:rust_bootstrap \
diff --git a/lang/rust/files/patch-src_librustc__back_target_i686__unknown__freebsd.rs b/lang/rust/files/patch-src_librustc__back_target_i686__unknown__freebsd.rs
new file mode 100644
index 000000000000..47f594784f7e
--- /dev/null
+++ b/lang/rust/files/patch-src_librustc__back_target_i686__unknown__freebsd.rs
@@ -0,0 +1,11 @@
+--- src/librustc_back/target/i686_unknown_freebsd.rs.orig 2017-10-09 20:04:51 UTC
++++ src/librustc_back/target/i686_unknown_freebsd.rs
+@@ -13,7 +13,7 @@ use target::{Target, TargetResult};
+
+ pub fn target() -> TargetResult {
+ let mut base = super::freebsd_base::opts();
+- base.cpu = "pentium4".to_string();
++ base.cpu = "pentiumpro".to_string();
+ base.max_atomic_width = Some(64);
+ base.pre_link_args.get_mut(&LinkerFlavor::Gcc).unwrap().push("-m32".to_string());
+ base.stack_probes = true;