aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-11-07 09:03:16 +0800
committerpav <pav@FreeBSD.org>2007-11-07 09:03:16 +0800
commita72af72b6fc96f128fd1122f72e5abfc90fd84a8 (patch)
tree8a0ee94d5604990f92142aa05f8d58042c9e25c7 /lang
parente5296f106f9587d2802be1e2a4bfd83031a2ba47 (diff)
downloadfreebsd-ports-gnome-a72af72b6fc96f128fd1122f72e5abfc90fd84a8.tar.gz
freebsd-ports-gnome-a72af72b6fc96f128fd1122f72e5abfc90fd84a8.tar.zst
freebsd-ports-gnome-a72af72b6fc96f128fd1122f72e5abfc90fd84a8.zip
- This port seems to need yasm on amd64 and nasm on i386
Reported by: pointyhat Approved by: portmgr (hat)
Diffstat (limited to 'lang')
-rw-r--r--lang/nwcc/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/nwcc/Makefile b/lang/nwcc/Makefile
index 7e2fc2c21e24..d51c4efbc287 100644
--- a/lang/nwcc/Makefile
+++ b/lang/nwcc/Makefile
@@ -17,15 +17,21 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= obrien@FreeBSD.org
COMMENT= Nils Weller's C compiler for Unix systems
-BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
-
ONLY_FOR_ARCHS= i386 amd64
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --installprefix=${PREFIX}
ALL_TARGET=
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
+.else
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
post-build:
cd ${WRKSRC} ; ${MAKE} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>