aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-21 16:34:26 +0800
committergahr <gahr@FreeBSD.org>2014-07-21 16:34:26 +0800
commitab5df6c8e95763a752831cf870c28977455de3ac (patch)
tree082cfb291c7aca9da346dd85d187f6aa759706f1 /lang
parent227f5230d1cad601ae47fe40046d6ecd5caa4e37 (diff)
downloadfreebsd-ports-gnome-ab5df6c8e95763a752831cf870c28977455de3ac.tar.gz
freebsd-ports-gnome-ab5df6c8e95763a752831cf870c28977455de3ac.tar.zst
freebsd-ports-gnome-ab5df6c8e95763a752831cf870c28977455de3ac.zip
- Update to 05_20140720
Changes: * The compiler has been improved to generate overflow checking code by default. The generation of overflow checking code can be switched off with the option -so. * The exception OVERFLOW_ERROR has been introduced. It is raised by the interpreter and by compiled programs when an integer overflow occurs. * A paragraph about integer overflow and the installation of Seed7 has been added to the FAQ. * The chapter about exceptions in the manual has been improved. * The program chkovf.sd7, which checks the recogition of integer overflows, has been added. * Checks for +, -, *, rem, mod, <<, +:=, -:=, *:=, succ, pred, incr and decr have been added to chkint.sd7. * Checks for the lpad operator have been added to chkstr.sd7. * The compiler option -r has been replace by the option -sr. * The program calc7.sd7 has been improved to report MEMORY_ERROR and OVERFLOW_ERROR. * The library make.s7i has been improved such that make7.sd7 accepts echo (and echo.) statements without parameters. * The function eof has been defined for the type tlsFile in tls.s7i. * The function gets in tls.s7i has been improved. * The function getHttp in gethttp.s7i has been improved to avoid an endless loop when eof has been reached. * The function memcpy_from_strelem has been added to striutl.c. This function uses loop unrolling inspired by Duff's device and a trick with a binary or (|=) to check for allowed values. * The functions filWrite, socWrite and bstParse have been changed to use memcpy_from_strelem. The reduction in runtime has been measured with gcc and valgrind. The runtime of filWrite, socWrite and bstParse has been reduced to 53%, 61% and 56% respectively. * Documentation comments have been added to integer.s7i, bin32.s7i, intlib.c and striutl.c. * The compiler has been improved to generate overflow checking code for *, <<, >>, *:=, <<:= and >>:= . * The generation of overflow checking code for the operators rem and mod has been improved. * Checks for overflow, division by zero, numeric error and index out of bounds in compiled programs now use the macros ovfChk, divChk, numChk and idxChk. This macros inform the C compiler about the unlikeliness of an exception. * The function fltIPow has been improved to avoid a signed integer overflow, when the exponent is the most negative integer. * The primitive actions INT_ULSHIFT and INT_ULSHIFT_ASSIGN have been added and supported in interpreter and compiler. * A version of the function uint_rand, which uses 128-bit integers, has been added to int_rtl.c. * The function raise_error3 in runerr.c has been renamed to interprRaiseError. * The configuration values INT128TYPE, UINT128TYPE and MACRO_DEFS have been added to cc_conf.s7i. The configuration value SIGILL_ON_OVERFLOW has been replaced with OVERFLOW_SIGNAL. * The functions constValueIsEqual, checkRangeFromZero, process_const_int_lshift, process_const_int_lshift_assign, process_const_int_rshift_assign, process_const_int_mult, process_const_int_mult_assign, process_const_int_ulshift_assign, process_const_int_ulshift and process_const_int_urshift_assign have been added to int_act.s7i. * The function intExpr in chkbig.sd7, chkexc.sd7, chkint.sd7 and chkstr.sd7 has been changed to make sure that the C compiler cannot evaluate it at compile time. * The runtime of the functions str_lpad, strLpad and strLpadTemp has been improved.
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/distinfo4
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index b9b7c3382990..d6b0670a9953 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20140706
+DISTVERSION= 05_20140720
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 9258f971c233..7ff9cac43833 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20140706.tgz) = 3c45ce5d6c766a02258f8d04ce939a8435cb07aa881ad807b8eb0cbee81f2696
-SIZE (seed7_05_20140706.tgz) = 2145580
+SHA256 (seed7_05_20140720.tgz) = 97a37c09a30dce50c65ba93f5cb66e71c091e7943e91ca7e34adfc3b94c58596
+SIZE (seed7_05_20140720.tgz) = 2208235