aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2009-12-07 00:17:29 +0800
committerbms <bms@FreeBSD.org>2009-12-07 00:17:29 +0800
commitb59d48d351ca96f2474c2b659b6d7b847768231f (patch)
tree7a1540f25015211ff93da75f952aff6d5fc187a8 /lang
parent766ec659acc20cea5fee54dc4145cbb45b55b850 (diff)
downloadfreebsd-ports-gnome-b59d48d351ca96f2474c2b659b6d7b847768231f.tar.gz
freebsd-ports-gnome-b59d48d351ca96f2474c2b659b6d7b847768231f.tar.zst
freebsd-ports-gnome-b59d48d351ca96f2474c2b659b6d7b847768231f.zip
Add new port of u++, the uC++ front-end for g++.
uC++ is an attempt to capture language-level parallelism in C++, to provide a new alternative for concurrent programming.
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/u++/Makefile55
-rw-r--r--lang/u++/distinfo3
-rw-r--r--lang/u++/pkg-descr5
-rw-r--r--lang/u++/pkg-plist70
5 files changed, 134 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 8e54f6b35d1e..c3aa7e934419 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -361,6 +361,7 @@
SUBDIR += treecc
SUBDIR += tuareg-mode.el
SUBDIR += twelf
+ SUBDIR += u++
SUBDIR += ucc
SUBDIR += vala
SUBDIR += visualworks
diff --git a/lang/u++/Makefile b/lang/u++/Makefile
new file mode 100644
index 000000000000..726b3b5fafc4
--- /dev/null
+++ b/lang/u++/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: u++
+# Date created: 5 Dec 2009
+# Whom: bms
+#
+# $FreeBSD$
+#
+
+PORTNAME= u++
+PORTVERSION= 5.7.0
+CATEGORIES= lang
+MASTER_SITES= http://plg.uwaterloo.ca/~usystem/pub/uSystem/
+EXTRACT_SUFX= .sh
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= The uSystem uC++ Compiler, a concurrent C++ extension language
+
+EXTRACT_CMD= ${SH}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= -b -e && \
+ ${TAR} xfz ${WRKDIR}/${PORTNAME}-${PORTVERSION}.tar.gz
+
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= Has not yet been ported to FreeBSD/amd64
+
+USE_GMAKE= yes
+USE_GCC= 4.2+
+MAKE_JOBS_SAFE= no
+
+CONFIGURE_TARGET= configure
+MAKE_ARGS= VENDOR=pc OS=freebsd CPU=${MACHINE_ARCH} \
+ TVENDOR=pc TOS=freebsd TCPU=${MACHINE_ARCH} \
+ MULTI=TRUE \
+ CCBUILD=${CXX} \
+ CCAPP=${CXX} \
+ INSTALLPREFIX="${PREFIX}" \
+ INSTALLINCDIR="${PREFIX}/include/u++" \
+ INSTALLLIBDIR="${PREFIX}/lib/u++" \
+ INSTALLBINDIR="${PREFIX}/bin" \
+ INSTALLMANDIR="${PREFIX}/man" \
+ INSTALLDOCDIR="${PREFIX}/share/doc"
+
+MAN1= u++.1
+
+do-configure:
+ @(cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${GMAKE} ${MAKE_ARGS} ${CONFIGURE_ARGS} ${CONFIGURE_TARGET})
+
+.include <bsd.port.pre.mk>
+
+# u++'s configure target baulks if CXX does not start with g++.
+# Force it to be defined this way if USE_GCC did nothing.
+.if ${CXX} == "c++"
+CXX= g++
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/u++/distinfo b/lang/u++/distinfo
new file mode 100644
index 000000000000..2472ca68c6d7
--- /dev/null
+++ b/lang/u++/distinfo
@@ -0,0 +1,3 @@
+MD5 (u++-5.7.0.sh) = 2c7dc30e1b5e636b8434992d54b0c0e5
+SHA256 (u++-5.7.0.sh) = cd3c1728dd2848e159f9e4110abe95f2e1917c8f5bfa9489c800b87d974d7cb0
+SIZE (u++-5.7.0.sh) = 593435
diff --git a/lang/u++/pkg-descr b/lang/u++/pkg-descr
new file mode 100644
index 000000000000..4a36b43d0768
--- /dev/null
+++ b/lang/u++/pkg-descr
@@ -0,0 +1,5 @@
+The uC++ project extends C++ with new constructs providing advanced
+control-flow including light-weight concurrency on shared-memory uni-
+and multi-processor computers running UNIX and Linux operating systems.
+
+WWW: http://plg.uwaterloo.ca/~usystem/uC++.html
diff --git a/lang/u++/pkg-plist b/lang/u++/pkg-plist
new file mode 100644
index 000000000000..f3be01f2c591
--- /dev/null
+++ b/lang/u++/pkg-plist
@@ -0,0 +1,70 @@
+bin/u++
+include/u++/fstream
+include/u++/fstream.h
+include/u++/ostream
+include/u++/ostream.h
+include/u++/uAdaptiveLock.h
+include/u++/uAlarm.h
+include/u++/uAlign.h
+include/u++/uAtomic.h
+include/u++/uBarrier.h
+include/u++/uBaseSelector.h
+include/u++/uBitSet.h
+include/u++/uBoundedBuffer.h
+include/u++/uC++.h
+include/u++/uCalendar.h
+include/u++/uCeilingQ.h
+include/u++/uCollection.h
+include/u++/uDeadlineMonotonic.h
+include/u++/uDeadlineMonotonic1.h
+include/u++/uDeadlineMonotonicStatic.h
+include/u++/uDebug.h
+include/u++/uDebuggerAPI.h
+include/u++/uDefault.h
+include/u++/uEHM.h
+include/u++/uFile.h
+include/u++/uFilebuf.h
+include/u++/uFlexArray.h
+include/u++/uFuture.h
+include/u++/uHeap.h
+include/u++/uHeapQ.h
+include/u++/uIOcntl.h
+include/u++/uKernelThreads.h
+include/u++/uLifoScheduler.h
+include/u++/uLocalDebugger.h
+include/u++/uPIHeap.h
+include/u++/uPoll.h
+include/u++/uProfiler.h
+include/u++/uQueue.h
+include/u++/uRWLock.h
+include/u++/uRealTime.h
+include/u++/uSelector.h
+include/u++/uSemaphore.h
+include/u++/uSequence.h
+include/u++/uSocket.h
+include/u++/uStack.h
+include/u++/uStaticAssert.h
+include/u++/uStaticPIQ.h
+include/u++/uStaticPriorityQ.h
+include/u++/uSystemTask.h
+include/u++/uWaitQueue.h
+include/u++/unwind-cxx.h
+include/u++/unwind.h
+lib/u++/cc1plus
+lib/u++/u++-cpp
+lib/u++/uDefaultProcessors-OpenMP.o
+lib/u++/uKernel-d.a
+lib/u++/uKernel-m-d.a
+lib/u++/uKernel-m.a
+lib/u++/uKernel.a
+lib/u++/uLibrary-d.a
+lib/u++/uLibrary-m-d.a
+lib/u++/uLibrary-m.a
+lib/u++/uLibrary.a
+lib/u++/uLocalDebugger-d.a
+lib/u++/uLocalDebugger-m-d.a
+lib/u++/uProfilerFunctionPointers.o
+lib/u++/uScheduler-d.a
+lib/u++/uScheduler-m-d.a
+lib/u++/uScheduler-m.a
+lib/u++/uScheduler.a