aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-28 05:14:39 +0800
committeredwin <edwin@FreeBSD.org>2005-12-28 05:14:39 +0800
commitb955ba9b0e7b216f7d987070df27be27e1c0ee83 (patch)
treeec63520b0d250d50446a0d39de72db07429e01ea /lang
parentbdf606b4be8fd55dd3e3d8eb28f8f37c7d576a7d (diff)
downloadfreebsd-ports-gnome-b955ba9b0e7b216f7d987070df27be27e1c0ee83.tar.gz
freebsd-ports-gnome-b955ba9b0e7b216f7d987070df27be27e1c0ee83.tar.zst
freebsd-ports-gnome-b955ba9b0e7b216f7d987070df27be27e1c0ee83.zip
[New ports] devel/mimir, lang/elan - Elan Programming Language
Elan is a programming language originally developed by the Technical University of Berlin, but nowadays an implementation is maintained by the Radboud University of Nijmegen. We at TCCN learn youngsters how to program in this language. We installed FreeBSD on one of our SPARC's some time ago, but Elan wasn't in the Ports tree yet. That's why I made two ports. One for lang/elan, the Elan compiler, and one for devel/mimir, a library the Elan compiler uses. More info about Elan: http://en.wikipedia.org/wiki/Elan_programming_language PR: ports/89275 Submitted by: Ed Schouten <ed@fxq.nl>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/elan/Makefile39
-rw-r--r--lang/elan/distinfo3
-rw-r--r--lang/elan/files/patch-docs22
-rw-r--r--lang/elan/pkg-descr13
-rw-r--r--lang/elan/pkg-plist27
6 files changed, 105 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 6433c96f5cf6..62f77fc01e3e 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -37,6 +37,7 @@
SUBDIR += ecl
SUBDIR += egcs
SUBDIR += eiffel
+ SUBDIR += elan
SUBDIR += elisp-manual
SUBDIR += elk
SUBDIR += emacs-lisp-intro
diff --git a/lang/elan/Makefile b/lang/elan/Makefile
new file mode 100644
index 000000000000..02b9bc511565
--- /dev/null
+++ b/lang/elan/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: elan
+# Date created: 19 Nov 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elan
+PORTVERSION= 1.7b
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.cs.ru.nl/pub/vb/
+DISTNAME= ${PORTNAME}-1.7-beta
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Compiler for the Elan Programming Environment
+
+LIB_DEPENDS= dcg:${PORTSDIR}/devel/mimir
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.7
+
+MAN1= elancc.1
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_AUTOTOOLS= libtool:13:inc
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manuals/compiler/comp.ps \
+ ${DOCSDIR}/elan-compiler.ps
+ ${INSTALL_DATA} ${WRKSRC}/manuals/language/elan.ps \
+ ${DOCSDIR}/elan-language.ps
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/elan/distinfo b/lang/elan/distinfo
new file mode 100644
index 000000000000..db261ccb7561
--- /dev/null
+++ b/lang/elan/distinfo
@@ -0,0 +1,3 @@
+MD5 (elan-1.7-beta.tar.gz) = 22fa3d626ada071802a2a114fe4a12a9
+SHA256 (elan-1.7-beta.tar.gz) = 0830c9f38a4446f028a28744f93fcb52d1bc96be13d383414236f1f99caddc5b
+SIZE (elan-1.7-beta.tar.gz) = 441339
diff --git a/lang/elan/files/patch-docs b/lang/elan/files/patch-docs
new file mode 100644
index 000000000000..5288a3568634
--- /dev/null
+++ b/lang/elan/files/patch-docs
@@ -0,0 +1,22 @@
+--- manuals/compiler/Makefile.in Thu May 19 17:52:40 2005
++++ manuals/compiler/Makefile.in Fri Nov 25 23:31:03 2005
+@@ -221,7 +221,7 @@
+
+ info-am:
+
+-install-data-am: install-docDATA
++install-data-am:
+
+ install-exec-am:
+
+--- manuals/language/Makefile.in Thu May 19 17:52:39 2005
++++ manuals/language/Makefile.in Fri Nov 25 23:30:54 2005
+@@ -217,7 +217,7 @@
+
+ info-am:
+
+-install-data-am: install-docDATA
++install-data-am:
+
+ install-exec-am:
+
diff --git a/lang/elan/pkg-descr b/lang/elan/pkg-descr
new file mode 100644
index 000000000000..30d0531b70b4
--- /dev/null
+++ b/lang/elan/pkg-descr
@@ -0,0 +1,13 @@
+Elan is an educational programming language for learning and teaching
+systematic programming.
+
+It was developed in 1974 by a group at the Technical University of
+Berlin as an alternative to BASIC in teaching, and approved for use in
+secondary schools in Germany by the "Arbeitskreis Schulsprache". It is
+presently in use in a number of schools in Western Germany, Belgium, The
+Netherlands and Hungary for informatics teaching in secondary education,
+and used at the Radboud University Nijmegen in the Netherlands for
+teaching systematic programming to students from various disciplines and
+in teacher courses.
+
+WWW: http://www.cs.ru.nl/elan/
diff --git a/lang/elan/pkg-plist b/lang/elan/pkg-plist
new file mode 100644
index 000000000000..f0cdd048d53b
--- /dev/null
+++ b/lang/elan/pkg-plist
@@ -0,0 +1,27 @@
+bin/elancc
+bin/mktests
+include/rts_alloc.h
+include/rts_error.h
+include/rts_files.h
+include/rts_init.h
+include/rts_ints.h
+include/rts_random.h
+include/rts_reals.h
+include/rts_system.h
+include/rts_term.h
+include/rts_texts.h
+lib/liberts.a
+lib/liberts.so
+lib/liberts.so.1
+%%DATADIR%%/prelude/elan0.ppe
+%%DATADIR%%/prelude/kareltje.ppe
+%%DATADIR%%/prelude/standard.ppe
+%%DATADIR%%/src/elan0.e
+%%DATADIR%%/src/kareltje.e
+%%DATADIR%%/src/standard.e
+@dirrm %%DATADIR%%/prelude
+@dirrm %%DATADIR%%/src
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/elan-compiler.ps
+%%PORTDOCS%%%%DOCSDIR%%/elan-language.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%