aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-07 18:39:25 +0800
committermarino <marino@FreeBSD.org>2013-11-07 18:39:25 +0800
commitc32a9d9d8ceaeed93b4b9a8ed58dd0d474dd6094 (patch)
tree5bdc7d5cb91c147a19a2c0ecd7bf32dd61de9be0 /lang
parent1c8e2e7cff427b1c3f99658bfd80c33f315a05d2 (diff)
downloadfreebsd-ports-gnome-c32a9d9d8ceaeed93b4b9a8ed58dd0d474dd6094.tar.gz
freebsd-ports-gnome-c32a9d9d8ceaeed93b4b9a8ed58dd0d474dd6094.tar.zst
freebsd-ports-gnome-c32a9d9d8ceaeed93b4b9a8ed58dd0d474dd6094.zip
lang/gnatdroid-binutils: Remove USE_GCC=yes
A pkg-fallout notice was received for gnatdroid, saying that lang/gcc and lang/gnatdroid-* were installing files in the same place. It turns out that gnatdroid-binutils was pulling lang/gcc in unnecessarily. With --disable-werror, it builds on clang on F10 just fine. While here, convert USE_GMAKE too. Soon all gnat* ports will be updated with the latest for ports, this is just a stop-gap fix.
Diffstat (limited to 'lang')
-rw-r--r--lang/gnatdroid-binutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/gnatdroid-binutils/Makefile b/lang/gnatdroid-binutils/Makefile
index 3342113857d4..478b24b0d018 100644
--- a/lang/gnatdroid-binutils/Makefile
+++ b/lang/gnatdroid-binutils/Makefile
@@ -16,9 +16,8 @@ BUILD_DEPENDS= gnatdroid-sysroot>=9:${PORTSDIR}/lang/gnatdroid-sysroot \
${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= gmake
USE_BZIP2= YES
-USE_GCC= any
-USE_GMAKE= YES
HAS_CONFIGURE= YES
NO_MTREE= YES
@@ -38,6 +37,7 @@ CONFIGURE_ARGS+= --prefix=${BR1_PREFIX}
CONFIGURE_ARGS+= --with-sysroot=${PREFIX}
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
CONFIGURE_ARGS+= --with-mpfr=${LOCALBASE}
+CONFIGURE_ARGS+= --disable-werror
CONFIGURE_ARGS+= --disable-nls
NO_STAGE= yes