aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-03-07 17:54:34 +0800
committergahr <gahr@FreeBSD.org>2013-03-07 17:54:34 +0800
commitce12e557df357cc4bf14e6b71ed7f55d672e351e (patch)
tree906bf8a488d48a6e7754ec39ea6f8673dfa56a5d /lang
parent66a2204fce489bcda7ca91fd2bfcd8a53e9498c9 (diff)
downloadfreebsd-ports-gnome-ce12e557df357cc4bf14e6b71ed7f55d672e351e.tar.gz
freebsd-ports-gnome-ce12e557df357cc4bf14e6b71ed7f55d672e351e.tar.zst
freebsd-ports-gnome-ce12e557df357cc4bf14e6b71ed7f55d672e351e.zip
- Update to 05_20130303
Changes: * The library editline.s7i has been added. This library defines a file type for linewise editing with history. * The manual chapter describing types, especially the type program, has been improved. * The calc.sd7 example has been improved to allow linewise editing. * The handling of the internal program representation in interpreter and compiler has been improved to free most unused memory. * The handling of the functions prgGlobalObjects, refArrToList, refHshDataToList, refHshKeyToList, refLocalVars and refSctToList in compiler and run-time library has been improved to free unused memory. * The stack trace has been improved to display infix operators better and to write parameter names. * The compiler has been improved to support the action TYP_FUNC. * The functions copy_expression and free_expression in listutl.c have been optimized. * The function substitute_params has been added to match.c . * The functions free_params and free_name_list have been added to name.c . * The function dump_list has been added to objutl.c . * The function copy_params has been added to entutl.c . * The functions prot_float and prot_params have been added to traceutl.c . * The functions free_type and close_type have been added to typeutl.c . * The free list management has been improved to be configurable in config.h. * The memory management in heaputl.h has been improved to work with and without DO_HEAPSIZE_COMPUTATION. * The function free_file and remove_prog_files have been added to infile.c. * The functions itf_cpy and itf_cpy2 in itflib.c have been improved to support assigning forward declared objects to an interface. * The function emptylist and the macro to_empty_list have been renamed to free_list and free_list2. * In prg_comp.c the function prgDeclObjects has been renamed to prgGlobalObjects. * In ref_data.c the functions refArrmaxidx, refArrminidx, refArrtolist, refScttolist and refHshKeyToList have been renamed to refArrMaxIdx, refArrMinIdx, refArrToList, refSctToList and refHshKeysToList. * In ref_data.c the functions refResult, refResini and refSetParams have been improved to raise RANGE_ERROR when the argument is NULL or when it is not a BLOCKOBJECT. * In progs.s7i the functions sys_var, error_count, declared_objects, params, setParams, func_result, func_res_init, local_consts, local_vars, array_to_list, array_min_index, array_max_index, struct_to_list, hash_data_to_list, hash_key_to_list, interface_to_struct, obj_number, type_number and match_obj have been renamed to sysVar errorCount, globalObjects, formalParams, setFormalParams, resultVar, resultInitValue, localConsts, localVars, arrayToList, arrayMinIdx, arrayMaxIdx, structToList, hashDataToList, hashKeysToList, interfaceToStruct, objNumber, typeNumber and typeObject. * In seed7_05.s7i the functions is_func, is_varfunc, result_type and is_derived have been renamed to isFunc, isVarfunc, resultType and isDerived.
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/pkg-plist1
3 files changed, 4 insertions, 3 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 62278f7adca8..fc468917b680 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20130217
+DISTVERSION= 05_20130303
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index bc75c8bde4f3..21fabdd492a5 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20130217.tgz) = d1a432165c4f26999a33458c5adca9e051b49c9dc65e0e7bb62d4415e6026a57
-SIZE (seed7_05_20130217.tgz) = 1832237
+SHA256 (seed7_05_20130303.tgz) = c00329a68deb1a4ee4b8fbef0e5cd98e74a63a25536ff08ef4a1b15486f9c62b
+SIZE (seed7_05_20130303.tgz) = 1838898
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index 068d73c6d5aa..e72397c4f051 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -32,6 +32,7 @@ lib/seed7/lib/dir.s7i
lib/seed7/lib/draw.s7i
lib/seed7/lib/duration.s7i
lib/seed7/lib/echo.s7i
+lib/seed7/lib/editline.s7i
lib/seed7/lib/enable_input.s7i
lib/seed7/lib/enable_io.s7i
lib/seed7/lib/enable_output.s7i