aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-09-15 18:48:36 +0800
committerolgeni <olgeni@FreeBSD.org>2015-09-15 18:48:36 +0800
commitdbf6131eb6e6eaf5d01f63b797fb839cfc368847 (patch)
tree1b6a166aa4365e9c857c98eb1b5640a579a1f1b3 /lang
parentb701808343d05f30779f9f1d0ae0ab63a61229e1 (diff)
downloadfreebsd-ports-gnome-dbf6131eb6e6eaf5d01f63b797fb839cfc368847.tar.gz
freebsd-ports-gnome-dbf6131eb6e6eaf5d01f63b797fb839cfc368847.tar.zst
freebsd-ports-gnome-dbf6131eb6e6eaf5d01f63b797fb839cfc368847.zip
- Switch to options helpers
- Add missing files to plist (THREADS option) PR: 203051 Submitted by: amdmi3
Diffstat (limited to 'lang')
-rw-r--r--lang/ecl/Makefile71
-rw-r--r--lang/ecl/pkg-plist53
2 files changed, 79 insertions, 45 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 57b5e3a472c0..f570fc468396 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ecl
PORTVERSION= 15.3.7
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/15.3/
@@ -33,53 +34,33 @@ DFFI_DESC= Dynamic foreign-function support
OPTIONS_SUB= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ${ARCH}
-.endif
-
-.if ${PORT_OPTIONS:MASDF}
-CONFIGURE_ARGS+=--with-asdf=yes
-.else
-CONFIGURE_ARGS+=--with-asdf=no
-.endif
-
-.if ${PORT_OPTIONS:MCLX}
-USE_XORG= x11
-CONFIGURE_ARGS+=--with-clx=yes
-.else
-CONFIGURE_ARGS+=--with-clx=no
-.endif
-
-.if ${PORT_OPTIONS:MSOCKETS}
-CONFIGURE_ARGS+=--with-tcp=yes
-.else
-CONFIGURE_ARGS+=--with-tcp=no
-.endif
-
-.if ${PORT_OPTIONS:MDFFI}
-CONFIGURE_ARGS+=--with-dffi=system
-LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
-.else
-CONFIGURE_ARGS+=--with-dffi=no
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+=--enable-threads=yes
-LDFLAGS+= -lpthread
-LIB_DEPENDS+= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
-.else
-CONFIGURE_ARGS+=--enable-threads=no
-LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-post-patch:
+BROKEN_ia64= does not compile
+BROKEN_sparc64= does not compile
+
+ASDF_CONFIGURE_ON= --with-asdf=yes
+ASDF_CONFIGURE_OFF= --with-asdf=no
+
+CLX_USE= XORG=x11
+CLX_CONFIGURE_ON= --with-clx=yes
+CLX_CONFIGURE_OFF= --with-clx=no
+
+SOCKETS_CONFIGURE_ON= --with-tcp=yes
+SOCKETS_CONFIGURE_OFF= --with-tcp=no
+
+DFFI_LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+DFFI_CONFIGURE_ON= --with-dffi=system
+DFFI_CONFIGURE_OFF= --with-dffi=no
+
+THREADS_CONFIGURE_ON= --enable-threads=yes
+THREADS_LDFLAGS= -lpthread
+THREADS_LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
+THREADS_CONFIGURE_OFF= --enable-threads=no
+THREADS_LIB_DEPENDS_OFF= libgc.so:${PORTSDIR}/devel/boehm-gc
+
+post-patch-THREADS-on:
@${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' ${WRKSRC}/src/configure
-.endif
post-install:
${RMDIR} ${STAGEDIR}${PREFIX}/include/ecl/gc/private
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/ecl/pkg-plist b/lang/ecl/pkg-plist
index 0d3d0cee95f5..e6bddaa92571 100644
--- a/lang/ecl/pkg-plist
+++ b/lang/ecl/pkg-plist
@@ -1,5 +1,57 @@
bin/ecl
bin/ecl-config
+%%THREADS%%include/ecl/atomic_ops.h
+%%THREADS%%include/ecl/atomic_ops/generalize-small.h
+%%THREADS%%include/ecl/atomic_ops/generalize.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/acquire_release_volatile.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/aligned_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/all_acquire_release_volatile.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/all_aligned_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/all_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/ao_t_is_int.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/armcc/arm_v6.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/char_acquire_release_volatile.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/char_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/emul_cas.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/alpha.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/arm.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/avr32.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/cris.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/hppa.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/ia64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/m68k.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/mips.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/powerpc.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/s390.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/sh.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/sparc.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/x86.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/gcc/x86_64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/generic_pthread.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/hpc/hppa.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/hpc/ia64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/ibmc/powerpc.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/icc/ia64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/int_acquire_release_volatile.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/int_aligned_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/int_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/msftc/arm.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/msftc/common32_defs.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/msftc/x86.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/msftc/x86_64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/ordered.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/ordered_except_wr.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/read_ordered.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/short_acquire_release_volatile.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/short_aligned_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/short_atomic_load_store.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/standard_ao_double_t.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/sunc/sparc.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/sunc/x86.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/sunc/x86_64.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/test_and_set_t_is_ao_t.h
+%%THREADS%%include/ecl/atomic_ops/sysdeps/test_and_set_t_is_char.h
include/ecl/bytecodes.h
include/ecl/cache.h
include/ecl/config.h
@@ -233,3 +285,4 @@ lib/libecl.so.15.3
lib/libecl.so.15.3.7
man/man1/ecl-config.1.gz
man/man1/ecl.1.gz
+@dir include/ecl/gc