aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-12-22 11:39:02 +0800
committerdanfe <danfe@FreeBSD.org>2016-12-22 11:39:02 +0800
commit057b0861aa9760aad6e8946c81acd5c4379ddf12 (patch)
tree5fafe1873404eb235a55f6586deebc3c6d4d2ab2 /lang
parent94ba4ee4ffdabd00f18d06af36b3e7a846e66b46 (diff)
downloadfreebsd-ports-gnome-057b0861aa9760aad6e8946c81acd5c4379ddf12.tar.gz
freebsd-ports-gnome-057b0861aa9760aad6e8946c81acd5c4379ddf12.tar.zst
freebsd-ports-gnome-057b0861aa9760aad6e8946c81acd5c4379ddf12.zip
Relax condition to pull GCC from ports which was added in r417665 to fix
the build specifically on powerpc64, while the check included both 32-bit and 64-bit PowerPC. While here, drop rudimentary support for ia64 which is long unsupported in base (and hardly ever was in ports). Tested on: Mac mini G4
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby21/Makefile5
-rw-r--r--lang/ruby22/Makefile5
-rw-r--r--lang/ruby23/Makefile5
3 files changed, 3 insertions, 12 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index ba06e866a7df..498f219dc6e4 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -46,9 +46,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not build
-
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -96,7 +93,7 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
-.if (${ARCH} == "powerpc64" || ${ARCH} == "powerpc")
+.if ${ARCH} == "powerpc64"
USE_GCC= yes
.endif
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 6a837ce8876b..0cce7b728aae 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -47,9 +47,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not build
-
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -101,7 +98,7 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
-.if ${ARCH} == "powerpc" || ${ARCH} == "powerpc64"
+.if ${ARCH} == "powerpc64"
USE_GCC= yes
.endif
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 01089668668f..50951215d708 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -45,9 +45,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not build
-
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -95,7 +92,7 @@ CONFIGURE_ARGS+=--disable-dtrace
.endif
.endif
-.if (${ARCH} == "powerpc64" || ${ARCH} == "powerpc")
+.if ${ARCH} == "powerpc64"
USE_GCC= yes
.endif