aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-03-24 19:28:57 +0800
committerstas <stas@FreeBSD.org>2010-03-24 19:28:57 +0800
commit3830d0c5379c0645fe1c83c93e86fd4119b821c7 (patch)
treee69ed9b3ca1b7ea3b0d3c66517637f18697d5df6 /lang
parent516deacad03f3b2f07d665fafcf8376451065ab5 (diff)
downloadfreebsd-ports-gnome-3830d0c5379c0645fe1c83c93e86fd4119b821c7.tar.gz
freebsd-ports-gnome-3830d0c5379c0645fe1c83c93e86fd4119b821c7.tar.zst
freebsd-ports-gnome-3830d0c5379c0645fe1c83c93e86fd4119b821c7.zip
- Add lang/ocaml-autoconf, ocaml macros module for autoconf.
WWW: http://forge.ocamlcore.org/projects/ocaml-autoconf/
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ocaml-autoconf/Makefile36
-rw-r--r--lang/ocaml-autoconf/distinfo3
-rw-r--r--lang/ocaml-autoconf/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index da6d74af0fdb..047d7061bf31 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -194,6 +194,7 @@
SUBDIR += nwcc
SUBDIR += objc
SUBDIR += ocaml
+ SUBDIR += ocaml-autoconf
SUBDIR += ocaml-camlidl
SUBDIR += ocaml-doc
SUBDIR += ocaml-examples
diff --git a/lang/ocaml-autoconf/Makefile b/lang/ocaml-autoconf/Makefile
new file mode 100644
index 000000000000..435677e7b768
--- /dev/null
+++ b/lang/ocaml-autoconf/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ocaml.m4
+# Date created: 24 Marth 2010
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoconf
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/181/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Autoconf module for ocaml
+
+NO_BUILD= yes
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+AC_SUBDIR= ${PREFIX}/share/aclocal
+PLIST_FILES= share/aclocal/ocaml.m4
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ocaml.m4.txt
+.endif
+
+do-install:
+ ${MKDIR} ${AC_SUBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ocaml.m4 ${AC_SUBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ocaml.m4.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/ocaml-autoconf/distinfo b/lang/ocaml-autoconf/distinfo
new file mode 100644
index 000000000000..bb72810e4a36
--- /dev/null
+++ b/lang/ocaml-autoconf/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocaml-autoconf-1.0.tar.gz) = 2eab5efad4364d2f0114f38e00af09ac
+SHA256 (ocaml-autoconf-1.0.tar.gz) = 67e85520f65c033c86e99e5438e51657e777579034570527c1b2c62096ecb004
+SIZE (ocaml-autoconf-1.0.tar.gz) = 11337
diff --git a/lang/ocaml-autoconf/pkg-descr b/lang/ocaml-autoconf/pkg-descr
new file mode 100644
index 000000000000..5a9e4acef883
--- /dev/null
+++ b/lang/ocaml-autoconf/pkg-descr
@@ -0,0 +1,4 @@
+This port contains standard, useful autoconf macros for detecting
+OCaml, findlib, OCaml packages, etc.
+
+WWW: http://forge.ocamlcore.org/projects/ocaml-autoconf/