aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-08-06 01:46:58 +0800
committergerald <gerald@FreeBSD.org>2012-08-06 01:46:58 +0800
commit516254be8ebadd406fec93283f5692669d81e9c6 (patch)
tree7ead6b93e5fcdb902480788582792a2c9b070646 /lang
parent01ff038266f291bd2fcb5c417bfce75bfeff459a (diff)
downloadfreebsd-ports-gnome-516254be8ebadd406fec93283f5692669d81e9c6.tar.gz
freebsd-ports-gnome-516254be8ebadd406fec93283f5692669d81e9c6.tar.zst
freebsd-ports-gnome-516254be8ebadd406fec93283f5692669d81e9c6.zip
Remove ABI version numbers for all library dependencies.
Just build, do not bootstrap, this obsolete and frozen version of GCC.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc44/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 511d3dbfc346..682dbda59121 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -16,8 +16,8 @@ MASTER_SITE_SUBDIR= releases/gcc-${VERSIONSTRING}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.4
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.4:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
+ mpfr:${PORTSDIR}/math/mpfr
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
DEPRECATED= Superseded by GCC 4.6, only kept for the sake of cad/salome
@@ -52,7 +52,8 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+=--disable-nls \
+CONFIGURE_ARGS+=--disable-bootstrap \
+ --disable-nls \
--enable-languages=c,c++,fortran \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
@@ -65,7 +66,6 @@ CONFIGURE_ARGS+=--disable-nls \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VER=${PORTVERSION} \
GNU_HOST=${CONFIGURE_TARGET} \