aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-11-24 18:19:22 +0800
committergerald <gerald@FreeBSD.org>2015-11-24 18:19:22 +0800
commit65f56e6f67550ba6d7af4c5e6b57132920e1feae (patch)
tree07237680e4a51de60f32a05aaa4af2268c7c4a5a /lang
parent2c53bec88f2c6ab5a3cd9f6f338d232f003a7cfb (diff)
downloadfreebsd-ports-gnome-65f56e6f67550ba6d7af4c5e6b57132920e1feae.tar.gz
freebsd-ports-gnome-65f56e6f67550ba6d7af4c5e6b57132920e1feae.tar.zst
freebsd-ports-gnome-65f56e6f67550ba6d7af4c5e6b57132920e1feae.zip
This being the generic GCC port, add gfortran, gcc, and g++ as links
to the versioned executable (gfortran48, gcc48, and g++48). These standard names are going to remain in place in case of version upgrades and constitute the default, and expected by users, names. Suggested by: db Reviewed by: db
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile7
-rw-r--r--lang/gcc/pkg-plist3
2 files changed, 9 insertions, 1 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index a82fa39a5169..8454d669e310 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gcc
PORTVERSION= 4.8.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
@@ -168,5 +168,10 @@ post-stage:
fi
.endfor
cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
+ # This is the canonical GCC port, so add key commands without
+ # version numbers as part of their names.
+ for c in gfortran g++ gcc; do \
+ ${LN} -s ${PREFIX}/bin/"$$c"${SUFFIX} ${STAGEDIR}${PREFIX}/bin/$$c ; \
+ done
.include <bsd.port.post.mk>
diff --git a/lang/gcc/pkg-plist b/lang/gcc/pkg-plist
index 48abb32af995..7c29e96d6ccf 100644
--- a/lang/gcc/pkg-plist
+++ b/lang/gcc/pkg-plist
@@ -8,12 +8,15 @@ bin/%%GNU_HOST%%-gcc-ranlib%%SUFFIX%%
bin/%%GNU_HOST%%-gfortran%%SUFFIX%%
bin/c++%%SUFFIX%%
bin/cpp%%SUFFIX%%
+bin/g++
bin/g++%%SUFFIX%%
+bin/gcc
bin/gcc%%SUFFIX%%
bin/gcc-ar%%SUFFIX%%
bin/gcc-nm%%SUFFIX%%
bin/gcc-ranlib%%SUFFIX%%
bin/gcov%%SUFFIX%%
+bin/gfortran
bin/gfortran%%SUFFIX%%
@comment info/gcc%%SUFFIX%%/dir
man/man1/cpp%%SUFFIX%%.1.gz