aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-03 12:06:37 +0800
committerrm <rm@FreeBSD.org>2012-10-03 12:06:37 +0800
commit6f674bcdc5383769b9eb619b34b60745e11d2201 (patch)
treee11a6a0035871aefd6af86b776e5520e17331523 /lang
parent6d5c8d72f359e2ddb6ce36954ac54025000e9cd5 (diff)
downloadfreebsd-ports-gnome-6f674bcdc5383769b9eb619b34b60745e11d2201.tar.gz
freebsd-ports-gnome-6f674bcdc5383769b9eb619b34b60745e11d2201.tar.zst
freebsd-ports-gnome-6f674bcdc5383769b9eb619b34b60745e11d2201.zip
- do not hardcode distfile extension for lang/python ports in bsd.python.mk
(PYTHON_DISTFILE variable) - switch lang/python ports (and it's slaves) to tar.xz I compared all the four pairs .tgz/.tar.xz and they have no content differences. Discussed on: python@
Diffstat (limited to 'lang')
-rw-r--r--lang/python26/Makefile1
-rw-r--r--lang/python26/distinfo4
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python27/distinfo4
-rw-r--r--lang/python31/Makefile1
-rw-r--r--lang/python31/distinfo4
-rw-r--r--lang/python32/Makefile1
-rw-r--r--lang/python32/distinfo4
8 files changed, 12 insertions, 8 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 40779f1958c2..2adcaa387949 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -29,6 +29,7 @@ INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
+USE_XZ= yes
PYTHON_VERSION= python2.6
PYTHON_NO_DEPENDS= yes
diff --git a/lang/python26/distinfo b/lang/python26/distinfo
index bd2548b4586f..91a474c49ac8 100644
--- a/lang/python26/distinfo
+++ b/lang/python26/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-2.6.8.tgz) = 5bf02a75ffa2fcaa5a3cabb8201998519b045541975622316888ea468d9512f7
-SIZE (python/Python-2.6.8.tgz) = 13282574
+SHA256 (python/Python-2.6.8.tar.xz) = 39c5fd7c66d57a09e739605e64a4bba7552e1a094dd4ce062a207095011b80ac
+SIZE (python/Python-2.6.8.tar.xz) = 9331140
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 54c9d1f4c9b4..cc09a246266c 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -29,6 +29,7 @@ INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
+USE_XZ= yes
PYTHON_VERSION= python2.7
PYTHON_NO_DEPENDS= yes
diff --git a/lang/python27/distinfo b/lang/python27/distinfo
index 7afacc30a8a2..e1fb6fdb7b8a 100644
--- a/lang/python27/distinfo
+++ b/lang/python27/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-2.7.3.tgz) = d4c20f2b5faf95999fd5fecb3f7d32071b0820516224a6d2b72932ab47a1cb8e
-SIZE (python/Python-2.7.3.tgz) = 14135620
+SHA256 (python/Python-2.7.3.tar.xz) = 61d36be58e9e9c733c49d7b76858d5c08e2c63a84f2066b29d35d3521057c985
+SIZE (python/Python-2.7.3.tar.xz) = 9976088
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 45fcafac8be2..59c32c55ffea 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -29,6 +29,7 @@ INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
+USE_XZ= yes
PYTHON_VERSION= python3.1
PYTHON_NO_DEPENDS= yes
diff --git a/lang/python31/distinfo b/lang/python31/distinfo
index 50c26d2f7310..a5401edf81a1 100644
--- a/lang/python31/distinfo
+++ b/lang/python31/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.1.5.tgz) = d12dae6d06f52ef6bf1271db4d5b4d14b5dd39813e324314e72b648ef1bc0103
-SIZE (python/Python-3.1.5.tgz) = 11798798
+SHA256 (python/Python-3.1.5.tar.xz) = 035c4370354d901924ce0fd8df65c5452839f590ec1b9c17fae2ada3e5f3b4d7
+SIZE (python/Python-3.1.5.tar.xz) = 8189536
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 1aae5c8de8e6..4481c47ad18c 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -29,6 +29,7 @@ INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
+USE_XZ= yes
PYTHON_VERSION= python3.2
PYTHON_NO_DEPENDS= yes
diff --git a/lang/python32/distinfo b/lang/python32/distinfo
index a65cb59f4ed8..043ed0ebe068 100644
--- a/lang/python32/distinfo
+++ b/lang/python32/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.2.3.tgz) = 74c33e165edef7532cef95fd9a325a06878b5bfc8a5d038161573f283eaf9809
-SIZE (python/Python-3.2.3.tgz) = 12787688
+SHA256 (python/Python-3.2.3.tar.xz) = 23c16f621f21e54987079765c060196cbe50235c7867147c6126d433054b1754
+SIZE (python/Python-3.2.3.tar.xz) = 8970368