aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
committermarino <marino@FreeBSD.org>2015-12-29 20:03:09 +0800
commit94df420314debf3fec0a6105e780348971b92ee9 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang
parentdf0b968b2dabb212c7d939f45dd10f5af3fefd84 (diff)
downloadfreebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.gz
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.tar.zst
freebsd-ports-gnome-94df420314debf3fec0a6105e780348971b92ee9.zip
lang/python27(3*), Mk/Uses/python.mk: remove make spawn
There are some inefficiencies in python.mk that significantly slow down full tree scanning. The use of bmake to obtain the current version of a specific python is responsible for the majority of the slow done. This commit splits out the PYTHON_PORTVERSION definition (which is the same as the lang/python* PORTVERSION) into separate files. With this change, python.mk can simple include the makefile fragment instead of spawning a new instance of make. Different Revision: https://reviews.freebsd.org/D4660 Approved by: antoine (python), mva (python)
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile3
-rw-r--r--lang/python27/Makefile.version4
-rw-r--r--lang/python32/Makefile3
-rw-r--r--lang/python32/Makefile.version4
-rw-r--r--lang/python33/Makefile3
-rw-r--r--lang/python33/Makefile.version4
-rw-r--r--lang/python34/Makefile3
-rw-r--r--lang/python34/Makefile.version4
-rw-r--r--lang/python35/Makefile6
-rw-r--r--lang/python35/Makefile.version4
10 files changed, 31 insertions, 7 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d8b9a506c915..70190f5185ab 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python27
-PORTVERSION= 2.7.11
+PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -73,6 +73,7 @@ THREADS_LDFLAGS= -lpthread
UCS2_CONFIGURE_ON= --enable-unicode=ucs2
UCS4_CONFIGURE_ON= --enable-unicode=ucs4
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
# http://bugs.python.org/issue22521
diff --git a/lang/python27/Makefile.version b/lang/python27/Makefile.version
new file mode 100644
index 000000000000..88ff2ad0d784
--- /dev/null
+++ b/lang/python27/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 2.7.11
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8db7f8ed4e89..43f045754cb2 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python32
-PORTVERSION= 3.2.6
+PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -71,6 +71,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
UCS4_CONFIGURE_WITH= wide-unicode
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUCS4}
diff --git a/lang/python32/Makefile.version b/lang/python32/Makefile.version
new file mode 100644
index 000000000000..681b086322df
--- /dev/null
+++ b/lang/python32/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.2.6
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 813cff0387b7..e49c1f9d9b1d 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python33
-PORTVERSION= 3.3.6
+PORTVERSION= ${PYTHON_PORTVERSION}
PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
@@ -73,6 +73,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python33/Makefile.version b/lang/python33/Makefile.version
new file mode 100644
index 000000000000..0f10704423bd
--- /dev/null
+++ b/lang/python33/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.3.6
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 82620cc2d7d8..d279ade79085 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= python34
-PORTVERSION= 3.4.3
+PORTVERSION= ${PYTHON_PORTVERSION}
PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
@@ -82,6 +82,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python34/Makefile.version b/lang/python34/Makefile.version
new file mode 100644
index 000000000000..cc944e6b251c
--- /dev/null
+++ b/lang/python34/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.4.3
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 097fa497756f..1aa52fa5ae8a 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= python
-DISTVERSION= 3.5.1
+DISTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON/ftp/python/${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
@@ -24,7 +24,6 @@ CPE_PRODUCT= ${CPE_VENDOR}
CPE_VERSION= ${DISTVERSION}
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_PORTVERSION= ${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
PYTHON_VER= ${PYTHON_PORTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -89,6 +88,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python35/Makefile.version b/lang/python35/Makefile.version
new file mode 100644
index 000000000000..bc8460896a75
--- /dev/null
+++ b/lang/python35/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.5.1