aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-01 21:26:35 +0800
committerpawel <pawel@FreeBSD.org>2014-06-01 21:26:35 +0800
commit9fb874e0889646110c3faf90ce028d2008349d46 (patch)
treec930e4c5f1b647fe5949c89856d02b4c7c7f42e2 /lang
parent04a670a7b25194565a2a0f54ae5646196d9991f0 (diff)
downloadfreebsd-ports-gnome-9fb874e0889646110c3faf90ce028d2008349d46.tar.gz
freebsd-ports-gnome-9fb874e0889646110c3faf90ce028d2008349d46.tar.zst
freebsd-ports-gnome-9fb874e0889646110c3faf90ce028d2008349d46.zip
Add staging support
Diffstat (limited to 'lang')
-rw-r--r--lang/sather-specification/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/sather-specification/Makefile b/lang/sather-specification/Makefile
index 4d853cfabe66..653f73785ff7 100644
--- a/lang/sather-specification/Makefile
+++ b/lang/sather-specification/Makefile
@@ -17,11 +17,9 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
DOCSDIR= ${PREFIX}/share/doc/sather/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DOCSDIR}
- @${TAR} -xzf ${DISTDIR}/${DISTFILES} -C ${DOCSDIR}
- @${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${TAR} -xzf ${DISTDIR}/${DISTFILES} -C ${STAGEDIR}${DOCSDIR}
+ @${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.include <bsd.port.mk>