aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-04 18:04:11 +0800
committerstas <stas@FreeBSD.org>2006-11-04 18:04:11 +0800
commitaeee52596f3b9cd5f8174a1910369466e59a9c6b (patch)
tree52536d9604986f0710f011f76ac923160c73443b /lang
parent79f00832c0cd45976be5b96fd830e0065a7d7758 (diff)
downloadfreebsd-ports-gnome-aeee52596f3b9cd5f8174a1910369466e59a9c6b.tar.gz
freebsd-ports-gnome-aeee52596f3b9cd5f8174a1910369466e59a9c6b.tar.zst
freebsd-ports-gnome-aeee52596f3b9cd5f8174a1910369466e59a9c6b.zip
- Add a workaround for the recently disclosed DoS vulnerability in the cgi.rb
ruby18 module - Bump portrevision PR: ports/105113 Submitted by: UEDA Hiroyuki <BSDmad@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile2
-rw-r--r--lang/ruby18/files/patch-lib_cgi.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index c3bd2630efe5..dc13546e8cbd 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
diff --git a/lang/ruby18/files/patch-lib_cgi.rb b/lang/ruby18/files/patch-lib_cgi.rb
new file mode 100644
index 000000000000..1ab40f7e2afa
--- /dev/null
+++ b/lang/ruby18/files/patch-lib_cgi.rb
@@ -0,0 +1,11 @@
+--- lib/cgi.rb 2005-10-06 19:01:22.000000000 -0600
++++ lib/cgi.rb 2006-09-22 16:38:08.000000000 -0600
+@@ -1017,7 +1017,7 @@
+ else
+ stdinput.read(content_length)
+ end
+- if c.nil?
++ if c.nil? || c.empty?
+ raise EOFError, "bad content body"
+ end
+ buf.concat(c)