aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-10 20:14:49 +0800
committerpawel <pawel@FreeBSD.org>2012-11-10 20:14:49 +0800
commitb06b77b6bacb44ae73b4e3dc13144e8f91b73d2b (patch)
tree906cdf0db649ecd6441e2fda16834bee2aaf4092 /lang
parent4392c5876c6a07913688a8ba002f64e689bb4231 (diff)
downloadfreebsd-ports-gnome-b06b77b6bacb44ae73b4e3dc13144e8f91b73d2b.tar.gz
freebsd-ports-gnome-b06b77b6bacb44ae73b4e3dc13144e8f91b73d2b.tar.zst
freebsd-ports-gnome-b06b77b6bacb44ae73b4e3dc13144e8f91b73d2b.zip
- Update MASTER_SITES
- Support NO_WRKSUBDIR - Support COPYTREE_SHARE - Support PORTEXAMPLES - Add MAKE_JOBS_SAFE PR: ports/172025 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/cocor/Makefile73
-rw-r--r--lang/cocor/files/patch-cplus2::unix.mk16
-rw-r--r--lang/cocor/files/patch-taste_cp::unix.mk11
-rw-r--r--lang/cocor/files/patch-unix.mk13
-rw-r--r--lang/cocor/pkg-plist322
5 files changed, 221 insertions, 214 deletions
diff --git a/lang/cocor/Makefile b/lang/cocor/Makefile
index 042e737759fe..5854b88e546f 100644
--- a/lang/cocor/Makefile
+++ b/lang/cocor/Makefile
@@ -1,54 +1,57 @@
-# New ports collection makefile for: cocor
-# Date Created: 24 March 2002
-# Whom: Guy Antony Halse <guy@rucus.ru.za.za>
-#
+# Created by: Guy Antony Halse <guy@rucus.ru.za.za>
# $FreeBSD$
-#
PORTNAME= cocor
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
-MASTER_SITES= http://www.scifac.ru.ac.za/coco/
-DISTNAME= cocorc17
+MASTER_SITES= ftp://ftp.psg.com/pub/modula-2/coco/ \
+ ftp://ftp.ssw.uni-linz.ac.at/pub/Coco/C/ \
+ http://www.scifac.ru.ac.za/coco/
+DISTNAME= ${PORTNAME}c${PORTVERSION:S/.//}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A compiler generator that combines the functionality of lex and yacc
+COMMENT= Compiler generator that combines the functionality of lex and yacc
-WRKSRC= ${WRKDIR}
-ALL_TARGET= all1
-MAKE_ENV+= CRFRAMES=${WRKSRC}/frames
-CFLAGS+= -I${WRKSRC}/cplus2
-PLIST_SUB+= FRAMES=${CRFRAMES}
-CRFRAMES?= ${PREFIX}/lib/cocor
+NO_WRKSUBDIR= yes
-MAN1= cocor.1
+USE_DOS2UNIX= yes
+MAKE_ENV= CRFRAMES="${WRKSRC}/frames"
+MAKEFILE= unix.mk
+ALL_TARGET= all1
+MAKE_JOBS_SAFE= yes
-post-extract:
- ${LN} -s ${WRKSRC}/unix.mk ${WRKSRC}/Makefile
+MAN1= ${PORTNAME}.1
-pre-patch:
- uudecode -p ${WRKSRC}/dos2unix.uue > ${WRKSRC}/dos2unix.sh
- ${CHMOD} +x ${WRKSRC}/dos2unix.sh
- cd ${WRKSRC} && ./dos2unix.sh unix.mk && ${MAKE} -f unix.mk dos2unix
+.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e "s,^MAKE,#MAKE," ${WRKSRC}/Makefile
- ${RM} ${WRKSRC}/taste/unix.mk.orig
+.for i in sources/unix.mk taste/unix.mk
+ @${REINPLACE_CMD} -e 's|^CFLAGS|#CFLAGS|' ${WRKSRC}/${i}
+.endfor
+.for i in cplus2 taste taste_cp
+ @${RM} -f ${WRKSRC}/${i}/unix.mk.*
+.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cocor ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/docs/cocor.1 ${PREFIX}/man/man1
- ${MKDIR} -m 755 ${CRFRAMES}
- ${CP} -r ${WRKSRC}/frames/* ${CRFRAMES} && \
- ${FIND} ${CRFRAMES} -type f -exec ${CHMOD} 644 {} \; && \
- ${FIND} ${CRFRAMES} -type d -exec ${CHMOD} 755 {} \;
- ${MKDIR} -m 755 ${PREFIX}/share/cocor
-.for i in samples cplus2 taste taste_cp docs
- ${CP} -r ${WRKSRC}/${i} ${PREFIX}/share/cocor
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}
+.for i in cplus2 taste taste_cp
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} ${i} ${PREFIX}/lib/${PORTNAME})
.endfor
- ${FIND} ${PREFIX}/share/cocor -type f -exec ${CHMOD} 644 {} \; && \
- ${FIND} ${PREFIX}/share/cocor -type d -exec ${CHMOD} 755 {} \;
+ @${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC}/frames; ${COPYTREE_SHARE} . ${DATADIR})
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/coco.use ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/cocol ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.atg ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.inp ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/lang/cocor/files/patch-cplus2::unix.mk b/lang/cocor/files/patch-cplus2::unix.mk
index f42e4c17a804..ff44a81d1ab5 100644
--- a/lang/cocor/files/patch-cplus2::unix.mk
+++ b/lang/cocor/files/patch-cplus2::unix.mk
@@ -1,5 +1,5 @@
---- cplus2/unix.mk.orig Sat Nov 20 22:27:41 1999
-+++ cplus2/unix.mk Sat Jan 18 01:55:19 2003
+--- cplus2/unix.mk.orig 1999-11-21 15:27:41.000000000 +0900
++++ cplus2/unix.mk 2010-01-26 03:46:07.000000000 +0900
@@ -11,16 +11,16 @@
#CC sets the name of the compiler to use (cc, gcc, etc)
@@ -8,23 +8,23 @@
+CC = ${CXX}
AR = ar
- CFLAGS = -g
+-CFLAGS = -g
++CFLAGS = ${CXXFLAGS}
DOS2UNIX = ../dos2unix.sh
-%.o: %.cpp
-+*.o: *.cpp
++.cpp.o:
$(CC) -c $(CFLAGS) $< -o $@
-%.o: %.cxx
-+*.o: *.cxx
++.cxx.o:
$(CC) -c $(CFLAGS) $< -o $@
all: cr_lib.a
-@@ -45,4 +45,7 @@
- clean:
+@@ -46,3 +46,6 @@
\rm -f *.o
\rm -f *.a
+
+
+
+
-
diff --git a/lang/cocor/files/patch-taste_cp::unix.mk b/lang/cocor/files/patch-taste_cp::unix.mk
index c44cc34badeb..436111d962ef 100644
--- a/lang/cocor/files/patch-taste_cp::unix.mk
+++ b/lang/cocor/files/patch-taste_cp::unix.mk
@@ -1,5 +1,5 @@
---- taste_cp/unix.mk.orig 2009-03-25 13:31:23.000000000 +0100
-+++ taste_cp/unix.mk 2009-03-25 13:33:00.000000000 +0100
+--- taste_cp/unix.mk.orig 1999-11-21 15:34:48.000000000 +0900
++++ taste_cp/unix.mk 2010-01-26 03:48:40.000000000 +0900
@@ -8,17 +8,17 @@
#CC sets the name of the compiler to use (cc, gcc, etc)
@@ -7,17 +7,18 @@
-#CC = g++
+CC = ${CXX}
- CFLAGS = -g -I../cplus2
+-CFLAGS = -g -I../cplus2
++CFLAGS = -I../cplus2 ${CXXFLAGS}
COCOR = ../cocor
DOS2UNIX = ../dos2unix.sh
LIB = ../cplus2/cr_lib.a
-%.o: %.cpp
-+*.o: *.cpp
++.cpp.o:
$(CC) -c $(CFLAGS) $< -o $@
-%.o: %.cxx
-+*.o: *.cxx
++.cxx.o:
$(CC) -c $(CFLAGS) $< -o $@
all: taste pretty xref
diff --git a/lang/cocor/files/patch-unix.mk b/lang/cocor/files/patch-unix.mk
index 3e40a5a1bbc1..2f57d5146d34 100644
--- a/lang/cocor/files/patch-unix.mk
+++ b/lang/cocor/files/patch-unix.mk
@@ -1,5 +1,14 @@
---- unix.mk.orig Sun Mar 24 14:37:17 2002
-+++ unix.mk Sun Mar 24 14:37:47 2002
+--- unix.mk.orig 1998-04-16 00:48:11.000000000 +0900
++++ unix.mk 2012-07-09 16:52:30.000000000 +0900
+@@ -13,7 +13,7 @@
+ # solaris Set environment variables for Sun with Solaris 2.X
+ # and gnu C/C++
+
+-MAKE = make
++#MAKE = make
+ DOS2UNIX = ./dos2unix.sh
+ SUBDIRS = sources taste cplus2 taste_cp
+ SUBDIRS2 = docs frames frames/cplus2 cplus2 samples
@@ -47,7 +47,7 @@
all1:
set -e; \
diff --git a/lang/cocor/pkg-plist b/lang/cocor/pkg-plist
index 7cb11113dd52..df1b27dfbf1a 100644
--- a/lang/cocor/pkg-plist
+++ b/lang/cocor/pkg-plist
@@ -1,167 +1,161 @@
bin/cocor
-
-lib/cocor/compiler.frm
-lib/cocor/cplus2/compiler.frm
-lib/cocor/cplus2/parser_c.frm
-lib/cocor/cplus2/parser_h.frm
-lib/cocor/cplus2/scan_c.frm
-lib/cocor/cplus2/scan_h.frm
-lib/cocor/parser_c.frm
-lib/cocor/parser_h.frm
-lib/cocor/scan_c.frm
-lib/cocor/scan_h.frm
-
-share/cocor/cplus2/cr_abs.cpp
-share/cocor/cplus2/cr_abs.hpp
-share/cocor/cplus2/cr_abs.o
-share/cocor/cplus2/cr_error.cpp
-share/cocor/cplus2/cr_error.hpp
-share/cocor/cplus2/cr_error.o
-share/cocor/cplus2/cr_lib.a
-share/cocor/cplus2/cr_parse.cpp
-share/cocor/cplus2/cr_parse.hpp
-share/cocor/cplus2/cr_parse.o
-share/cocor/cplus2/cr_scan.cpp
-share/cocor/cplus2/cr_scan.hpp
-share/cocor/cplus2/cr_scan.o
-share/cocor/cplus2/unix.mk
-share/cocor/cplus2/unix.mk.orig
-share/cocor/docs/coco.use
-share/cocor/docs/cocol
-share/cocor/docs/cocor.1
-share/cocor/samples/adacs.atg
-share/cocor/samples/c.atg
-share/cocor/samples/calc.atg
-share/cocor/samples/calc.inp
-share/cocor/samples/cdecl.inp
-share/cocor/samples/cdecl1.atg
-share/cocor/samples/cdecl2.atg
-share/cocor/samples/cdecl3.atg
-share/cocor/samples/clang.inp
-share/cocor/samples/clang1.atg
-share/cocor/samples/clang2.atg
-share/cocor/samples/expr.atg
-share/cocor/samples/expr.inp
-share/cocor/samples/microada.atg
-share/cocor/samples/mod2.atg
-share/cocor/samples/oberon.atg
-share/cocor/samples/pascal.atg
-share/cocor/samples/pimmod2.atg
-share/cocor/samples/umbriel1.atg
-share/cocor/samples/umbriel2.atg
-share/cocor/taste/crossref.c
-share/cocor/taste/crossref.h
-share/cocor/taste/crossref.o
-share/cocor/taste/pretty
-share/cocor/taste/pretty.atg
-share/cocor/taste/pretty.c
-share/cocor/taste/pretty.o
-share/cocor/taste/prettyc.h
-share/cocor/taste/prettye.h
-share/cocor/taste/prettyp.c
-share/cocor/taste/prettyp.h
-share/cocor/taste/prettyp.o
-share/cocor/taste/prettypr.c
-share/cocor/taste/prettypr.h
-share/cocor/taste/prettypr.o
-share/cocor/taste/prettys.c
-share/cocor/taste/prettys.h
-share/cocor/taste/prettys.o
-share/cocor/taste/taste
-share/cocor/taste/taste.atg
-share/cocor/taste/taste.c
-share/cocor/taste/taste.frm
-share/cocor/taste/taste.o
-share/cocor/taste/tastec.h
-share/cocor/taste/tastee.h
-share/cocor/taste/tastep.c
-share/cocor/taste/tastep.h
-share/cocor/taste/tastep.o
-share/cocor/taste/tastes.c
-share/cocor/taste/tastes.h
-share/cocor/taste/tastes.o
-share/cocor/taste/tc.c
-share/cocor/taste/tc.h
-share/cocor/taste/tc.o
-share/cocor/taste/test.tas
-share/cocor/taste/tl.c
-share/cocor/taste/tl.h
-share/cocor/taste/tl.o
-share/cocor/taste/unix.mk
-share/cocor/taste/wrong.tas
-share/cocor/taste/xref
-share/cocor/taste/xref.atg
-share/cocor/taste/xref.c
-share/cocor/taste/xref.frm
-share/cocor/taste/xref.o
-share/cocor/taste/xrefc.h
-share/cocor/taste/xrefe.h
-share/cocor/taste/xrefp.c
-share/cocor/taste/xrefp.h
-share/cocor/taste/xrefp.o
-share/cocor/taste/xrefs.c
-share/cocor/taste/xrefs.h
-share/cocor/taste/xrefs.o
-share/cocor/taste_cp/crossref.cpp
-share/cocor/taste_cp/crossref.hpp
-share/cocor/taste_cp/crossref.o
-share/cocor/taste_cp/pretty
-share/cocor/taste_cp/pretty.atg
-share/cocor/taste_cp/pretty.cpp
-share/cocor/taste_cp/pretty.o
-share/cocor/taste_cp/prettyc.hpp
-share/cocor/taste_cp/prettye.hpp
-share/cocor/taste_cp/prettyp.cpp
-share/cocor/taste_cp/prettyp.hpp
-share/cocor/taste_cp/prettyp.o
-share/cocor/taste_cp/prettypr.cpp
-share/cocor/taste_cp/prettypr.hpp
-share/cocor/taste_cp/prettypr.o
-share/cocor/taste_cp/prettys.cpp
-share/cocor/taste_cp/prettys.hpp
-share/cocor/taste_cp/prettys.o
-share/cocor/taste_cp/taste
-share/cocor/taste_cp/taste.atg
-share/cocor/taste_cp/taste.cpp
-share/cocor/taste_cp/taste.frm
-share/cocor/taste_cp/taste.o
-share/cocor/taste_cp/tastec.hpp
-share/cocor/taste_cp/tastee.hpp
-share/cocor/taste_cp/tastep.cpp
-share/cocor/taste_cp/tastep.hpp
-share/cocor/taste_cp/tastep.o
-share/cocor/taste_cp/tastes.cpp
-share/cocor/taste_cp/tastes.hpp
-share/cocor/taste_cp/tastes.o
-share/cocor/taste_cp/tc.cpp
-share/cocor/taste_cp/tc.hpp
-share/cocor/taste_cp/tc.o
-share/cocor/taste_cp/test.tas
-share/cocor/taste_cp/tl.cpp
-share/cocor/taste_cp/tl.hpp
-share/cocor/taste_cp/tl.o
-share/cocor/taste_cp/unix.mk
-share/cocor/taste_cp/unix.mk.orig
-share/cocor/taste_cp/wrong.tas
-share/cocor/taste_cp/xref
-share/cocor/taste_cp/xref.atg
-share/cocor/taste_cp/xref.cpp
-share/cocor/taste_cp/xref.frm
-share/cocor/taste_cp/xref.o
-share/cocor/taste_cp/xrefc.hpp
-share/cocor/taste_cp/xrefe.hpp
-share/cocor/taste_cp/xrefp.cpp
-share/cocor/taste_cp/xrefp.hpp
-share/cocor/taste_cp/xrefp.o
-share/cocor/taste_cp/xrefs.cpp
-share/cocor/taste_cp/xrefs.hpp
-share/cocor/taste_cp/xrefs.o
-
+lib/cocor/cplus2/cr_abs.cpp
+lib/cocor/cplus2/cr_abs.hpp
+lib/cocor/cplus2/cr_abs.o
+lib/cocor/cplus2/cr_error.cpp
+lib/cocor/cplus2/cr_error.hpp
+lib/cocor/cplus2/cr_error.o
+lib/cocor/cplus2/cr_lib.a
+lib/cocor/cplus2/cr_parse.cpp
+lib/cocor/cplus2/cr_parse.hpp
+lib/cocor/cplus2/cr_parse.o
+lib/cocor/cplus2/cr_scan.cpp
+lib/cocor/cplus2/cr_scan.hpp
+lib/cocor/cplus2/cr_scan.o
+lib/cocor/cplus2/unix.mk
+lib/cocor/taste/crossref.c
+lib/cocor/taste/crossref.h
+lib/cocor/taste/crossref.o
+lib/cocor/taste/pretty
+lib/cocor/taste/pretty.atg
+lib/cocor/taste/pretty.c
+lib/cocor/taste/pretty.o
+lib/cocor/taste/prettyc.h
+lib/cocor/taste/prettye.h
+lib/cocor/taste/prettyp.c
+lib/cocor/taste/prettyp.h
+lib/cocor/taste/prettyp.o
+lib/cocor/taste/prettypr.c
+lib/cocor/taste/prettypr.h
+lib/cocor/taste/prettypr.o
+lib/cocor/taste/prettys.c
+lib/cocor/taste/prettys.h
+lib/cocor/taste/prettys.o
+lib/cocor/taste/taste
+lib/cocor/taste/taste.atg
+lib/cocor/taste/taste.c
+lib/cocor/taste/taste.frm
+lib/cocor/taste/taste.o
+lib/cocor/taste/tastec.h
+lib/cocor/taste/tastee.h
+lib/cocor/taste/tastep.c
+lib/cocor/taste/tastep.h
+lib/cocor/taste/tastep.o
+lib/cocor/taste/tastes.c
+lib/cocor/taste/tastes.h
+lib/cocor/taste/tastes.o
+lib/cocor/taste/tc.c
+lib/cocor/taste/tc.h
+lib/cocor/taste/tc.o
+lib/cocor/taste/test.tas
+lib/cocor/taste/tl.c
+lib/cocor/taste/tl.h
+lib/cocor/taste/tl.o
+lib/cocor/taste/unix.mk
+lib/cocor/taste/wrong.tas
+lib/cocor/taste/xref
+lib/cocor/taste/xref.atg
+lib/cocor/taste/xref.c
+lib/cocor/taste/xref.frm
+lib/cocor/taste/xref.o
+lib/cocor/taste/xrefc.h
+lib/cocor/taste/xrefe.h
+lib/cocor/taste/xrefp.c
+lib/cocor/taste/xrefp.h
+lib/cocor/taste/xrefp.o
+lib/cocor/taste/xrefs.c
+lib/cocor/taste/xrefs.h
+lib/cocor/taste/xrefs.o
+lib/cocor/taste_cp/crossref.cpp
+lib/cocor/taste_cp/crossref.hpp
+lib/cocor/taste_cp/crossref.o
+lib/cocor/taste_cp/pretty
+lib/cocor/taste_cp/pretty.atg
+lib/cocor/taste_cp/pretty.cpp
+lib/cocor/taste_cp/pretty.o
+lib/cocor/taste_cp/prettyc.hpp
+lib/cocor/taste_cp/prettye.hpp
+lib/cocor/taste_cp/prettyp.cpp
+lib/cocor/taste_cp/prettyp.hpp
+lib/cocor/taste_cp/prettyp.o
+lib/cocor/taste_cp/prettypr.cpp
+lib/cocor/taste_cp/prettypr.hpp
+lib/cocor/taste_cp/prettypr.o
+lib/cocor/taste_cp/prettys.cpp
+lib/cocor/taste_cp/prettys.hpp
+lib/cocor/taste_cp/prettys.o
+lib/cocor/taste_cp/taste
+lib/cocor/taste_cp/taste.atg
+lib/cocor/taste_cp/taste.cpp
+lib/cocor/taste_cp/taste.frm
+lib/cocor/taste_cp/taste.o
+lib/cocor/taste_cp/tastec.hpp
+lib/cocor/taste_cp/tastee.hpp
+lib/cocor/taste_cp/tastep.cpp
+lib/cocor/taste_cp/tastep.hpp
+lib/cocor/taste_cp/tastep.o
+lib/cocor/taste_cp/tastes.cpp
+lib/cocor/taste_cp/tastes.hpp
+lib/cocor/taste_cp/tastes.o
+lib/cocor/taste_cp/tc.cpp
+lib/cocor/taste_cp/tc.hpp
+lib/cocor/taste_cp/tc.o
+lib/cocor/taste_cp/test.tas
+lib/cocor/taste_cp/tl.cpp
+lib/cocor/taste_cp/tl.hpp
+lib/cocor/taste_cp/tl.o
+lib/cocor/taste_cp/unix.mk
+lib/cocor/taste_cp/wrong.tas
+lib/cocor/taste_cp/xref
+lib/cocor/taste_cp/xref.atg
+lib/cocor/taste_cp/xref.cpp
+lib/cocor/taste_cp/xref.frm
+lib/cocor/taste_cp/xref.o
+lib/cocor/taste_cp/xrefc.hpp
+lib/cocor/taste_cp/xrefe.hpp
+lib/cocor/taste_cp/xrefp.cpp
+lib/cocor/taste_cp/xrefp.hpp
+lib/cocor/taste_cp/xrefp.o
+lib/cocor/taste_cp/xrefs.cpp
+lib/cocor/taste_cp/xrefs.hpp
+lib/cocor/taste_cp/xrefs.o
+%%DATADIR%%/compiler.frm
+%%DATADIR%%/cplus2/compiler.frm
+%%DATADIR%%/cplus2/parser_c.frm
+%%DATADIR%%/cplus2/parser_h.frm
+%%DATADIR%%/cplus2/scan_c.frm
+%%DATADIR%%/cplus2/scan_h.frm
+%%DATADIR%%/parser_c.frm
+%%DATADIR%%/parser_h.frm
+%%DATADIR%%/scan_c.frm
+%%DATADIR%%/scan_h.frm
+%%PORTDOCS%%%%DOCSDIR%%/coco.use
+%%PORTDOCS%%%%DOCSDIR%%/cocol
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/adacs.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cdecl.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cdecl1.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cdecl2.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cdecl3.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang1.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang2.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/expr.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/expr.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/microada.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mod2.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/oberon.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pascal.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pimmod2.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/umbriel1.atg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/umbriel2.atg
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/cplus2
+@dirrm %%DATADIR%%
+@dirrm lib/cocor/taste_cp
+@dirrm lib/cocor/taste
@dirrm lib/cocor/cplus2
@dirrm lib/cocor
-@dirrm share/cocor/cplus2
-@dirrm share/cocor/samples
-@dirrm share/cocor/taste
-@dirrm share/cocor/taste_cp
-@dirrm share/cocor/docs
-@dirrm share/cocor