aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-08-18 15:05:58 +0800
committermakc <makc@FreeBSD.org>2010-08-18 15:05:58 +0800
commitbedadd602c8ea2c7a62fc025d7abfb5228eb06a5 (patch)
treedcaf25b741b9038adc20aceddff3593013d790b1 /lang
parent9f17f218417118795ae51ee4adccdf788d11d55a (diff)
downloadfreebsd-ports-gnome-bedadd602c8ea2c7a62fc025d7abfb5228eb06a5.tar.gz
freebsd-ports-gnome-bedadd602c8ea2c7a62fc025d7abfb5228eb06a5.tar.zst
freebsd-ports-gnome-bedadd602c8ea2c7a62fc025d7abfb5228eb06a5.zip
Update to 1.00
PR: ports/149519 Submitted by: Vitaly Magerya (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/stklos/Makefile25
-rw-r--r--lang/stklos/distinfo6
-rw-r--r--lang/stklos/files/patch-configure31
-rw-r--r--lang/stklos/files/patch-lib-repl.stk11
-rw-r--r--lang/stklos/files/patch-src-number.c11
-rw-r--r--lang/stklos/pkg-plist35
6 files changed, 39 insertions, 80 deletions
diff --git a/lang/stklos/Makefile b/lang/stklos/Makefile
index 51d88384c37c..8a0611da5e32 100644
--- a/lang/stklos/Makefile
+++ b/lang/stklos/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stklos
-PORTVERSION= 0.98
-PORTREVISION= 3
+PORTVERSION= 1.00
CATEGORIES= lang scheme
MASTER_SITES= http://www.stklos.net/download/ \
ftp://kaolin.essi.fr/pub/STklos/
@@ -27,22 +26,20 @@ CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-gtk \
- --disable-gnome \
- --enable-threads=posix
+CONFIGURE_ARGS= --enable-threads=posix
-MAN1= stklos-compile.1 stklos-config.1 stklos-genlex.1 stklos.1 \
- stklos-install.1
+MAN1= stklos-compile.1 stklos-config.1 stklos-genlex.1 \
+ stklos-pkg.1 stklos.1
post-patch:
@${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -e 's|-@VERSION@||' ${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -e '/&&/s|make|gmake|; /&&/s|configure|./configure|' \
- -e 's|wget|fetch|' ${WRKSRC}/utils/stklos-install
- @${REINPLACE_CMD} -e 's|stklos\.org|stklos.net|' \
- ${WRKSRC}/pkgman/params.stk
+ -e 's|bdw-gc|bdw-gc-threaded|' \
+ -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|share/man|man|' \
+ -e 's|-@VERSION@||' \
+ -e 's|^man_MANS = |man_MANS = stklos-pkg.1 |' \
+ ${WRKSRC}/doc/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(install-data-am:).*/\1 install-man install-schemeDATA/' \
diff --git a/lang/stklos/distinfo b/lang/stklos/distinfo
index 8ce30ba5c476..7fcebdecf17a 100644
--- a/lang/stklos/distinfo
+++ b/lang/stklos/distinfo
@@ -1,3 +1,3 @@
-MD5 (stklos-0.98.tar.gz) = f641b2f04b5805ce570db034fcf64d3b
-SHA256 (stklos-0.98.tar.gz) = c809e1e5999e987b94b918e8d6556ab5b19ffef8b9b8a3a4a56ec94579ef9b93
-SIZE (stklos-0.98.tar.gz) = 5306627
+MD5 (stklos-1.00.tar.gz) = 3fd4809205871b65882be9b9f7e17090
+SHA256 (stklos-1.00.tar.gz) = 40049a452704ddd8a4f37a27cec6126d0517627de621e9349fb174d016c9efcc
+SIZE (stklos-1.00.tar.gz) = 5861046
diff --git a/lang/stklos/files/patch-configure b/lang/stklos/files/patch-configure
deleted file mode 100644
index 2c4d5e2fbb2e..000000000000
--- a/lang/stklos/files/patch-configure
+++ /dev/null
@@ -1,31 +0,0 @@
---- configure.orig 2008-05-03 23:43:30.000000000 +0300
-+++ configure 2009-02-02 23:23:42.000000000 +0200
-@@ -6790,15 +6790,20 @@
-
-
- if test "$USER_FFI" = "yes" ;then
-- echo "Configuring libffi"
-- (cd ffi; CC=${CC} CFLAGS=${CFLAGS} ./configure \
-- --disable-structs --disable-raw-api --disable-shared \
-- --prefix=$prefix)
-- LIBS="$LIBS ../ffi/.libs/libffi.a"
-- CFLAGS="$CFLAGS -I../ffi/include"
-- LIBFFI="ffi"
-+# echo "Configuring libffi"
-+# (cd ffi; CC=${CC} CFLAGS=${CFLAGS} ./configure \
-+# --disable-structs --disable-raw-api --disable-shared \
-+# --prefix=$prefix)
-+# LIBS="$LIBS ../ffi/.libs/libffi.a"
-+# CFLAGS="$CFLAGS -I../ffi/include"
-+# LIBFFI="ffi"
-+# HAVE_FFI="#define HAVE_FFI 1"
-+# FFI="yes"
-+ echo "Using the system libffi library"
-+ LIBS="$LIBS -lffi"
-+ LIBFFI=""
- HAVE_FFI="#define HAVE_FFI 1"
-- FFI="yes"
-+ FFI="use the system library"
- else
- echo "Disabling FFI support"
- LIBFFI=""
diff --git a/lang/stklos/files/patch-lib-repl.stk b/lang/stklos/files/patch-lib-repl.stk
deleted file mode 100644
index 480f1db17f2a..000000000000
--- a/lang/stklos/files/patch-lib-repl.stk
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/repl.stk.orig 2010-02-19 19:43:51.000000000 +0200
-+++ lib/repl.stk 2010-02-19 19:44:11.000000000 +0200
-@@ -44,7 +44,7 @@
- (define do-color
- (if (and (not (key-get *%program-args* :interactive #f))
- (member (getenv "TERM")
-- '("rxvt" "xterm" "xterm-color" "linux" "cygwin")))
-+ '("rxvt" "xterm" "xterm-color" "linux" "cygwin" "cons25")))
- ;; Terminal accepts color
- ansi-color
- ;; Provide a procedure which ignore color indications
diff --git a/lang/stklos/files/patch-src-number.c b/lang/stklos/files/patch-src-number.c
deleted file mode 100644
index c841299ea908..000000000000
--- a/lang/stklos/files/patch-src-number.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/number.c.orig Sat Feb 8 05:31:25 2003
-+++ src/number.c Thu Apr 10 00:15:24 2003
-@@ -2903,7 +2903,7 @@
- */
- int STk_init_number(void)
- {
--#if defined(__linux__) && defined(__alpha__)
-+#if defined(__alpha__)
- static union {
- unsigned char a[4];
- float f;
diff --git a/lang/stklos/pkg-plist b/lang/stklos/pkg-plist
index 3f501ded872e..3a86c315df36 100644
--- a/lang/stklos/pkg-plist
+++ b/lang/stklos/pkg-plist
@@ -1,9 +1,7 @@
bin/stklos
bin/stklos-compile
bin/stklos-config
-bin/stklos-ext-install
bin/stklos-genlex
-bin/stklos-install
bin/stklos-pkg
bin/stklos-script
etc/stklos/Makefile-scmpkg.tmpl
@@ -12,8 +10,19 @@ include/stklos/fport.h
include/stklos/socket.h
include/stklos/stklos.h
include/stklos/stklosconf.h
-lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/DOCDB
+%%DATADIR%%/%%VERSION%%/Demos.d/fork-test
+%%DATADIR%%/%%VERSION%%/Demos.d/fork-test.stk
+%%DATADIR%%/%%VERSION%%/Demos.d/hello
+%%DATADIR%%/%%VERSION%%/Demos.d/hello.stk
+%%DATADIR%%/%%VERSION%%/Demos.d/secho
+%%DATADIR%%/%%VERSION%%/Demos.d/secho.stk
+%%DATADIR%%/%%VERSION%%/Demos.d/socket-client
+%%DATADIR%%/%%VERSION%%/Demos.d/socket-client.stk
+%%DATADIR%%/%%VERSION%%/Demos.d/socket-server
+%%DATADIR%%/%%VERSION%%/Demos.d/socket-server.stk
+%%DATADIR%%/%%VERSION%%/Demos.d/threads
+%%DATADIR%%/%%VERSION%%/Demos.d/threads.stk
%%DATADIR%%/%%VERSION%%/Match.d/compiler.scm
%%DATADIR%%/%%VERSION%%/Match.d/descr.scm
%%DATADIR%%/%%VERSION%%/Match.d/mexpand.scm
@@ -28,7 +37,6 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/bigmatch.ostk
%%DATADIR%%/%%VERSION%%/bigmatch.stk
%%DATADIR%%/%%VERSION%%/bonus.stk
-%%DATADIR%%/%%VERSION%%/boot-callcc.stk
%%DATADIR%%/%%VERSION%%/boot.stk
%%DATADIR%%/%%VERSION%%/callcc.stk
%%DATADIR%%/%%VERSION%%/compfile.ostk
@@ -42,7 +50,6 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/env.stk
%%DATADIR%%/%%VERSION%%/expand.pp
%%DATADIR%%/%%VERSION%%/expand.ss
-%%DATADIR%%/%%VERSION%%/ffi.ostk
%%DATADIR%%/%%VERSION%%/ffi.stk
%%DATADIR%%/%%VERSION%%/full-conditions.ostk
%%DATADIR%%/%%VERSION%%/full-conditions.stk
@@ -50,15 +57,16 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/full-syntax.stk
%%DATADIR%%/%%VERSION%%/getopt.ostk
%%DATADIR%%/%%VERSION%%/getopt.stk
+%%DATADIR%%/%%VERSION%%/help.ostk
+%%DATADIR%%/%%VERSION%%/help.stk
%%DATADIR%%/%%VERSION%%/http.ostk
%%DATADIR%%/%%VERSION%%/http.stk
%%DATADIR%%/%%VERSION%%/lalr.ostk
%%DATADIR%%/%%VERSION%%/lalr.stk
-%%DATADIR%%/%%VERSION%%/ldap.ostk
-%%DATADIR%%/%%VERSION%%/ldap.stk
%%DATADIR%%/%%VERSION%%/lex-rt.ostk
%%DATADIR%%/%%VERSION%%/lex-rt.stk
%%DATADIR%%/%%VERSION%%/load.stk
+%%DATADIR%%/%%VERSION%%/logical.stk
%%DATADIR%%/%%VERSION%%/make-C-boot.stk
%%DATADIR%%/%%VERSION%%/mbe.stk
%%DATADIR%%/%%VERSION%%/module.stk
@@ -70,9 +78,11 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/pp.stk
%%DATADIR%%/%%VERSION%%/process.stk
%%DATADIR%%/%%VERSION%%/r5rs.stk
+%%DATADIR%%/%%VERSION%%/readline.stk
%%DATADIR%%/%%VERSION%%/recette.ostk
%%DATADIR%%/%%VERSION%%/recette.stk
%%DATADIR%%/%%VERSION%%/regexp.stk
+%%DATADIR%%/%%VERSION%%/repl-readline.stk
%%DATADIR%%/%%VERSION%%/repl.stk
%%DATADIR%%/%%VERSION%%/runtime.stk
%%DATADIR%%/%%VERSION%%/scmpkg-support.ostk
@@ -83,6 +93,8 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/srfi-0.stk
%%DATADIR%%/%%VERSION%%/srfi-1.ostk
%%DATADIR%%/%%VERSION%%/srfi-1.stk
+%%DATADIR%%/%%VERSION%%/srfi-100.ostk
+%%DATADIR%%/%%VERSION%%/srfi-100.stk
%%DATADIR%%/%%VERSION%%/srfi-11.ostk
%%DATADIR%%/%%VERSION%%/srfi-11.stk
%%DATADIR%%/%%VERSION%%/srfi-13.ostk
@@ -123,10 +135,14 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/srfi-7.stk
%%DATADIR%%/%%VERSION%%/srfi-70.ostk
%%DATADIR%%/%%VERSION%%/srfi-70.stk
+%%DATADIR%%/%%VERSION%%/srfi-74.ostk
+%%DATADIR%%/%%VERSION%%/srfi-74.stk
%%DATADIR%%/%%VERSION%%/srfi-89.ostk
%%DATADIR%%/%%VERSION%%/srfi-89.stk
%%DATADIR%%/%%VERSION%%/srfi-9.ostk
%%DATADIR%%/%%VERSION%%/srfi-9.stk
+%%DATADIR%%/%%VERSION%%/srfi-96.ostk
+%%DATADIR%%/%%VERSION%%/srfi-96.stk
%%DATADIR%%/%%VERSION%%/struct.stk
%%DATADIR%%/%%VERSION%%/tar.ostk
%%DATADIR%%/%%VERSION%%/tar.stk
@@ -157,11 +173,10 @@ lib/stklos/%%VERSION%%/ldap.so
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/%%VERSION%%/ScmPkg.d
+@dirrm %%DATADIR%%/%%VERSION%%/Demos.d
@dirrm %%DATADIR%%/%%VERSION%%/Match.d
+@dirrm %%DATADIR%%/%%VERSION%%/ScmPkg.d
@dirrm %%DATADIR%%/%%VERSION%%
@dirrm %%DATADIR%%
-@dirrm lib/stklos/%%VERSION%%
-@dirrm lib/stklos
@dirrm include/stklos
@dirrm etc/stklos