aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>1999-08-23 07:33:47 +0800
committermharo <mharo@FreeBSD.org>1999-08-23 07:33:47 +0800
commite36f9dbee84ccfd7ed078050303a76b569d0ead0 (patch)
tree4f6e254ed273f40def6ec9e6d94066be8e9c6588 /lang
parent26083abcc9eb48fec93239f2c3257eab60edb1c0 (diff)
downloadfreebsd-ports-gnome-e36f9dbee84ccfd7ed078050303a76b569d0ead0.tar.gz
freebsd-ports-gnome-e36f9dbee84ccfd7ed078050303a76b569d0ead0.tar.zst
freebsd-ports-gnome-e36f9dbee84ccfd7ed078050303a76b569d0ead0.zip
awk -> ${AWK}
basename -> ${BASENAME} cat -> ${CAT} cp -> ${CP} ldconfig -> ${LDCONFIG} mkdir -> ${MKDIR}
Diffstat (limited to 'lang')
-rw-r--r--lang/f2c/Makefile4
-rw-r--r--lang/modula-3-lib/Makefile4
-rw-r--r--lang/ocaml/Makefile4
-rw-r--r--lang/sml-nj-devel/Makefile4
-rw-r--r--lang/sml-nj/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/lang/f2c/Makefile b/lang/f2c/Makefile
index f0ab50fcdc6f..6443e5b45f81 100644
--- a/lang/f2c/Makefile
+++ b/lang/f2c/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 DEC 1998
# Whom: Steven G. Kargl
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/24 22:33:14 obrien Exp $
#
DISTNAME= f2c-freebsd.2.0.1
@@ -17,7 +17,7 @@ MAINTAINER= kargl@troutmask.apl.washington.edu
.if (${ARCH} == "alpha")
pre-configure:
- @cp ${FILESDIR}/f2c.h.alpha ${WRKSRC}/f2c/f2c.h
+ @${CP} ${FILESDIR}/f2c.h.alpha ${WRKSRC}/f2c/f2c.h
.endif
ALL_TARGET= depend all
diff --git a/lang/modula-3-lib/Makefile b/lang/modula-3-lib/Makefile
index c680d5c25bfa..17eeb2a937fb 100644
--- a/lang/modula-3-lib/Makefile
+++ b/lang/modula-3-lib/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 Oct 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.14 1999/01/28 05:39:19 jdp Exp $
+# $Id: Makefile,v 1.15 1999/08/22 18:58:51 mharo Exp $
#
DISTNAME= modula-3-lib-3.6
@@ -154,7 +154,7 @@ do-install:
test -d ${startup_dir} || ${MKDIR} ${startup_dir}; \
echo "#!/bin/sh" > ${startup_script}; \
echo "echo -n ' Modula-3'" >> ${startup_script}; \
- echo "/sbin/ldconfig -m ${PREFIX}/lib/m3/FreeBSD2" \
+ echo "${LDCONFIG} -m ${PREFIX}/lib/m3/FreeBSD2" \
>> ${startup_script}; \
${CHMOD} 755 ${startup_script}; \
fi
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index cd60d62d8fc3..9b7398c8114e 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 December 1996
# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.7 1999/05/09 16:39:54 steve Exp $
+# $Id: Makefile,v 1.8 1999/05/31 05:14:39 steve Exp $
#
DISTNAME= ocaml-2.02
@@ -38,7 +38,7 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/ocaml/html
@cd ${WRKDIR}/htmlman; ${INSTALL_DATA} * ${PREFIX}/share/doc/ocaml/html
- @cp ${DISTDIR}/${DISTNAME}-refman.ps.gz ${PREFIX}/share/doc/ocaml
+ @${CP} ${DISTDIR}/${DISTNAME}-refman.ps.gz ${PREFIX}/share/doc/ocaml
.endif
@strip ${PREFIX}/bin/ocamlrun ${PREFIX}/bin/ocamlyacc
diff --git a/lang/sml-nj-devel/Makefile b/lang/sml-nj-devel/Makefile
index 7a95f5f73b78..9828a27664b3 100644
--- a/lang/sml-nj-devel/Makefile
+++ b/lang/sml-nj-devel/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 July 1998
# Whom: jkoshy
#
-# $Id: Makefile,v 1.6 1999/02/02 04:18:52 jkoshy Exp $
+# $Id: Makefile,v 1.7 1999/08/22 18:58:55 mharo Exp $
#
DISTNAME= 110.9.1-bin.x86-unix
@@ -70,7 +70,7 @@ do-install:
tar -C ${SML_BASE} -xf -
for file in ${WRKDIR}/lib/*; do\
${SED} -e "s,${WRKDIR},${SML_BASE}," < $$file > \
- ${SML_LIBDIR}/`basename $$file`; \
+ ${SML_LIBDIR}/`${BASENAME} $$file`; \
done
.for file in ${SML_EXES}
-${LN} -s ${SML_BINDIR}/${file} ${PREFIX}/bin/${file}
diff --git a/lang/sml-nj/Makefile b/lang/sml-nj/Makefile
index 7a95f5f73b78..9828a27664b3 100644
--- a/lang/sml-nj/Makefile
+++ b/lang/sml-nj/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 July 1998
# Whom: jkoshy
#
-# $Id: Makefile,v 1.6 1999/02/02 04:18:52 jkoshy Exp $
+# $Id: Makefile,v 1.7 1999/08/22 18:58:55 mharo Exp $
#
DISTNAME= 110.9.1-bin.x86-unix
@@ -70,7 +70,7 @@ do-install:
tar -C ${SML_BASE} -xf -
for file in ${WRKDIR}/lib/*; do\
${SED} -e "s,${WRKDIR},${SML_BASE}," < $$file > \
- ${SML_LIBDIR}/`basename $$file`; \
+ ${SML_LIBDIR}/`${BASENAME} $$file`; \
done
.for file in ${SML_EXES}
-${LN} -s ${SML_BINDIR}/${file} ${PREFIX}/bin/${file}