aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /lang
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'lang')
-rw-r--r--lang/caml-light/Makefile10
-rw-r--r--lang/hope/Makefile12
-rw-r--r--lang/ici/Makefile12
-rw-r--r--lang/moscow_ml/Makefile12
-rw-r--r--lang/nickle/Makefile12
5 files changed, 29 insertions, 29 deletions
diff --git a/lang/caml-light/Makefile b/lang/caml-light/Makefile
index a4405cc1b74e..7a9a137bc2a7 100644
--- a/lang/caml-light/Makefile
+++ b/lang/caml-light/Makefile
@@ -18,17 +18,17 @@ DISTNAME= cl74unix
MAINTAINER= jkoshy@freebsd.org
COMMENT= A strongly typed functional language belonging to the ML family
+USE_XLIB= yes
+WRKSRC= ${WRKDIR}/cl74
+ALL_TARGET= configure world bootstrap
+MAN1= camlc.1 camllex.1 camllibr.1 camllight.1 camlmktop.1 camlrun.1 camlyacc.1 mletags.1 camllorder.1 camlsearch.1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-USE_XLIB= yes
-WRKSRC= ${WRKDIR}/cl74
-ALL_TARGET= configure world bootstrap
-MAN1= camlc.1 camllex.1 camllibr.1 camllight.1 camlmktop.1 camlrun.1 camlyacc.1 mletags.1 camllorder.1 camlsearch.1
-
do-build:
cd ${WRKSRC}/src; ${MAKE} ${ALL_TARGET} PREFIX=${PREFIX} \
X11BASE=${X11BASE}
diff --git a/lang/hope/Makefile b/lang/hope/Makefile
index 732a34c46f06..6d578a8382b3 100644
--- a/lang/hope/Makefile
+++ b/lang/hope/Makefile
@@ -14,12 +14,6 @@ DISTNAME= ${PORTNAME}
MAINTAINER= lev@serebryakov.spb.ru
COMMENT= Hope is lazy interpriter for HOPE applicative language
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not install"
-.endif
-
.if defined(WITH_DOCS)
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX \
latex2html:${PORTSDIR}/textproc/latex2html
@@ -33,6 +27,12 @@ USE_GMAKE= yes
MAN1= hope.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not install"
+.endif
+
pre-fetch:
.if !defined(WITH_DOCS)
@${ECHO} ""
diff --git a/lang/ici/Makefile b/lang/ici/Makefile
index a675284f72a3..8cadcb0c714b 100644
--- a/lang/ici/Makefile
+++ b/lang/ici/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= http://www.zeta.org.au/~atrn/ici/distfiles/
MAINTAINER= atrn@zeta.org.au
COMMENT= An interpretive language with C's overall feel combined with high level data types
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
MAKEFILE= Makefile.bsd
MAN1= ici3.1
MANCOMPRESSED= yes
@@ -34,6 +28,12 @@ ICIPCREHDRS= pcre/internal.h pcre/pcre.h
ICIDOCS= doc/ici-a4.ps doc/ici-ltr.ps doc/ici.txt doc/ici.pdf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
do-install:
cd ${WRKSRC} && ${MAKE} -f ${MAKEFILE} libici3.a
${INSTALL_PROGRAM} ${WRKSRC}/ici3 ${PREFIX}/bin
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index e65cd73882a2..7124d3f2d1f3 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -18,12 +18,6 @@ COMMENT= Moscow ML, a lightweight implementation of Standard ML
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
MOSMLHOME= $(PREFIX)/moscow_ml
ALL_TARGET= world MOSMLHOME=$(MOSMLHOME)
@@ -31,6 +25,12 @@ INSTALL_TARGET= install MOSMLHOME=$(MOSMLHOME)
WRKSRC= ${WRKDIR}/mosml/src
USE_PERL5= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-install:
${SED} -e 's|^MOSMLHOME=.*|MOSMLHOME=${MOSMLHOME}|' \
${WRKDIR}/mosml/tools/Makefile.stub > ${MOSMLHOME}/tools/Makefile.stub
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index ecaec8fb0e90..eae97eff0548 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -13,16 +13,16 @@ MASTER_SITES= http://www.nickle.org/release/
MAINTAINER= chrise@scardini.com
COMMENT= A desk calculator language
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= nickle.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.include <bsd.port.post.mk>