aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-28 07:50:04 +0800
committerale <ale@FreeBSD.org>2004-07-28 07:50:04 +0800
commit09b3a90ba4f8ec8f6717800888d59beb81243e88 (patch)
tree35a8cc34580b12eb9c23f55845c6de764dcda8cb /lang
parent4da3811a7ea92092ce6b537d6816c97ec9d651fe (diff)
downloadfreebsd-ports-gnome-09b3a90ba4f8ec8f6717800888d59beb81243e88.tar.gz
freebsd-ports-gnome-09b3a90ba4f8ec8f6717800888d59beb81243e88.tar.zst
freebsd-ports-gnome-09b3a90ba4f8ec8f6717800888d59beb81243e88.zip
Enable default extensions when OPTIONSFILE is missing:
- Fix package creation and BATCH installation
Diffstat (limited to 'lang')
-rw-r--r--lang/php4-extensions/Makefile15
-rw-r--r--lang/php5-extensions/Makefile16
2 files changed, 25 insertions, 6 deletions
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index 695b10fda7c6..39a00e8f5a7a 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -18,10 +18,19 @@ COMMENT= A "meta-port" to install PHP extensions
NO_BUILD= # none
-USE_PHP= yes
DEFAULT_PHP_VER=4
BROKEN_WITH_PHP=5
+WITH_CTYPE= yes
+WITH_MYSQL= yes
+WITH_OVERLOAD= yes
+WITH_PCRE= yes
+WITH_POSIX= yes
+WITH_SESSION= yes
+WITH_TOKENIZER= yes
+WITH_XML= yes
+WITH_ZLIB= yes
+
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
CALENDAR "calendar conversion support" off \
@@ -106,11 +115,11 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CRACK CTYPE CURL DBA DBASE DBX DIO \
SEL_OPTIONS= yes
.for opt in ${ALL_OPTIONS}
-. if defined(WITH_${opt})
+. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
SEL_OPTIONS+= ${opt:L}
. endif
.endfor
-USE_PHP+= ${SEL_OPTIONS}
+USE_PHP= ${SEL_OPTIONS}
do-build:
@${DO_NADA}
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 558ffed8add6..39b3b149b453 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -18,10 +18,20 @@ COMMENT= A "meta-port" to install PHP extensions
NO_BUILD= # none
-USE_PHP= yes
DEFAULT_PHP_VER=5
BROKEN_WITH_PHP=4
+WITH_CTYPE= yes
+WITH_DOM= yes
+WITH_ICONV= yes
+WITH_PCRE= yes
+WITH_POSIX= yes
+WITH_SESSION= yes
+WITH_SIMPLEXML= yes
+WITH_SQLITE= yes
+WITH_TOKENIZER= yes
+WITH_XML= yes
+
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
CALENDAR "calendar conversion support" off \
@@ -108,11 +118,11 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE DBX DIO \
SEL_OPTIONS= yes
.for opt in ${ALL_OPTIONS}
-. if defined(WITH_${opt})
+. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
SEL_OPTIONS+= ${opt:L}
. endif
.endfor
-USE_PHP+= ${SEL_OPTIONS}
+USE_PHP= ${SEL_OPTIONS}
do-build:
@${DO_NADA}