aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-07-29 05:52:44 +0800
committerthierry <thierry@FreeBSD.org>2006-07-29 05:52:44 +0800
commit17b7ebe7bc6a86c047afe95a255a46aa6c54dc53 (patch)
tree70d312933ab482e97f0b87887fe8e10a1fb15b98 /lang
parent5e4ed30c3515d06c1b2431d0150f0d2472a45e6d (diff)
downloadfreebsd-ports-gnome-17b7ebe7bc6a86c047afe95a255a46aa6c54dc53.tar.gz
freebsd-ports-gnome-17b7ebe7bc6a86c047afe95a255a46aa6c54dc53.tar.zst
freebsd-ports-gnome-17b7ebe7bc6a86c047afe95a255a46aa6c54dc53.zip
- Remove the ancient pkg-plist: this port does not install f2c, and it
may be confusing; - Use PLIST_FILES; - Switch PREFIX / LOCALBASE.
Diffstat (limited to 'lang')
-rw-r--r--lang/f77/Makefile19
-rw-r--r--lang/f77/pkg-plist1
2 files changed, 8 insertions, 12 deletions
diff --git a/lang/f77/Makefile b/lang/f77/Makefile
index 6813c86e46ac..9eb1638092d9 100644
--- a/lang/f77/Makefile
+++ b/lang/f77/Makefile
@@ -16,30 +16,27 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fortran 77 driver utility for f2c and gcc
.ifdef GNU_CPP
-RUN_DEPENDS= ${PREFIX}/bin/f2c:${PORTSDIR}/lang/f2c
+RUN_DEPENDS= ${LOCALBASE}/bin/f2c:${PORTSDIR}/lang/f2c
.else
-RUN_DEPENDS= ${PREFIX}/bin/fpp:${PORTSDIR}/devel/fpp \
- ${PREFIX}/bin/f2c:${PORTSDIR}/lang/f2c
+RUN_DEPENDS= ${LOCALBASE}/bin/fpp:${PORTSDIR}/devel/fpp \
+ ${LOCALBASE}/bin/f2c:${PORTSDIR}/lang/f2c
.endif
# Set F77NAME to the name of the Fortran 77 wrapper.
F77NAME= ftn77
.ifdef GNU_CPP
-MAKE_ARGS= "CFLAGS= ${CFLAGS} -DPP_COMMAND='\"/usr/bin/cpp\"' \
- -DF2C_COMMAND='\"${PREFIX}/bin/f2c\"'"
+MAKE_ARGS= "CFLAGS= ${CFLAGS} -DPP_COMMAND='\"${CPP}\"' \
+ -DF2C_COMMAND='\"${LOCALBASE}/bin/f2c\"'"
.else
MAKE_ARGS= "CFLAGS= ${CFLAGS} -DSUN_FPP \
- -DPP_COMMAND='\"${PREFIX}/bin/fpp\"' \
- -DF2C_COMMAND='\"${PREFIX}/bin/f2c\"'"
+ -DPP_COMMAND='\"${LOCALBASE}/bin/fpp\"' \
+ -DF2C_COMMAND='\"${LOCALBASE}/bin/f2c\"'"
.endif
ALL_TARGET= depend all
MAN1= ${F77NAME}.1
-PLIST= ${WRKDIR}/PLIST
-
-pre-install:
- @${ECHO_CMD} 'bin/${F77NAME}' > ${PLIST}
+PLIST_FILES= bin/${F77NAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/f77 ${PREFIX}/bin/${F77NAME}
diff --git a/lang/f77/pkg-plist b/lang/f77/pkg-plist
deleted file mode 100644
index b03b441f1909..000000000000
--- a/lang/f77/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/fc