aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-01-12 11:42:23 +0800
committerstas <stas@FreeBSD.org>2011-01-12 11:42:23 +0800
commit2cabba457903169eae321226ef1c3fb18bff4090 (patch)
treecdf0e9256cd1e39707168872eb992c134655d07f /lang
parent15cc112c8c68ef2cc2dd9eb06c76b8f43590da72 (diff)
downloadfreebsd-ports-gnome-2cabba457903169eae321226ef1c3fb18bff4090.tar.gz
freebsd-ports-gnome-2cabba457903169eae321226ef1c3fb18bff4090.tar.zst
freebsd-ports-gnome-2cabba457903169eae321226ef1c3fb18bff4090.zip
- Fix pkg-plist in case when gdbm is not present.
- Add option to enable/disable GDBM. Reported by: pav Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/rubinius/Makefile9
-rw-r--r--lang/rubinius/pkg-plist2
2 files changed, 10 insertions, 1 deletions
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index e16dfc900077..9ebb2c822f5f 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -35,12 +35,21 @@ USE_PERL5_BUILD= yes
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
+OPTIONS= GDBM "Enable GDBM support" on
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not build on 6.X
.endif
+.if !defined(WITHOUT_GDBM) || exists(${LOCALBASE}/include/gdbm.h)
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+PLIST_SUB+= GDBM=""
+.else
+PLIST_SUB+= GDBM="@comment "
+.endif
+
post-extract:
@${MKDIR} ${WRKSRC}/vm/external_libs/prebuilt/
@${CP} ${DISTDIR}/${LLVMDIST} ${WRKSRC}/vm/external_libs/prebuilt/${LLVMDIST}
diff --git a/lang/rubinius/pkg-plist b/lang/rubinius/pkg-plist
index 5794b7f972f8..39d6b0aa947d 100644
--- a/lang/rubinius/pkg-plist
+++ b/lang/rubinius/pkg-plist
@@ -239,7 +239,7 @@ lib/ruby/rubinius/rubinius/1.2/lib/ext/dl/type.rb
lib/ruby/rubinius/rubinius/1.2/lib/ext/dl/type.rbc
lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/extconf.rb
lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/extconf.rbc
-lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/gdbm.so
+%%GDBM%%lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/gdbm.so
lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/test/test_gdbm.rb
lib/ruby/rubinius/rubinius/1.2/lib/ext/gdbm/test/test_gdbm.rbc
lib/ruby/rubinius/rubinius/1.2/lib/ext/melbourne/extconf.rb