aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-28 07:15:02 +0800
committerale <ale@FreeBSD.org>2004-07-28 07:15:02 +0800
commit4da3811a7ea92092ce6b537d6816c97ec9d651fe (patch)
tree760d30a943a241ff8793fda4cb61c09adc003a74 /lang
parent8e7826e34ec3a92d9dbecdc6af31a52dfef507fe (diff)
downloadfreebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.tar.gz
freebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.tar.zst
freebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.zip
MFphp4: Fix compilation of wddx extension.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext5
-rw-r--r--lang/php53/Makefile.ext5
2 files changed, 8 insertions, 2 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes