aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
commit591689f7f7301da41e08d95976e1318322254d75 (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /lang
parent241bc346167b5bfc4beac8d3b3044454cf6b0f87 (diff)
downloadfreebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.gz
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.zst
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Diffstat (limited to 'lang')
-rw-r--r--lang/cocor/Makefile3
-rw-r--r--lang/groovy/Makefile2
-rw-r--r--lang/lafontaine/Makefile3
-rw-r--r--lang/malbolge/Makefile2
-rw-r--r--lang/scala-docs/Makefile2
-rw-r--r--lang/scheme48/Makefile3
-rw-r--r--lang/x10/Makefile2
-rw-r--r--lang/yabasic/Makefile2
8 files changed, 19 insertions, 0 deletions
diff --git a/lang/cocor/Makefile b/lang/cocor/Makefile
index 6fc3046120d9..55d95e57dfce 100644
--- a/lang/cocor/Makefile
+++ b/lang/cocor/Makefile
@@ -24,6 +24,9 @@ ALL_TARGET= all1
MAN1= ${PORTNAME}.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/lang/groovy/Makefile b/lang/groovy/Makefile
index a77fda622362..77042a71ea42 100644
--- a/lang/groovy/Makefile
+++ b/lang/groovy/Makefile
@@ -22,6 +22,8 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
DATAFILES= ANTLR-LICENSE.txt ASM-LICENSE.txt CLI-LICENSE.txt JSR223-LICENSE.txt LICENSE.txt conf lib
SCRIPTFILES= groovy groovyConsole groovyc groovysh java2groovy startGroovy
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/lang/lafontaine/Makefile b/lang/lafontaine/Makefile
index 735c172e6a49..724f9c61a532 100644
--- a/lang/lafontaine/Makefile
+++ b/lang/lafontaine/Makefile
@@ -20,6 +20,9 @@ USE_CSTD= gnu89
LDFLAGS+= -lm
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/lang/malbolge/Makefile b/lang/malbolge/Makefile
index 35b4531fc748..c867bdba127d 100644
--- a/lang/malbolge/Makefile
+++ b/lang/malbolge/Makefile
@@ -17,6 +17,8 @@ NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/malbolge ${PREFIX}/bin
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/lang/scala-docs/Makefile b/lang/scala-docs/Makefile
index bfe82d015fd2..dc6a14f54293 100644
--- a/lang/scala-docs/Makefile
+++ b/lang/scala-docs/Makefile
@@ -15,6 +15,8 @@ NO_BUILD= yes
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MDOCS}
diff --git a/lang/scheme48/Makefile b/lang/scheme48/Makefile
index 4619aedfeda6..fb6c55e74f45 100644
--- a/lang/scheme48/Makefile
+++ b/lang/scheme48/Makefile
@@ -21,6 +21,9 @@ GNU_CONFIGURE= yes
MAN1= scheme48.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
PLIST_SUB+= VER=${PORTVERSION}
diff --git a/lang/x10/Makefile b/lang/x10/Makefile
index 25a98fdf00e9..df3a1e94010e 100644
--- a/lang/x10/Makefile
+++ b/lang/x10/Makefile
@@ -38,6 +38,8 @@ BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake \
WRKSRC= ${WRKDIR}/x10.dist
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/lang/yabasic/Makefile b/lang/yabasic/Makefile
index 8b1fb9765fc4..80eec991fa46 100644
--- a/lang/yabasic/Makefile
+++ b/lang/yabasic/Makefile
@@ -17,6 +17,8 @@ GNU_CONFIGURE= yes
PORTDOCS= yabasic.htm
PLIST_FILES= bin/yabasic man/man1/yabasic.1.gz
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
bee87ae6'>- Fix error described in "http://lists.freebsd.org/pipermail/freebsd-question...alepulver2007-02-192-0/+24 * - Fix distname.jmelo2007-02-161-1/+1 * - It has been marked as IGNORE on 5.x and above for more than 3 years.rafan2007-02-141-0/+3 * - It has been broken for 2+ years. Mark it deprecated and scheduled to berafan2007-02-141-0/+3 * - Use MASTER_SITE_SUNSITErafan2007-02-141-2/+2 * - Update mastersite to make it fetchable again.jmelo2007-02-131-1/+2 * - Update mastersites to make it fetchable again.jmelo2007-02-131-1/+2 * - Fix distname to make it fetchable again.jmelo2007-02-131-2/+3 * Schedule these broken ports for removal on 2007-04-10 if they are stillkris2007-02-112-0/+4 * Re-add OICQ with updated version (1.3)delphij2007-02-096-0/+78 * Add CONFLICTS with unrar-*ache2007-02-091-0/+2 * - Add local distfiles mirror until next release.rafan2007-02-081-1/+2 * 2007-02-06 irc/xchat-systray-plugin: Functionality is now included in xchatmiwi2007-02-085-59/+0 * - Fix fetch. Short master site macro does not work in PATCH_SITESrafan2007-02-072-2/+4 * - Update to 0.07leeym2007-02-072-12/+6 * From the "who gave this guy a commit bit" dept.:lofi2007-02-061-1/+0 * Post-import bugfixorama:lofi2007-02-065-0/+84 * - Fix problem with GTK_IM_MODULE set to gcin [1]rafan2007-02-064-20/+20 * Add qt4, a multiplatform C++ application frameworklofi2007-02-06