aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-02-03 18:34:08 +0800
committerbapt <bapt@FreeBSD.org>2014-02-03 18:34:08 +0800
commit61b1468173b1c5aa662b3733dc58e04df3dc815e (patch)
treea5a7487108d735162537f14360a7446ee3dd5149 /lang
parentd5852f0f515046452235e694da52b98b8f7a5f8a (diff)
downloadfreebsd-ports-gnome-61b1468173b1c5aa662b3733dc58e04df3dc815e.tar.gz
freebsd-ports-gnome-61b1468173b1c5aa662b3733dc58e04df3dc815e.tar.zst
freebsd-ports-gnome-61b1468173b1c5aa662b3733dc58e04df3dc815e.zip
Use regular CC and CXX instead of custom CLANGXX/CLANG
That fixes build after .pre.mk removal as well as simplify the makefile Reported by: tijl
Diffstat (limited to 'lang')
-rw-r--r--lang/libobjc2/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index dd0eccd4c398..fac3713bd26d 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -22,11 +22,11 @@ _CLANG!= if [ -f /usr/bin/clang ] ; then /usr/bin/clang --version | head -1 | \
.if ${_CLANG} < 33
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang33:${PORTSDIR}/lang/clang33
-CLANG= ${LOCALBASE}/bin/clang33
-CLANGXX= ${LOCALBASE}/bin/clang++33
+CC= ${LOCALBASE}/bin/clang33
+CXX= ${LOCALBASE}/bin/clang++33
.else
-CLANG= /usr/bin/clang
-CLANGXX= /usr/bin/clang++
+CC= /usr/bin/clang
+CXX= /usr/bin/clang++
.endif
SHLIB_MAJOR= 4
@@ -42,8 +42,7 @@ PLIST_SUB+= WITH_SEPARATECXX=""
PLIST_SUB+= WITH_SEPARATECXX="@comment "
.endif
-CMAKE_ARGS+= -DLIB_INSTALL_PATH=lib -DCMAKE_ASM_COMPILER=${CLANG}
-CMAKE_ARGS+= -DCMAKE_C_COMPILER=${CLANG} -DCMAKE_CXX_COMPILER=${CLANGXX}
+CMAKE_ARGS+= -DLIB_INSTALL_PATH=lib
CMAKE_ARGS+= -DTESTS=OFF
# This shouldn't be needed, but our llvm port installs llvm-config with a silly
# name...