aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-29 19:22:33 +0800
committerbapt <bapt@FreeBSD.org>2014-01-29 19:22:33 +0800
commit67944201df0ce13e4628e4e3c033266c024dd0da (patch)
tree636b2c1733ab334a18fcaf8408a10e7c49d363ea /lang
parent70a5405051d1d3a8b8ba3a153a4a6a31ded52b38 (diff)
downloadfreebsd-ports-gnome-67944201df0ce13e4628e4e3c033266c024dd0da.tar.gz
freebsd-ports-gnome-67944201df0ce13e4628e4e3c033266c024dd0da.tar.zst
freebsd-ports-gnome-67944201df0ce13e4628e4e3c033266c024dd0da.zip
Add jimtcl into the ports tree
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/jimtcl/Makefile25
-rw-r--r--lang/jimtcl/distinfo2
-rw-r--r--lang/jimtcl/pkg-descr8
-rw-r--r--lang/jimtcl/pkg-plist11
5 files changed, 47 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 4a7e1683bb36..48875be6e1ca 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -134,6 +134,7 @@
SUBDIR += ironpython
SUBDIR += itcl
SUBDIR += jakarta-commons-jelly
+ SUBDIR += jimtcl
SUBDIR += jruby
SUBDIR += jython
SUBDIR += kawa
diff --git a/lang/jimtcl/Makefile b/lang/jimtcl/Makefile
new file mode 100644
index 000000000000..bc34cececfdf
--- /dev/null
+++ b/lang/jimtcl/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= jimtcl
+PORTVERSION= 0.74
+CATEGORIES= lang tcl
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Small footprint implementation of the Tcl programming language
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= msteveb
+GH_COMMIT= 9a3562c
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --full \
+ --enable-shared \
+ --disable-docs
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/jimsh \
+ ${STAGEDIR}${PREFIX}/lib/libjim.so.0.74
+
+.include <bsd.port.mk>
diff --git a/lang/jimtcl/distinfo b/lang/jimtcl/distinfo
new file mode 100644
index 000000000000..994c84a563d4
--- /dev/null
+++ b/lang/jimtcl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jimtcl-0.74.tar.gz) = 8b0a7b290dfa29102df822dcb16ca416f2d6a39f81f35a77f4e3abd2a8a4ff04
+SIZE (jimtcl-0.74.tar.gz) = 2212559
diff --git a/lang/jimtcl/pkg-descr b/lang/jimtcl/pkg-descr
new file mode 100644
index 000000000000..ebee51171e3d
--- /dev/null
+++ b/lang/jimtcl/pkg-descr
@@ -0,0 +1,8 @@
+Jim is an opensource small-footprint implementation of the Tcl programming
+language. It implements a large subset of Tcl and adds new features like
+references with garbage collection, closures, built-in Object Oriented
+Programming system, Functional Programming commands, first-class arrays and
+UTF-8 support. All this with a binary size of about 100-200kB (depending upon
+selected options).
+
+WWW: http://jim.tcl.tk
diff --git a/lang/jimtcl/pkg-plist b/lang/jimtcl/pkg-plist
new file mode 100644
index 000000000000..f898b7bf0240
--- /dev/null
+++ b/lang/jimtcl/pkg-plist
@@ -0,0 +1,11 @@
+bin/build-jim-ext
+bin/jimsh
+include/jim-config.h
+include/jim-eventloop.h
+include/jim-signal.h
+include/jim-subcmd.h
+include/jim-win32compat.h
+include/jim.h
+lib/jim/README.extensions
+lib/libjim.so.0.74
+@dirrmtry lib/jim