aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-20 07:25:22 +0800
committerale <ale@FreeBSD.org>2004-07-20 07:25:22 +0800
commit76ac475707bc7d006296a7c6b2d7c3f8b1b9994b (patch)
tree1c83dd5542d84fe1d853eac01b2804288339d596 /lang
parent1fe3ec4af08fc220d424dd0e6e75dc15d0c6bbbb (diff)
downloadfreebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.tar.gz
freebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.tar.zst
freebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.zip
- Document DEFAULT_PHP_VER and BROKEN_WITH_PHP
- Set them acccordingly in PHP extensions ports (Now I really need some rest, see you tomorrow)
Diffstat (limited to 'lang')
-rw-r--r--lang/php4-extensions/Makefile4
-rw-r--r--lang/php4/Makefile.ext2
-rw-r--r--lang/php5-extensions/Makefile4
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
5 files changed, 14 insertions, 0 deletions
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index b9cd5b6bbafc..75c9b62f0c43 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -18,6 +18,10 @@ COMMENT= A "meta-port" to install PHP extensions
NO_BUILD= # none
+USE_PHP= yes
+DEFAULT_PHP_VER=4
+BROKEN_WITH_PHP=5
+
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
CALENDAR "calendar conversion support" off \
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 3c240d1b2dbe..f2a44a29a45b 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -3,6 +3,8 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
+DEFAULT_PHP_VER=4
+BROKEN_WITH_PHP=5
WRKSRC= ${WRKDIR}/php-${PORTVERSION:S/.r/RC/}/ext/${PHP_MODNAME}
PATCHDIR= ${.CURDIR}/files
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index c15fc5332705..4b8f2b9c104c 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -18,6 +18,10 @@ COMMENT= A "meta-port" to install PHP extensions
NO_BUILD= # none
+USE_PHP= yes
+DEFAULT_PHP_VER=5
+BROKEN_WITH_PHP=4
+
OPTIONS= BCMATH "bc style precision math functions" off \
BZ2 "bzip2 library support" off \
CALENDAR "calendar conversion support" off \
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 93c0ca2fc30a..313db804cc85 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -3,6 +3,8 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
+DEFAULT_PHP_VER=5
+BROKEN_WITH_PHP=4
WRKSRC= ${WRKDIR}/php-${PORTVERSION:S/.r/RC/}/ext/${PHP_MODNAME}
PATCHDIR= ${.CURDIR}/files
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 93c0ca2fc30a..313db804cc85 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -3,6 +3,8 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
+DEFAULT_PHP_VER=5
+BROKEN_WITH_PHP=4
WRKSRC= ${WRKDIR}/php-${PORTVERSION:S/.r/RC/}/ext/${PHP_MODNAME}
PATCHDIR= ${.CURDIR}/files