aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2009-07-06 18:21:17 +0800
committerflz <flz@FreeBSD.org>2009-07-06 18:21:17 +0800
commit7fd998c19fd1115c102cf658ffa64a88ec75841d (patch)
tree7213aeecf33dcee19d52699c8cdb9c4ae2711a97 /lang
parent60cc87766c3af08e602b0dface8d867653a24503 (diff)
downloadfreebsd-ports-gnome-7fd998c19fd1115c102cf658ffa64a88ec75841d.tar.gz
freebsd-ports-gnome-7fd998c19fd1115c102cf658ffa64a88ec75841d.tar.zst
freebsd-ports-gnome-7fd998c19fd1115c102cf658ffa64a88ec75841d.zip
Update lang/mono to 2.4.2.
PR: ports/136350 Submitted by: Romain Tartiere
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile2
-rw-r--r--lang/mono/distinfo6
-rw-r--r--lang/mono/files/patch-mono_mini_mini-x86.c76
3 files changed, 4 insertions, 80 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index fb456b40c2a9..512006fd39ca 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mono
-PORTVERSION= 2.4
+PORTVERSION= 2.4.2
CATEGORIES= lang
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index a9af71313ede..6dc498439fd6 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,3 +1,3 @@
-MD5 (mono-2.4.tar.bz2) = da2bf1c0aba2958d26c5e8a9a49fd9d1
-SHA256 (mono-2.4.tar.bz2) = 653544a91374102bf473458a09f1e779955083b6d86682f171ab58a8446511c7
-SIZE (mono-2.4.tar.bz2) = 24861051
+MD5 (mono-2.4.2.tar.bz2) = f086227f3cd4cecb5c1fe0f566760f81
+SHA256 (mono-2.4.2.tar.bz2) = 994324e776af7b77c9feab5cd98eb28bffbf182cf07a17b282e7ec8e181904d1
+SIZE (mono-2.4.2.tar.bz2) = 24759918
diff --git a/lang/mono/files/patch-mono_mini_mini-x86.c b/lang/mono/files/patch-mono_mini_mini-x86.c
deleted file mode 100644
index b9b8bc7dc09f..000000000000
--- a/lang/mono/files/patch-mono_mini_mini-x86.c
+++ /dev/null
@@ -1,76 +0,0 @@
-
-$FreeBSD$
-
---- mono/mini/mini-x86.c.orig
-+++ mono/mini/mini-x86.c
-@@ -1068,26 +1068,15 @@
- }
-
- if (sig->ret && MONO_TYPE_ISSTRUCT (sig->ret)) {
-- MonoInst *vtarg;
--
- if (cinfo->ret.storage == ArgValuetypeInReg) {
-- if (cinfo->ret.pair_storage [0] == ArgInIReg && cinfo->ret.pair_storage [1] == ArgNone) {
- /*
- * Tell the JIT to use a more efficient calling convention: call using
- * OP_CALL, compute the result location after the call, and save the
- * result there.
- */
- call->vret_in_reg = TRUE;
-- } else {
-- /*
-- * The valuetype is in EAX:EDX after the call, needs to be copied to
-- * the stack. Save the address here, so the call instruction can
-- * access it.
-- */
-- MONO_INST_NEW (cfg, vtarg, OP_X86_PUSH);
-- vtarg->sreg1 = call->vret_var->dreg;
-- MONO_ADD_INS (cfg->cbb, vtarg);
-- }
-+ if (call->vret_var)
-+ NULLIFY_INS (call->vret_var);
- }
- }
-
-@@ -1802,9 +1791,6 @@
- static guint8*
- emit_move_return_value (MonoCompile *cfg, MonoInst *ins, guint8 *code)
- {
-- CallInfo *cinfo;
-- int quad;
--
- /* Move return value to the target register */
- switch (ins->opcode) {
- case OP_CALL:
-@@ -1813,31 +1799,6 @@
- if (ins->dreg != X86_EAX)
- x86_mov_reg_reg (code, ins->dreg, X86_EAX, 4);
- break;
-- case OP_VCALL:
-- case OP_VCALL_REG:
-- case OP_VCALL_MEMBASE:
-- case OP_VCALL2:
-- case OP_VCALL2_REG:
-- case OP_VCALL2_MEMBASE:
-- cinfo = get_call_info (cfg->generic_sharing_context, cfg->mempool, ((MonoCallInst*)ins)->signature, FALSE);
-- if (cinfo->ret.storage == ArgValuetypeInReg) {
-- /* Pop the destination address from the stack */
-- x86_pop_reg (code, X86_ECX);
--
-- for (quad = 0; quad < 2; quad ++) {
-- switch (cinfo->ret.pair_storage [quad]) {
-- case ArgInIReg:
-- g_assert (cinfo->ret.pair_regs [quad] != X86_ECX);
-- x86_mov_membase_reg (code, X86_ECX, (quad * sizeof (gpointer)), cinfo->ret.pair_regs [quad], sizeof (gpointer));
-- break;
-- case ArgNone:
-- break;
-- default:
-- g_assert_not_reached ();
-- }
-- }
-- }
-- break;
- case OP_FCALL: {
- MonoCallInst *call = (MonoCallInst*)ins;
- if (call->method && !mono_method_signature (call->method)->ret->byref && mono_method_signature (call->method)->ret->type == MONO_TYPE_R4) {