aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-04-23 04:55:48 +0800
committerwxs <wxs@FreeBSD.org>2009-04-23 04:55:48 +0800
commit81bdf2ebd429b6afcc75cfe682fb6e71e1b8a681 (patch)
tree022861f7bc2011276b92f07b82d6c8fefcce2944 /lang
parentb04afeb832dd004345b96d20021c332b68ab51f7 (diff)
downloadfreebsd-ports-gnome-81bdf2ebd429b6afcc75cfe682fb6e71e1b8a681.tar.gz
freebsd-ports-gnome-81bdf2ebd429b6afcc75cfe682fb6e71e1b8a681.tar.zst
freebsd-ports-gnome-81bdf2ebd429b6afcc75cfe682fb6e71e1b8a681.zip
- Fix build on -CURRENT.
PR: ports/133598 Submitted by: Kai Wang <kaiwang27@gmail.com> Approved by: Takeshi MUTOH <mutoh@openedu.org> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/squeak-dev/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h11
-rw-r--r--lang/squeak-dev/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in11
-rw-r--r--lang/squeak/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h11
-rw-r--r--lang/squeak/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in11
4 files changed, 22 insertions, 22 deletions
diff --git a/lang/squeak-dev/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h b/lang/squeak-dev/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h
new file mode 100644
index 000000000000..dbfac8c0722b
--- /dev/null
+++ b/lang/squeak-dev/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h
@@ -0,0 +1,11 @@
+--- platforms/Cross/plugins/Mpeg3Plugin/libmpeg/mpeg3io.h.orig 2006-04-15 01:17:20.000000000 +0200
++++ platforms/Cross/plugins/Mpeg3Plugin/libmpeg/mpeg3io.h 2009-04-11 14:54:38.000000000 +0200
+@@ -35,7 +35,7 @@
+ #endif
+
+ #define mpeg3io_total_bytes(fs) (((mpeg3_fs_t *)(fs))->total_bytes)
+-inline int mpeg3io_fgetc(mpeg3_fs_t *fs);
++int mpeg3io_fgetc(mpeg3_fs_t *fs);
+
+ static inline unsigned int mpeg3io_read_int32(mpeg3_fs_t *fs)
+ {
diff --git a/lang/squeak-dev/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in b/lang/squeak-dev/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in
deleted file mode 100644
index 3c0fd9e7894e..000000000000
--- a/lang/squeak-dev/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- platforms/unix/plugins/SqueakFFIPrims/Makefile.in.orig Sun Mar 20 05:38:18 2005
-+++ platforms/unix/plugins/SqueakFFIPrims/Makefile.in Sun Feb 26 00:08:03 2006
-@@ -14,7 +14,7 @@
- XINCLUDES = [includes]
-
- $(TARGET) : $(OBJS) Makefile
-- $(LINK) $(TARGET) $(OBJS)
-+ $(LINK) $(TARGET) $(OBJS) -lffi
- $(RANLIB) $(TARGET)
-
- [make_targets]
diff --git a/lang/squeak/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h b/lang/squeak/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h
new file mode 100644
index 000000000000..dbfac8c0722b
--- /dev/null
+++ b/lang/squeak/files/patch-platforms__Cross__plugins__Mpeg3Plugin__libmpeg__mpeg3io.h
@@ -0,0 +1,11 @@
+--- platforms/Cross/plugins/Mpeg3Plugin/libmpeg/mpeg3io.h.orig 2006-04-15 01:17:20.000000000 +0200
++++ platforms/Cross/plugins/Mpeg3Plugin/libmpeg/mpeg3io.h 2009-04-11 14:54:38.000000000 +0200
+@@ -35,7 +35,7 @@
+ #endif
+
+ #define mpeg3io_total_bytes(fs) (((mpeg3_fs_t *)(fs))->total_bytes)
+-inline int mpeg3io_fgetc(mpeg3_fs_t *fs);
++int mpeg3io_fgetc(mpeg3_fs_t *fs);
+
+ static inline unsigned int mpeg3io_read_int32(mpeg3_fs_t *fs)
+ {
diff --git a/lang/squeak/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in b/lang/squeak/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in
deleted file mode 100644
index 3c0fd9e7894e..000000000000
--- a/lang/squeak/files/patch-platforms__unix__plugins__SqueakFFIPrims__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- platforms/unix/plugins/SqueakFFIPrims/Makefile.in.orig Sun Mar 20 05:38:18 2005
-+++ platforms/unix/plugins/SqueakFFIPrims/Makefile.in Sun Feb 26 00:08:03 2006
-@@ -14,7 +14,7 @@
- XINCLUDES = [includes]
-
- $(TARGET) : $(OBJS) Makefile
-- $(LINK) $(TARGET) $(OBJS)
-+ $(LINK) $(TARGET) $(OBJS) -lffi
- $(RANLIB) $(TARGET)
-
- [make_targets]