aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-04-18 16:20:59 +0800
committergahr <gahr@FreeBSD.org>2013-04-18 16:20:59 +0800
commit8816fe6beebb0a2087730e039710b251b98c7a3a (patch)
treed5d9c36f74d1ecd4b3d080ec234fbbd428a64fa1 /lang
parent2079100a482ae78bf7086c697d42746da9c97ba5 (diff)
downloadfreebsd-ports-gnome-8816fe6beebb0a2087730e039710b251b98c7a3a.tar.gz
freebsd-ports-gnome-8816fe6beebb0a2087730e039710b251b98c7a3a.tar.zst
freebsd-ports-gnome-8816fe6beebb0a2087730e039710b251b98c7a3a.zip
- Fix a long standing problem in tclConfig.sh and tkConfig.sh, where paths
were set based on WRKSRC instead of PREFIX. This mainly affected TEA-based extensions that source tclConfig.sh / tkConfig.sh to set important variables. An example is TCL_SRC_DIR, which is used to locate Tcl/Tk private header files such as tclUnixPort.h or tkUnixPort.h. This variable was previously set to WRKSRC, which caused ports to need additional tweaks to CFLAGS or CONFIGURE_ARGS. It should now be possible to build TEA-based extensions by specifying only the CONFIGURE_ARGS --with-tcl=${TCL_LIBDIR} / --with-tk=${TK_LIBDIR}. Feature safe: yes Approved by: bapt (portmgr)
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl84/Makefile8
-rw-r--r--lang/tcl85/Makefile8
-rw-r--r--lang/tcl86/Makefile6
3 files changed, 22 insertions, 0 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 8308b2e3c463..7a510a8d76c6 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -55,6 +55,14 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|@TCL_BUILD_LIB_SPEC@|@TCL_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_SPEC@|@TCL_STUB_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_PATH@|@TCL_STUB_LIB_PATH@|; \
+ s|@TCL_SRC_DIR@|${PREFIX}/include/tcl${TCL_VER}|' \
+ ${WRKSRC}/tclConfig.sh.in
+
post-configure:
${REINPLACE_CMD} \
-e 's,-DNO_MEMMOVE=1,,' -e 's,-DNO_STRING_H=1,,' \
diff --git a/lang/tcl85/Makefile b/lang/tcl85/Makefile
index 6a3cefdddbed..a343305e5af3 100644
--- a/lang/tcl85/Makefile
+++ b/lang/tcl85/Makefile
@@ -70,6 +70,14 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--without-tzdata
.endif
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|@TCL_BUILD_LIB_SPEC@|@TCL_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_SPEC@|@TCL_STUB_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_PATH@|@TCL_STUB_LIB_PATH@|; \
+ s|@TCL_SRC_DIR@|${PREFIX}/include/tcl${TCL_VER}|' \
+ ${WRKSRC}/tclConfig.sh.in
+
post-configure:
${REINPLACE_CMD} \
-e 's,-DNO_MEMMOVE=1,,' -e 's,-DNO_STRING_H=1,,' \
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index c2bd5281f580..ffb1b01901dd 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -77,6 +77,12 @@ BROKEN= Does not build on arm
.endif
post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|@TCL_BUILD_LIB_SPEC@|@TCL_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_SPEC@|@TCL_STUB_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_PATH@|@TCL_STUB_LIB_PATH@|; \
+ s|@TCL_SRC_DIR@|${PREFIX}/include/tcl${TCL_VER}|' \
+ ${WRKSRC}/tclConfig.sh.in
.if !${PORT_OPTIONS:MTCLMAN}
@${FIND} ${WRKSRC}/../pkgs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
-e '/^install:/s|install-doc||'