aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-10 13:31:20 +0800
committerperky <perky@FreeBSD.org>2006-10-10 13:31:20 +0800
commit913fcec230b60a8309c9fd417e14c6a944502566 (patch)
tree768f12da56852c876e5095aadf3e458cd6c611c0 /lang
parentf607e00504432e2d7dbf0af5a2139b953df38fe2 (diff)
downloadfreebsd-ports-gnome-913fcec230b60a8309c9fd417e14c6a944502566.tar.gz
freebsd-ports-gnome-913fcec230b60a8309c9fd417e14c6a944502566.tar.zst
freebsd-ports-gnome-913fcec230b60a8309c9fd417e14c6a944502566.zip
Fix build with WITH_FPECTL=yes on i386.
PR: 104243 Submitted by: S Roberts <stacey@vickiandstacey.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python25/Makefile1
-rw-r--r--lang/python26/Makefile1
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python30/Makefile1
-rw-r--r--lang/python31/Makefile1
-rw-r--r--lang/python32/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif