aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-07 21:11:35 +0800
committerrafan <rafan@FreeBSD.org>2006-08-07 21:11:35 +0800
commit989c2eb80e55bcc77068d233ef3ef5f13ec93bbf (patch)
tree9894e15b63a647788e5f280b1639d0c529beae06 /lang
parentcf6fba3315d2ee92d6744985c5d9a303501fed1c (diff)
downloadfreebsd-ports-gnome-989c2eb80e55bcc77068d233ef3ef5f13ec93bbf.tar.gz
freebsd-ports-gnome-989c2eb80e55bcc77068d233ef3ef5f13ec93bbf.tar.zst
freebsd-ports-gnome-989c2eb80e55bcc77068d233ef3ef5f13ec93bbf.zip
Add sather-specification 000328, specification of the Sather programming
language. PR: ports/101424 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/sather-specification/Makefile35
-rw-r--r--lang/sather-specification/distinfo3
-rw-r--r--lang/sather-specification/pkg-descr3
-rw-r--r--lang/sather-specification/pkg-plist85
5 files changed, 127 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 8f62732dc658..d1f9e2231776 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -261,6 +261,7 @@
SUBDIR += ruby16_static
SUBDIR += ruby18
SUBDIR += ruby18_static
+ SUBDIR += sather-specification
SUBDIR += sbcl
SUBDIR += scheme48
SUBDIR += schemetoc
diff --git a/lang/sather-specification/Makefile b/lang/sather-specification/Makefile
new file mode 100644
index 000000000000..5cf73ce9431a
--- /dev/null
+++ b/lang/sather-specification/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sather-specification
+# Date created: 5 August 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= specification
+PORTVERSION= 000328
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR=sather/Doc
+PKGNAMEPREFIX= sather-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}.html
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Specification of the Sather programming language
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+DOCSDIR= ${PREFIX}/share/doc/sather/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DOCSDIR}
+ @${TAR} -xf ${DISTDIR}/${DISTFILES} -C ${DOCSDIR}
+ @${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ ${CHOWN} -R ${SHAREOWN} ${DOCSDIR}/
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= tar is too old
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/sather-specification/distinfo b/lang/sather-specification/distinfo
new file mode 100644
index 000000000000..ba26ebd7c17b
--- /dev/null
+++ b/lang/sather-specification/distinfo
@@ -0,0 +1,3 @@
+MD5 (sather-specification-000328.html.tar.gz) = a1ac828600d76e1a6ae7752906af19a7
+SHA256 (sather-specification-000328.html.tar.gz) = 8d63936d9e031f9d7b5f640b74282d4db944a293eb2aed3be96b5d201333061d
+SIZE (sather-specification-000328.html.tar.gz) = 65633
diff --git a/lang/sather-specification/pkg-descr b/lang/sather-specification/pkg-descr
new file mode 100644
index 000000000000..c321b2580338
--- /dev/null
+++ b/lang/sather-specification/pkg-descr
@@ -0,0 +1,3 @@
+Official specification of the Sather programming language.
+
+WWW: http://www.gnu.org/software/sather/
diff --git a/lang/sather-specification/pkg-plist b/lang/sather-specification/pkg-plist
new file mode 100644
index 000000000000..bc71f24702cd
--- /dev/null
+++ b/lang/sather-specification/pkg-plist
@@ -0,0 +1,85 @@
+%%DOCSDIR%%/specification.html/HTML.manifest
+%%DOCSDIR%%/specification.html/abstractclasses.html
+%%DOCSDIR%%/specification.html/andexpressions.html
+%%DOCSDIR%%/specification.html/ansicinterface.html
+%%DOCSDIR%%/specification.html/arraycreationexpressions.html
+%%DOCSDIR%%/specification.html/assignmentstatements.html
+%%DOCSDIR%%/specification.html/attachclasses.html
+%%DOCSDIR%%/specification.html/attachstatement.html
+%%DOCSDIR%%/specification.html/basicexpressions.html
+%%DOCSDIR%%/specification.html/basicexpressions1112.html
+%%DOCSDIR%%/specification.html/basicexpressions1351.html
+%%DOCSDIR%%/specification.html/basicstatements.html
+%%DOCSDIR%%/specification.html/basicstatements849.html
+%%DOCSDIR%%/specification.html/basicstatements885.html
+%%DOCSDIR%%/specification.html/basicstatements914.html
+%%DOCSDIR%%/specification.html/basicstatements941.html
+%%DOCSDIR%%/specification.html/builtinclasses.html
+%%DOCSDIR%%/specification.html/characterliteralexpressions.html
+%%DOCSDIR%%/specification.html/classelements.html
+%%DOCSDIR%%/specification.html/classelements556.html
+%%DOCSDIR%%/specification.html/classelements578.html
+%%DOCSDIR%%/specification.html/closures.html
+%%DOCSDIR%%/specification.html/closures1743.html
+%%DOCSDIR%%/specification.html/codeinclusion.html
+%%DOCSDIR%%/specification.html/conventions.html
+%%DOCSDIR%%/specification.html/conventions2127.html
+%%DOCSDIR%%/specification.html/conventions2178.html
+%%DOCSDIR%%/specification.html/conventions2210.html
+%%DOCSDIR%%/specification.html/conventions2234.html
+%%DOCSDIR%%/specification.html/creationexpressions.html
+%%DOCSDIR%%/specification.html/distributedextension.html
+%%DOCSDIR%%/specification.html/distributedextension3213.html
+%%DOCSDIR%%/specification.html/exceptions.html
+%%DOCSDIR%%/specification.html/exceptions1861.html
+%%DOCSDIR%%/specification.html/extensionpart.html
+%%DOCSDIR%%/specification.html/initialexpressions.html
+%%DOCSDIR%%/specification.html/introduction.html
+%%DOCSDIR%%/specification.html/introduction48.html
+%%DOCSDIR%%/specification.html/iteratordefinitions.html
+%%DOCSDIR%%/specification.html/languageinterfaceextensions.html
+%%DOCSDIR%%/specification.html/lexicalstructure.html
+%%DOCSDIR%%/specification.html/literalexpressions.html
+%%DOCSDIR%%/specification.html/literalexpressions1026.html
+%%DOCSDIR%%/specification.html/literalexpressions1076.html
+%%DOCSDIR%%/specification.html/lockclasses.html
+%%DOCSDIR%%/specification.html/loopsanditerators.html
+%%DOCSDIR%%/specification.html/loopsanditerators1573.html
+%%DOCSDIR%%/specification.html/loopsanditerators1602.html
+%%DOCSDIR%%/specification.html/loopsanditerators1615.html
+%%DOCSDIR%%/specification.html/loopsanditerators1628.html
+%%DOCSDIR%%/specification.html/main.html
+%%DOCSDIR%%/specification.html/memoryconsistency.html
+%%DOCSDIR%%/specification.html/methodcallexpressions.html
+%%DOCSDIR%%/specification.html/newexpressions.html
+%%DOCSDIR%%/specification.html/parameterization.html
+%%DOCSDIR%%/specification.html/parloopstatement.html
+%%DOCSDIR%%/specification.html/quitstatements.html
+%%DOCSDIR%%/specification.html/raisestatements.html
+%%DOCSDIR%%/specification.html/resultexpressions.html
+%%DOCSDIR%%/specification.html/returnstatements.html
+%%DOCSDIR%%/specification.html/routinedefinitions.html
+%%DOCSDIR%%/specification.html/safetyfeatures.html
+%%DOCSDIR%%/specification.html/safetyfeatures1905.html
+%%DOCSDIR%%/specification.html/sather-specification.html
+%%DOCSDIR%%/specification.html/specialfeaturenames.html
+%%DOCSDIR%%/specification.html/specificationpart.html
+%%DOCSDIR%%/specification.html/stringliteralexpressions.html
+%%DOCSDIR%%/specification.html/stubssection.html
+%%DOCSDIR%%/specification.html/style.css
+%%DOCSDIR%%/specification.html/synchronizationextension.html
+%%DOCSDIR%%/specification.html/synchronizationextension2768.html
+%%DOCSDIR%%/specification.html/synchronizationextension3041.html
+%%DOCSDIR%%/specification.html/syntacticsugarexpressions.html
+%%DOCSDIR%%/specification.html/sysclass.html
+%%DOCSDIR%%/specification.html/threadedextension.html
+%%DOCSDIR%%/specification.html/typesandclasses.html
+%%DOCSDIR%%/specification.html/typesandclasses271.html
+%%DOCSDIR%%/specification.html/typesandclasses353.html
+%%DOCSDIR%%/specification.html/typesandclasses430.html
+%%DOCSDIR%%/specification.html/void-test.html
+%%DOCSDIR%%/specification.html/voidexpressions.html
+%%DOCSDIR%%/specification.html/withnearstatement.html
+@dirrm %%DOCSDIR%%/specification.html
+@dirrm %%DOCSDIR%%
+@dirrmtry share/doc/sather