aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-08-11 06:42:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-08-11 06:42:41 +0800
commita6d9f8904857be382f89a07a860e9254bd51ec4b (patch)
tree8d039a3a89ba8ae5308cb13fc8f4b3a79ce40e7c /lang
parent97e3eba3ae9de06a0045e38274d7b4d965dd0550 (diff)
downloadfreebsd-ports-gnome-a6d9f8904857be382f89a07a860e9254bd51ec4b.tar.gz
freebsd-ports-gnome-a6d9f8904857be382f89a07a860e9254bd51ec4b.tar.zst
freebsd-ports-gnome-a6d9f8904857be382f89a07a860e9254bd51ec4b.zip
- Add tolua++50 port similar to tolua++
- tolua++50 is to be used with lua 5.0 and tolua++ with lua 5.1, update depends accordingly - Depend on lua with USE_LUA instead of LIB_DEPEND - Make both ports install files to (lua version)-specific directories, so they can coexist peacefully in a manner similar to tolua/tolua50. - Take maintainership - Add distfile mirror - Remove USE_LDCONFIG (ports do not install any shared libs) - Fix pkg-descr Approved by: miwi (mentor implicit)
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/tolua++/Makefile23
-rw-r--r--lang/tolua++/pkg-descr6
-rw-r--r--lang/tolua++/pkg-plist7
-rw-r--r--lang/tolua++50/Makefile20
-rw-r--r--lang/tolua++50/pkg-descr6
-rw-r--r--lang/tolua++50/pkg-plist7
7 files changed, 44 insertions, 26 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 2e42c295e813..95b24e8ce907 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -333,6 +333,7 @@
SUBDIR += tinycobol
SUBDIR += tolua
SUBDIR += tolua++
+ SUBDIR += tolua++50
SUBDIR += tolua4
SUBDIR += tolua50
SUBDIR += treecc
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
index 997a9927ef60..4281ba890016 100644
--- a/lang/tolua++/Makefile
+++ b/lang/tolua++/Makefile
@@ -7,20 +7,29 @@
PORTNAME= tolua++
PORTVERSION= 1.0.92
+PORTREVISION= 1
CATEGORIES= lang devel
-MASTER_SITES= http://www.codenix.com/~tolua/
+MASTER_SITES= http://www.codenix.com/~tolua/ \
+ http://www.amdmi3.ru/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
-
USE_BZIP2= yes
-USE_LDCONFIG= yes
+USE_LUA= 5.1
USE_SCONS= yes
SCONS_ARGS= prefix=${PREFIX}
-CFLAGS+= -I/usr/local/include/lua50
-LDFLAGS+= -L/usr/local/lib/lua50
+CFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|'lualib',||" ${WRKSRC}/config_posix.py
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua++ ${LUA_BINDIR}
+ ${LN} -sf ${LUA_SUBDIR}/tolua++ ${PREFIX}/bin/tolua++-${LUA_VER}
+ ${INSTALL_DATA} ${WRKSRC}/include/tolua++.h ${LUA_INCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtolua++.a ${LUA_LIBDIR}
.include <bsd.port.mk>
diff --git a/lang/tolua++/pkg-descr b/lang/tolua++/pkg-descr
index 26424b722738..42228072fcb6 100644
--- a/lang/tolua++/pkg-descr
+++ b/lang/tolua++/pkg-descr
@@ -1,9 +1,9 @@
tolua++ is an extended version of tolua, a tool to integrate C/C++ code
with Lua. tolua++ includes new features oriented to c++ such as:
- * Support for std::string as a basic type (this can be turned off by a
-command line option).
- * Support for class templates
+* Support for std::string as a basic type (this can be turned off by a
+ command line option).
+* Support for class templates
As well as other features and bugfixes.
diff --git a/lang/tolua++/pkg-plist b/lang/tolua++/pkg-plist
index 48663bb9894c..ae3137aa5652 100644
--- a/lang/tolua++/pkg-plist
+++ b/lang/tolua++/pkg-plist
@@ -1,3 +1,4 @@
-bin/tolua++
-include/tolua++.h
-lib/libtolua++.a
+%%LUA_BINDIR%%/tolua++
+bin/tolua++-%%LUA_VER%%
+%%LUA_LIBDIR%%/libtolua++.a
+%%LUA_INCDIR%%/tolua++.h
diff --git a/lang/tolua++50/Makefile b/lang/tolua++50/Makefile
index 997a9927ef60..60d9f4f44049 100644
--- a/lang/tolua++50/Makefile
+++ b/lang/tolua++50/Makefile
@@ -7,20 +7,26 @@
PORTNAME= tolua++
PORTVERSION= 1.0.92
+PKGNAMESUFFIX= 50
CATEGORIES= lang devel
-MASTER_SITES= http://www.codenix.com/~tolua/
+MASTER_SITES= http://www.codenix.com/~tolua/ \
+ http://www.amdmi3.ru/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
-
USE_BZIP2= yes
-USE_LDCONFIG= yes
+USE_LUA= 5.0
USE_SCONS= yes
SCONS_ARGS= prefix=${PREFIX}
-CFLAGS+= -I/usr/local/include/lua50
-LDFLAGS+= -L/usr/local/lib/lua50
+CFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua++ ${LUA_BINDIR}
+ ${LN} -sf ${LUA_SUBDIR}/tolua++ ${PREFIX}/bin/tolua++-${LUA_VER}
+ ${INSTALL_DATA} ${WRKSRC}/include/tolua++.h ${LUA_INCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtolua++.a ${LUA_LIBDIR}
.include <bsd.port.mk>
diff --git a/lang/tolua++50/pkg-descr b/lang/tolua++50/pkg-descr
index 26424b722738..42228072fcb6 100644
--- a/lang/tolua++50/pkg-descr
+++ b/lang/tolua++50/pkg-descr
@@ -1,9 +1,9 @@
tolua++ is an extended version of tolua, a tool to integrate C/C++ code
with Lua. tolua++ includes new features oriented to c++ such as:
- * Support for std::string as a basic type (this can be turned off by a
-command line option).
- * Support for class templates
+* Support for std::string as a basic type (this can be turned off by a
+ command line option).
+* Support for class templates
As well as other features and bugfixes.
diff --git a/lang/tolua++50/pkg-plist b/lang/tolua++50/pkg-plist
index 48663bb9894c..ae3137aa5652 100644
--- a/lang/tolua++50/pkg-plist
+++ b/lang/tolua++50/pkg-plist
@@ -1,3 +1,4 @@
-bin/tolua++
-include/tolua++.h
-lib/libtolua++.a
+%%LUA_BINDIR%%/tolua++
+bin/tolua++-%%LUA_VER%%
+%%LUA_LIBDIR%%/libtolua++.a
+%%LUA_INCDIR%%/tolua++.h