aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-04-27 05:17:35 +0800
committerknu <knu@FreeBSD.org>2003-04-27 05:17:35 +0800
commitb0664f6ba10bd48da8da178210ed4086253cd984 (patch)
treedce775ff345d141d265d886569d95048950d21e9 /lang
parent9197a89086433e5565db8c3a20c08307871d9312 (diff)
downloadfreebsd-ports-gnome-b0664f6ba10bd48da8da178210ed4086253cd984.tar.gz
freebsd-ports-gnome-b0664f6ba10bd48da8da178210ed4086253cd984.tar.zst
freebsd-ports-gnome-b0664f6ba10bd48da8da178210ed4086253cd984.zip
Unbreak the build.
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby16_static/Makefile1
-rw-r--r--lang/ruby16_static/files/patch-ext+bdb1+extconf.rb25
-rw-r--r--lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb11
-rw-r--r--lang/ruby_static/Makefile1
-rw-r--r--lang/ruby_static/files/patch-ext+bdb1+extconf.rb25
-rw-r--r--lang/ruby_static/files/ruby16-patch-ext+zlib+extconf.rb11
6 files changed, 74 insertions, 0 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 1c5afd093bda..e9670bebc1f0 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -33,6 +33,7 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
EXT_PORTS+= ${RUBY_SHIM18_PORT}
+EXTRA_PATCHES= ${PATCHDIR}/ruby16-patch-*
.else
EXT_PORTS+= converters/ruby-iconv
.endif
diff --git a/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb b/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb
new file mode 100644
index 000000000000..b49410f5700c
--- /dev/null
+++ b/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb
@@ -0,0 +1,25 @@
+--- ext/bdb1/extconf.rb.orig Fri Dec 27 22:32:58 2002
++++ ext/bdb1/extconf.rb Sun Apr 27 05:35:25 2003
+@@ -1,9 +1,10 @@
+ #!/usr/bin/ruby
+ require 'mkmf'
++require 'rbconfig'
+
+-$stat_lib = if CONFIG.key?("LIBRUBYARG_STATIC")
++$stat_lib = if Config::CONFIG.key?("LIBRUBYARG_STATIC")
+ $LDFLAGS += " -L#{CONFIG['libdir']}"
+- CONFIG["LIBRUBYARG_STATIC"]
++ Config::CONFIG["LIBRUBYARG_STATIC"]
+ else
+ "-lruby"
+ end
+@@ -40,8 +41,7 @@
+
+ unknown: $(DLLIB)
+ \t@echo "main() {}" > /tmp/a.c
+-\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{CONFIG["LIBS"
+-]} $(LIBS) $(LOCAL_LIBS)
++\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{Config::CONFIG["LIBS"]} $(LIBS) $(LOCAL_LIBS)
+ \t@-rm /tmp/a.c a.out
+
+ test: $(DLLIB)
diff --git a/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb b/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb
new file mode 100644
index 000000000000..3ff097f28f02
--- /dev/null
+++ b/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb
@@ -0,0 +1,11 @@
+--- ext/zlib/extconf.rb.orig Fri Mar 28 11:24:47 2003
++++ ext/zlib/extconf.rb Sun Apr 27 05:56:22 2003
+@@ -24,7 +24,7 @@
+ oldlibs = $libs
+ oldlibpath = $LIBPATH
+ $libs += " " + Config::CONFIG['LIBRUBYARG']
+- $LIBPATH = [$libdir, $archdir] | $LIBPATH
++ $LIBPATH = [$libdir, $archdir || Config::CONFIG["compile_dir"]] | $LIBPATH
+ begin
+ have_func s, 'ruby.h'
+ rescue ArgumentError # for ruby-1.4
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 1c5afd093bda..e9670bebc1f0 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -33,6 +33,7 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
EXT_PORTS+= ${RUBY_SHIM18_PORT}
+EXTRA_PATCHES= ${PATCHDIR}/ruby16-patch-*
.else
EXT_PORTS+= converters/ruby-iconv
.endif
diff --git a/lang/ruby_static/files/patch-ext+bdb1+extconf.rb b/lang/ruby_static/files/patch-ext+bdb1+extconf.rb
new file mode 100644
index 000000000000..b49410f5700c
--- /dev/null
+++ b/lang/ruby_static/files/patch-ext+bdb1+extconf.rb
@@ -0,0 +1,25 @@
+--- ext/bdb1/extconf.rb.orig Fri Dec 27 22:32:58 2002
++++ ext/bdb1/extconf.rb Sun Apr 27 05:35:25 2003
+@@ -1,9 +1,10 @@
+ #!/usr/bin/ruby
+ require 'mkmf'
++require 'rbconfig'
+
+-$stat_lib = if CONFIG.key?("LIBRUBYARG_STATIC")
++$stat_lib = if Config::CONFIG.key?("LIBRUBYARG_STATIC")
+ $LDFLAGS += " -L#{CONFIG['libdir']}"
+- CONFIG["LIBRUBYARG_STATIC"]
++ Config::CONFIG["LIBRUBYARG_STATIC"]
+ else
+ "-lruby"
+ end
+@@ -40,8 +41,7 @@
+
+ unknown: $(DLLIB)
+ \t@echo "main() {}" > /tmp/a.c
+-\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{CONFIG["LIBS"
+-]} $(LIBS) $(LOCAL_LIBS)
++\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{Config::CONFIG["LIBS"]} $(LIBS) $(LOCAL_LIBS)
+ \t@-rm /tmp/a.c a.out
+
+ test: $(DLLIB)
diff --git a/lang/ruby_static/files/ruby16-patch-ext+zlib+extconf.rb b/lang/ruby_static/files/ruby16-patch-ext+zlib+extconf.rb
new file mode 100644
index 000000000000..3ff097f28f02
--- /dev/null
+++ b/lang/ruby_static/files/ruby16-patch-ext+zlib+extconf.rb
@@ -0,0 +1,11 @@
+--- ext/zlib/extconf.rb.orig Fri Mar 28 11:24:47 2003
++++ ext/zlib/extconf.rb Sun Apr 27 05:56:22 2003
+@@ -24,7 +24,7 @@
+ oldlibs = $libs
+ oldlibpath = $LIBPATH
+ $libs += " " + Config::CONFIG['LIBRUBYARG']
+- $LIBPATH = [$libdir, $archdir] | $LIBPATH
++ $LIBPATH = [$libdir, $archdir || Config::CONFIG["compile_dir"]] | $LIBPATH
+ begin
+ have_func s, 'ruby.h'
+ rescue ArgumentError # for ruby-1.4