aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-26 15:16:40 +0800
committerale <ale@FreeBSD.org>2004-07-26 15:16:40 +0800
commitb9dd8db597270b89498beea1bd31021dbfaea6ee (patch)
tree75c67caf7a3bb0510741ab471a09cf490d389da8 /lang
parent9639ceb3aa1103b786f833221d3b19854c6cf171 (diff)
downloadfreebsd-ports-gnome-b9dd8db597270b89498beea1bd31021dbfaea6ee.tar.gz
freebsd-ports-gnome-b9dd8db597270b89498beea1bd31021dbfaea6ee.tar.zst
freebsd-ports-gnome-b9dd8db597270b89498beea1bd31021dbfaea6ee.zip
Fix compilation of wddx extension.
PR: ports/69464 Submitted by: Vadim Mikhailov <freebsd-bugs@mikhailov.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile.ext5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index ee4425901830..457494ad3384 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -329,7 +329,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
+
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-expat-dir=${LOCALBASE}
USE_PHP= xml session
USE_PHP_BUILD= yes