aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-16 09:43:29 +0800
committerpav <pav@FreeBSD.org>2006-01-16 09:43:29 +0800
commitcd04fb9d4a71f73030d894647ee7cd7c552cb17a (patch)
tree6b0ac63c4cbdd6ed6f9223432be198c0ddddcb43 /lang
parent2c1b297aeb65ee199fcf7a741632e7a07f1b8a6b (diff)
downloadfreebsd-ports-gnome-cd04fb9d4a71f73030d894647ee7cd7c552cb17a.tar.gz
freebsd-ports-gnome-cd04fb9d4a71f73030d894647ee7cd7c552cb17a.tar.zst
freebsd-ports-gnome-cd04fb9d4a71f73030d894647ee7cd7c552cb17a.zip
- Fix bug: FileUtils.mv() does not unlink source file when moving over
filesystem boundaries Reported by: Virgil Champlin <champlin@stupidog.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile2
-rw-r--r--lang/ruby18/files/patch-fileutils.rb10
2 files changed, 11 insertions, 1 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index fe5a85b29333..e483d268b9f7 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
diff --git a/lang/ruby18/files/patch-fileutils.rb b/lang/ruby18/files/patch-fileutils.rb
new file mode 100644
index 000000000000..93930cd4c5b6
--- /dev/null
+++ b/lang/ruby18/files/patch-fileutils.rb
@@ -0,0 +1,10 @@
+--- lib/fileutils.rb.orig Sun Nov 20 02:23:41 2005
++++ lib/fileutils.rb Mon Jan 16 02:08:47 2006
+@@ -501,6 +501,7 @@
+ File.rename s, d
+ rescue Errno::EXDEV
+ copy_entry s, d, true
++ File.unlink s
+ end
+ rescue SystemCallError
+ raise unless options[:force]