aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-08 13:52:42 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-08 13:52:42 +0800
commitdd914692ef28938949c8c6fb3a4463a6aab3dbdb (patch)
tree2bab5795955b920f120341e7187a8bb29f6651cc /lang
parentece47cbede3b2755d17abfd1fbd4d8c958dca9e4 (diff)
downloadfreebsd-ports-gnome-dd914692ef28938949c8c6fb3a4463a6aab3dbdb.tar.gz
freebsd-ports-gnome-dd914692ef28938949c8c6fb3a4463a6aab3dbdb.tar.zst
freebsd-ports-gnome-dd914692ef28938949c8c6fb3a4463a6aab3dbdb.zip
update lang/pike74: 7.4.13 -> 7.4.25
PR: 54204 Submitted by: Xavier Beaudouin <kiwi@oav.net> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/pike74/Makefile71
-rw-r--r--lang/pike74/distinfo2
2 files changed, 50 insertions, 23 deletions
diff --git a/lang/pike74/Makefile b/lang/pike74/Makefile
index 1fa0444a7403..10af4ccfcdba 100644
--- a/lang/pike74/Makefile
+++ b/lang/pike74/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pike74
-PORTVERSION= 7.4.13
-PORTREVISION= 2
+PORTVERSION= 7.4.25
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
ftp://ftp.oav.net/pkg_freebsd/distfiles/ \
@@ -34,8 +33,6 @@ MAN1= pike.1
WRKSRC= ${WRKDIR}/${DISTNAME}/src/
WANT_MESA= yes
-WANT_GTK= yes
-WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -50,7 +47,6 @@ CONFIGURE_ARGS+= --without-debug \
--with-oob \
--with-poll \
--with-max-fd=60000 \
- --without-perl \
--with-gmp \
--with-zlib \
--with-threads \
@@ -60,6 +56,10 @@ CONFIGURE_ARGS+= --without-debug \
--with-gdbm \
--without-java \
--without-ssleay \
+ --without-GTK \
+ --without-gnome \
+ --without-glade \
+ --without-libglade-config \
--prefix=${PREFIX}
.include <bsd.port.pre.mk>
@@ -71,6 +71,14 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION}
LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+# Allow building Embeded perl when >= 5.6
+.if ${PERL_LEVEL} > 500600
+CONFIGURE_ARGS+= --with-perl
+USE_PERL5= YES
+.else
+CONFIGURE_ARGS+= --without-perl
+.endif
+
.if exists(${LOCALBASE}/lib/libavcodec.so.0)
WITH_FFMPEG= yes
.endif
@@ -87,6 +95,14 @@ WITH_FREETYPE= yes
WITH_MYSQL= yes
.endif
+.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.12)
+WITH_MYSQL40= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
+WITH_MYSQL41= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libpq.so.3)
WITH_POSTGRES= yes
.endif
@@ -177,6 +193,20 @@ CONFIGURE_ARGS+= --with-mysql=${PREFIX}
CONFIGURE_ARGS+= --without-mysql
.endif
+.if defined(WITH_MYSQL40)
+LIB_DEPENDS+= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
+CONFIGURE_ARGS+= --with-mysql=${PREFIX}
+.else
+CONFIGURE_ARGS+= --without-mysql
+.endif
+
+.if defined(WITH_MYSQL41)
+LIB_DEPENDS+= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
+CONFIGURE_ARGS+= --with-mysql=${PREFIX}
+.else
+CONFIGURE_ARGS+= --without-mysql
+.endif
+
.if defined(WITH_POSTGRES)
LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
@@ -244,21 +274,12 @@ CONFIGURE_ARGS+= --with-GL --with-GLUT
CONFIGURE_ARGS+= --without-GL --without-GLUT
.endif
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
-USE_GTK= yes
-USE_GLI= yes
-CONFIGURE_ARGS+= --with-GTK --with-gnome --with-glade --with-libglade-config=${X11BASE}/bin/libglade-config
-.else
-CONFIGURE_ARGS+= --without-GTK --without-gnome --without-glade --without-libglade-config
-.endif
-
-.if (${MACHINE} == "i386")
-CONFIGURE_ARGS+= --with-poll
-.else
-# Alpha seems to have problems with poll() with pike... :/
-CONFIGURE_ARGS+= --without-poll
-.endif
+#.if (${MACHINE} == "i386")
+#CONFIGURE_ARGS+= --with-poll
+#.else
+## Alpha seems to have problems with poll() with pike... :/
+#CONFIGURE_ARGS+= --without-poll
+#.endif
USE_GMAKE= yes
@@ -277,7 +298,13 @@ pre-everything::
@${ECHO_MSG} "You can enable _Image_FreeType support by defining WITH_FREETYPE."
.endif
.if !defined(WITH_MYSQL)
- @${ECHO_MSG} "You can enable MySQL support by defining WITH_MYSQL."
+ @${ECHO_MSG} "You can enable MySQL 3.23 support by defining WITH_MYSQL."
+.endif
+.if !defined(WITH_MYSQL40)
+ @${ECHO_MSG} "You can enable MySQL 4.0 support by defining WITH_MYSQL40."
+.endif
+.if !defined(WITH_MYSQL41)
+ @${ECHO_MSG} "You can enable MySQL 4.1 support by defining WITH_MYSQL41."
.endif
.if !defined(WITH_POSTGRES)
@${ECHO_MSG} "You can enable PostGres support by defining WITH_POSTGRES."
@@ -298,7 +325,7 @@ pre-everything::
.endif
.if !defined(WITH_MOST)
@${ECHO_MSG} "You can enable most of the features here except Sane,"
- @${ECHO_MSG} "MesaGLi, GNOME and SQL support by defining WITH_MOST."
+ @${ECHO_MSG} "MesaGLi and SQL support by defining WITH_MOST."
.endif
.if !defined(WITH_SVG2)
@${ECHO_MSG} "You can enable SVG2 image support by "
diff --git a/lang/pike74/distinfo b/lang/pike74/distinfo
index 51dfb796b716..076553cc36aa 100644
--- a/lang/pike74/distinfo
+++ b/lang/pike74/distinfo
@@ -1 +1 @@
-MD5 (Pike-v7.4.13.tar.gz) = c0e0e4f04fb0aaf5667ba0710dc59602
+MD5 (Pike-v7.4.25.tar.gz) = b9cc266124827c01c3c6b81496205817