aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /lang
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby-perl/Makefile8
-rw-r--r--lang/ruby-perl/pkg-descr1
-rw-r--r--lang/ruby-python/Makefile12
-rw-r--r--lang/ruby-python/pkg-descr1
-rw-r--r--lang/ruby-tcltklib/Makefile18
-rw-r--r--lang/ruby/Makefile12
-rw-r--r--lang/ruby/pkg-descr3
-rw-r--r--lang/ruby14-irb/Makefile20
-rw-r--r--lang/ruby14-tcltklib/Makefile18
-rw-r--r--lang/ruby14/Makefile12
-rw-r--r--lang/ruby14/pkg-descr3
-rw-r--r--lang/ruby16/Makefile12
-rw-r--r--lang/ruby16/pkg-descr3
13 files changed, 63 insertions, 60 deletions
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
index 26f55eabef9e..c4f3236d7cd9 100644
--- a/lang/ruby-perl/Makefile
+++ b/lang/ruby-perl/Makefile
@@ -24,9 +24,9 @@ PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
USE_PERL5= yes
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
EXAMPLES= htmlparse.rb http.rb perllib.rb ping.rb \
test.rb xmlparser.rb
@@ -44,11 +44,11 @@ post-build:
post-install:
@cd ${WRKSRC}/Ruby; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
+.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/perl
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/perl/
.endfor
-.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/perl/ja
${INSTALL_DATA} ${WRKSRC}/README.ja ${PREFIX}/share/doc/ruby/perl/ja/
.endif
diff --git a/lang/ruby-perl/pkg-descr b/lang/ruby-perl/pkg-descr
index e9217e272b31..29827ca9dc36 100644
--- a/lang/ruby-perl/pkg-descr
+++ b/lang/ruby-perl/pkg-descr
@@ -2,4 +2,5 @@ This is a Ruby extension module to use the functions of Perl from Ruby.
You can also call Ruby functions back from within the Perl code.
+Author: Yoshida Masato <yoshidam@yoshidam.net>
WWW: http://www.bekkoame.ne.jp/~yoshidam/Ruby.html#perl
diff --git a/lang/ruby-python/Makefile b/lang/ruby-python/Makefile
index b2a0b2612713..c472d8dc6116 100644
--- a/lang/ruby-python/Makefile
+++ b/lang/ruby-python/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby/Python
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby/Python
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -23,9 +23,9 @@ RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb; \
diff --git a/lang/ruby-python/pkg-descr b/lang/ruby-python/pkg-descr
index 52f1faa2570c..3bbc79441782 100644
--- a/lang/ruby-python/pkg-descr
+++ b/lang/ruby-python/pkg-descr
@@ -11,4 +11,5 @@ enables Ruby users to have the advantages of both languages:
If you are attracted by Python modules but not fully satisfied with
Python's syntax or type system, try this library!
+Author: Masaki Fukushima <fukusima@goto.info.waseda.ac.jp>
WWW: http://www.goto.info.waseda.ac.jp/~fukusima/ruby/python-e.html
diff --git a/lang/ruby-tcltklib/Makefile b/lang/ruby-tcltklib/Makefile
index f446dcb28322..f54523d19575 100644
--- a/lang/ruby-tcltklib/Makefile
+++ b/lang/ruby-tcltklib/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: rubytk
-# Date created: 15 March 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: rubytk
+# Date created: 15 March 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -36,8 +36,8 @@ PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
BRANCH_NAME= 1.4
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
@@ -62,7 +62,7 @@ TK_LIB= tk${TK_VERSION}${TCL_JP}
TCL_DIR= `echo "${TCL_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
TK_DIR= `echo "${TK_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
-RUBY= ${LOCALBASE}/bin/ruby
+RUBY?= ${LOCALBASE}/bin/ruby
EXTS= tcltklib tk
do-configure:
@@ -81,14 +81,14 @@ do-install:
.for dir in ${EXTS}
@${ECHO_MSG} "Installing in ${dir}..."
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/sample/* ${EXAMPLESDIR}/${dir}
+.endif
.endfor
-
-post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/tcltklib/demo
${INSTALL_DATA} ${WRKSRC}/tcltklib/demo/* ${EXAMPLESDIR}/tcltklib/demo
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}/tcltklib
${INSTALL_DATA} ${WRKSRC}/tcltklib/*.euc ${DOCDIR}/tcltklib
.endif
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 1567638fd310..8cb8924bb6d4 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: ruby
-# Date created: 04 September 1997
-# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
+# New ports collection makefile for: ruby
+# Date created: 04 September 1997
+# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
#
# $FreeBSD$
#
@@ -24,8 +24,8 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby.1
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
BRANCH_NAME= 1.4
@@ -45,6 +45,7 @@ post-patch:
post-install:
strip ${PREFIX}/bin/ruby
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/misc
@@ -53,7 +54,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${EXAMPLESDIR}/curses
${MKDIR} ${EXAMPLESDIR}/pty
${INSTALL_DATA} ${WRKSRC}/ext/pty/expect_sample.rb ${WRKSRC}/ext/pty/script.rb ${WRKSRC}/ext/pty/shl.rb ${EXAMPLESDIR}/pty
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/README* ${DOCDIR}
${MKDIR} ${DOCDIR}/etc
diff --git a/lang/ruby/pkg-descr b/lang/ruby/pkg-descr
index f42fdba241cd..a2d4b342410b 100644
--- a/lang/ruby/pkg-descr
+++ b/lang/ruby/pkg-descr
@@ -17,4 +17,5 @@ Features of Ruby are shown below.
Windows, Mac, BeOS etc.)
The Ruby home page is at:
-WWW: http://www.ruby-lang.org/
+Author: Matsumoto "matz" Yukihiro <matz@netlab.co.jp>
+WWW: http://www.ruby-lang.org/
diff --git a/lang/ruby14-irb/Makefile b/lang/ruby14-irb/Makefile
index 8f2a350e8bd3..13514100a607 100644
--- a/lang/ruby14-irb/Makefile
+++ b/lang/ruby14-irb/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: irb
-# Date created: 19 April 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: irb
+# Date created: 19 April 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -20,22 +20,20 @@ MAINTAINER= yasuf@big.or.jp
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+NO_BUILD= yes
+
WRKSRC= ${WRKDIR}/irb
PLIST_SUB+= RUBY_VER="${RUBY_VER}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
post-patch:
+ ${PERL} -i -pe '$$. == 1 && s,^#!\s*\S+,#!${RUBY},' ${WRKSRC}/irb.rb
${RM} -f ${WRKSRC}/instirb.rb
-do-build:
- ( cd ${WRKSRC}; \
- ${MV} irb.rb irb.tmpl; \
- ${SED} -e '1s,^#!.*$$,#!${RUBY},' irb.tmpl > irb )
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/irb ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/irb.rb ${PREFIX}/bin/irb
${MKDIR} ${PREFIX}/lib/ruby/${RUBY_VER}/irb
${INSTALL_DATA} ${WRKSRC}/*.rb ${PREFIX}/lib/ruby/${RUBY_VER}/irb
.if !defined(NOPORTDOCS)
diff --git a/lang/ruby14-tcltklib/Makefile b/lang/ruby14-tcltklib/Makefile
index f446dcb28322..f54523d19575 100644
--- a/lang/ruby14-tcltklib/Makefile
+++ b/lang/ruby14-tcltklib/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: rubytk
-# Date created: 15 March 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: rubytk
+# Date created: 15 March 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -36,8 +36,8 @@ PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
BRANCH_NAME= 1.4
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
@@ -62,7 +62,7 @@ TK_LIB= tk${TK_VERSION}${TCL_JP}
TCL_DIR= `echo "${TCL_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
TK_DIR= `echo "${TK_LIB}" | ${SED} 's/\([0-9]\)\([0-9]\)/\1.\2/'`
-RUBY= ${LOCALBASE}/bin/ruby
+RUBY?= ${LOCALBASE}/bin/ruby
EXTS= tcltklib tk
do-configure:
@@ -81,14 +81,14 @@ do-install:
.for dir in ${EXTS}
@${ECHO_MSG} "Installing in ${dir}..."
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/sample/* ${EXAMPLESDIR}/${dir}
+.endif
.endfor
-
-post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}/tcltklib/demo
${INSTALL_DATA} ${WRKSRC}/tcltklib/demo/* ${EXAMPLESDIR}/tcltklib/demo
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}/tcltklib
${INSTALL_DATA} ${WRKSRC}/tcltklib/*.euc ${DOCDIR}/tcltklib
.endif
diff --git a/lang/ruby14/Makefile b/lang/ruby14/Makefile
index 1567638fd310..8cb8924bb6d4 100644
--- a/lang/ruby14/Makefile
+++ b/lang/ruby14/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: ruby
-# Date created: 04 September 1997
-# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
+# New ports collection makefile for: ruby
+# Date created: 04 September 1997
+# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
#
# $FreeBSD$
#
@@ -24,8 +24,8 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby.1
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
BRANCH_NAME= 1.4
@@ -45,6 +45,7 @@ post-patch:
post-install:
strip ${PREFIX}/bin/ruby
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/misc
@@ -53,7 +54,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${EXAMPLESDIR}/curses
${MKDIR} ${EXAMPLESDIR}/pty
${INSTALL_DATA} ${WRKSRC}/ext/pty/expect_sample.rb ${WRKSRC}/ext/pty/script.rb ${WRKSRC}/ext/pty/shl.rb ${EXAMPLESDIR}/pty
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/README* ${DOCDIR}
${MKDIR} ${DOCDIR}/etc
diff --git a/lang/ruby14/pkg-descr b/lang/ruby14/pkg-descr
index f42fdba241cd..a2d4b342410b 100644
--- a/lang/ruby14/pkg-descr
+++ b/lang/ruby14/pkg-descr
@@ -17,4 +17,5 @@ Features of Ruby are shown below.
Windows, Mac, BeOS etc.)
The Ruby home page is at:
-WWW: http://www.ruby-lang.org/
+Author: Matsumoto "matz" Yukihiro <matz@netlab.co.jp>
+WWW: http://www.ruby-lang.org/
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 1567638fd310..8cb8924bb6d4 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: ruby
-# Date created: 04 September 1997
-# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
+# New ports collection makefile for: ruby
+# Date created: 04 September 1997
+# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
#
# $FreeBSD$
#
@@ -24,8 +24,8 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby.1
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
BRANCH_NAME= 1.4
@@ -45,6 +45,7 @@ post-patch:
post-install:
strip ${PREFIX}/bin/ruby
+.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/misc
@@ -53,7 +54,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${EXAMPLESDIR}/curses
${MKDIR} ${EXAMPLESDIR}/pty
${INSTALL_DATA} ${WRKSRC}/ext/pty/expect_sample.rb ${WRKSRC}/ext/pty/script.rb ${WRKSRC}/ext/pty/shl.rb ${EXAMPLESDIR}/pty
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/README* ${DOCDIR}
${MKDIR} ${DOCDIR}/etc
diff --git a/lang/ruby16/pkg-descr b/lang/ruby16/pkg-descr
index f42fdba241cd..a2d4b342410b 100644
--- a/lang/ruby16/pkg-descr
+++ b/lang/ruby16/pkg-descr
@@ -17,4 +17,5 @@ Features of Ruby are shown below.
Windows, Mac, BeOS etc.)
The Ruby home page is at:
-WWW: http://www.ruby-lang.org/
+Author: Matsumoto "matz" Yukihiro <matz@netlab.co.jp>
+WWW: http://www.ruby-lang.org/