aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2011-03-20 06:02:44 +0800
committerskv <skv@FreeBSD.org>2011-03-20 06:02:44 +0800
commitedd4037a78e8b8faede145810e8a1fee6c904c29 (patch)
treef731c58af79ff9c51aa06c28dce4b4bdfbbd3b16 /lang
parentf600f192d0d2a1d2687baf0858d4f456367c7607 (diff)
downloadfreebsd-ports-gnome-edd4037a78e8b8faede145810e8a1fee6c904c29.tar.gz
freebsd-ports-gnome-edd4037a78e8b8faede145810e8a1fee6c904c29.tar.zst
freebsd-ports-gnome-edd4037a78e8b8faede145810e8a1fee6c904c29.zip
Update to 3.2.0
Changes: http://www.parrot.org/news/2011/Parrot-3.2.0
Diffstat (limited to 'lang')
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/parrot/Makefile.common2
-rw-r--r--lang/parrot/distinfo4
-rw-r--r--lang/parrot/pkg-plist15
4 files changed, 18 insertions, 6 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index e0f5de0b0a6a..d6fa35dc66a3 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -7,7 +7,6 @@
PORTNAME= parrot
PORTVERSION= ${PARROT_VERSION}
-PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/devel/${PORTVERSION}/
@@ -35,7 +34,7 @@ CONFIGURE_SCRIPT= Configure.pl
CONFIGURE_ARGS= --cc=${CC} --ld=${CC} --ccflags="${CFLAGS}" \
--ldflags="${LDFLAGS} -L/usr/lib -L${LOCALBASE}/lib" \
--icu-config=${LOCALBASE}/bin/icu-config \
- --optimize --parrot_is_shared --inline \
+ --optimize --parrot_is_shared --inline --gc=gms \
--lex=${LOCALBASE}/bin/flex \
--yacc=${LOCALBASE}/bin/bison \
--verbose \
diff --git a/lang/parrot/Makefile.common b/lang/parrot/Makefile.common
index affb5bb882aa..593830785d0e 100644
--- a/lang/parrot/Makefile.common
+++ b/lang/parrot/Makefile.common
@@ -1,4 +1,4 @@
# $FreeBSD$
-PARROT_VERSION= 3.1.0
+PARROT_VERSION= 3.2.0
diff --git a/lang/parrot/distinfo b/lang/parrot/distinfo
index 56eb93680b8f..6cf2acfc587c 100644
--- a/lang/parrot/distinfo
+++ b/lang/parrot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (parrot-3.1.0.tar.bz2) = bd200b84d8c6d1565360b7aad7802a42649baebc62d43a823b6aa8f9245e8f01
-SIZE (parrot-3.1.0.tar.bz2) = 3214347
+SHA256 (parrot-3.2.0.tar.bz2) = 568b245ce41f9d8f73e306a47b179cc77c7016fe55bd7ae8c91b9e4bb3976884
+SIZE (parrot-3.2.0.tar.bz2) = 3249939
diff --git a/lang/parrot/pkg-plist b/lang/parrot/pkg-plist
index 59ece9b9f4a9..8a3ac577209e 100644
--- a/lang/parrot/pkg-plist
+++ b/lang/parrot/pkg-plist
@@ -72,10 +72,10 @@ include/parrot/%%PARROT_VER%%/parrot/runcore_trace.h
include/parrot/%%PARROT_VER%%/parrot/scheduler.h
include/parrot/%%PARROT_VER%%/parrot/scheduler_private.h
include/parrot/%%PARROT_VER%%/parrot/settings.h
-include/parrot/%%PARROT_VER%%/parrot/stat.h
include/parrot/%%PARROT_VER%%/parrot/string.h
include/parrot/%%PARROT_VER%%/parrot/string_funcs.h
include/parrot/%%PARROT_VER%%/parrot/sub.h
+include/parrot/%%PARROT_VER%%/parrot/thr_none.h
include/parrot/%%PARROT_VER%%/parrot/thr_pthread.h
include/parrot/%%PARROT_VER%%/parrot/thr_windows.h
include/parrot/%%PARROT_VER%%/parrot/thread.h
@@ -149,6 +149,9 @@ include/parrot/%%PARROT_VER%%/pmc/pmc_parrotlibrary.h
include/parrot/%%PARROT_VER%%/pmc/pmc_parrotthread.h
include/parrot/%%PARROT_VER%%/pmc/pmc_pmcproxy.h
include/parrot/%%PARROT_VER%%/pmc/pmc_pointer.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_ptr.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_ptrbuf.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_ptrobj.h
include/parrot/%%PARROT_VER%%/pmc/pmc_resizablebooleanarray.h
include/parrot/%%PARROT_VER%%/pmc/pmc_resizablefloatarray.h
include/parrot/%%PARROT_VER%%/pmc/pmc_resizableintegerarray.h
@@ -164,6 +167,7 @@ include/parrot/%%PARROT_VER%%/pmc/pmc_string.h
include/parrot/%%PARROT_VER%%/pmc/pmc_stringbuilder.h
include/parrot/%%PARROT_VER%%/pmc/pmc_stringhandle.h
include/parrot/%%PARROT_VER%%/pmc/pmc_stringiterator.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_structview.h
include/parrot/%%PARROT_VER%%/pmc/pmc_sub.h
include/parrot/%%PARROT_VER%%/pmc/pmc_task.h
include/parrot/%%PARROT_VER%%/pmc/pmc_threadinterpreter.h
@@ -219,7 +223,9 @@ lib/parrot/%%PARROT_VER%%/include/test_more.pir
lib/parrot/%%PARROT_VER%%/include/timer.pasm
lib/parrot/%%PARROT_VER%%/include/tm.pasm
lib/parrot/%%PARROT_VER%%/include/warnings.pasm
+lib/parrot/%%PARROT_VER%%/languages/JSON/JSON.pir
lib/parrot/%%PARROT_VER%%/languages/data_json/Defines.mak
+lib/parrot/%%PARROT_VER%%/languages/data_json/JSON.nqp
lib/parrot/%%PARROT_VER%%/languages/data_json/Rules.mak
lib/parrot/%%PARROT_VER%%/languages/data_json/data_json.pbc
lib/parrot/%%PARROT_VER%%/languages/data_json/data_json.pir
@@ -405,6 +411,7 @@ lib/parrot/%%PARROT_VER%%/library/YAML/Tiny.pbc
lib/parrot/%%PARROT_VER%%/library/YAML/Tiny.pm
lib/parrot/%%PARROT_VER%%/library/config.pbc
lib/parrot/%%PARROT_VER%%/library/config.pir
+lib/parrot/%%PARROT_VER%%/library/crypto.declarations
lib/parrot/%%PARROT_VER%%/library/distutils.pbc
lib/parrot/%%PARROT_VER%%/library/distutils.pir
lib/parrot/%%PARROT_VER%%/library/dumper.pbc
@@ -417,6 +424,7 @@ lib/parrot/%%PARROT_VER%%/library/ncurses.pbc
lib/parrot/%%PARROT_VER%%/library/ncurses.pir
lib/parrot/%%PARROT_VER%%/library/nqp-rx.pbc
lib/parrot/%%PARROT_VER%%/library/nqp-setting.pbc
+lib/parrot/%%PARROT_VER%%/library/openssl.declarations
lib/parrot/%%PARROT_VER%%/library/opsc.pbc
lib/parrot/%%PARROT_VER%%/library/osutils.pbc
lib/parrot/%%PARROT_VER%%/library/osutils.pir
@@ -613,6 +621,9 @@ src/parrot/%%PARROT_VER%%/pmc/parrotlibrary.dump
src/parrot/%%PARROT_VER%%/pmc/parrotthread.dump
src/parrot/%%PARROT_VER%%/pmc/pmcproxy.dump
src/parrot/%%PARROT_VER%%/pmc/pointer.dump
+src/parrot/%%PARROT_VER%%/pmc/ptr.dump
+src/parrot/%%PARROT_VER%%/pmc/ptrbuf.dump
+src/parrot/%%PARROT_VER%%/pmc/ptrobj.dump
src/parrot/%%PARROT_VER%%/pmc/resizablebooleanarray.dump
src/parrot/%%PARROT_VER%%/pmc/resizablefloatarray.dump
src/parrot/%%PARROT_VER%%/pmc/resizableintegerarray.dump
@@ -628,6 +639,7 @@ src/parrot/%%PARROT_VER%%/pmc/string.dump
src/parrot/%%PARROT_VER%%/pmc/stringbuilder.dump
src/parrot/%%PARROT_VER%%/pmc/stringhandle.dump
src/parrot/%%PARROT_VER%%/pmc/stringiterator.dump
+src/parrot/%%PARROT_VER%%/pmc/structview.dump
src/parrot/%%PARROT_VER%%/pmc/sub.dump
src/parrot/%%PARROT_VER%%/pmc/task.dump
src/parrot/%%PARROT_VER%%/pmc/threadinterpreter.dump
@@ -709,6 +721,7 @@ src/parrot/%%PARROT_VER%%/vtable.tbl
@dirrm lib/parrot/%%PARROT_VER%%/languages/parrot
@dirrm lib/parrot/%%PARROT_VER%%/languages/data_json/data_json
@dirrm lib/parrot/%%PARROT_VER%%/languages/data_json
+@dirrm lib/parrot/%%PARROT_VER%%/languages/JSON
@dirrmtry lib/parrot/%%PARROT_VER%%/languages
@dirrm lib/parrot/%%PARROT_VER%%/include
@dirrmtry lib/parrot/%%PARROT_VER%%/dynext