aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-14 16:37:27 +0800
committermarino <marino@FreeBSD.org>2014-03-14 16:37:27 +0800
commit9454478d887857aa1d31098ab4cfb2472fc6a7f0 (patch)
tree7df51732b383df62bab3f1d9cdea22e73c897107 /lang
parent0841e3e790f3503e187156fdb9287bce970a9657 (diff)
downloadfreebsd-ports-gnome-9454478d887857aa1d31098ab4cfb2472fc6a7f0.tar.gz
freebsd-ports-gnome-9454478d887857aa1d31098ab4cfb2472fc6a7f0.tar.zst
freebsd-ports-gnome-9454478d887857aa1d31098ab4cfb2472fc6a7f0.zip
lang/asis: New version as result of gcc-aux upgrade to gcc49
The ASIS source has to be matched with the compiler source of the compiler that builds it. ASIS is always tricky because it's matched to annual releases of GNAT GPL, and never to GNAT FSF. However, after disabling the useless (and faulty) strong version check, ASIS 2013 seems to work okay with gcc49. At least the two ports that use it seem to work ok.
Diffstat (limited to 'lang')
-rw-r--r--lang/asis/Makefile6
-rw-r--r--lang/asis/distinfo4
-rw-r--r--lang/asis/files/patch-Makefile50
-rw-r--r--lang/asis/files/patch-Makefile.stub2
-rw-r--r--lang/asis/files/patch-asis__bld.gpr13
-rw-r--r--lang/asis/files/patch-asis_a4g-gnat__int.adb52
-rw-r--r--lang/asis/files/patch-asis_asis.gpr7
7 files changed, 58 insertions, 76 deletions
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index a307e6d9d24c..a24a821e8873 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= asis
-PORTVERSION= 2011
-PORTREVISION= 3
+PORTVERSION= 2013
CATEGORIES= lang
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= ${PORTNAME}-gpl-${PORTVERSION}-src
@@ -14,7 +13,7 @@ COMMENT= GNAT implementation of Ada Semantic Interface Specification
LICENSE= GPLv2
-BUILD_DEPENDS= gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
+BUILD_DEPENDS= gprbuild>=20130416:${PORTSDIR}/devel/gprbuild \
xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
${GUSTATIC}:${PORTSDIR}/lang/gnat_util
RUN_DEPENDS= ${GUSTATIC}:${PORTSDIR}/lang/gnat_util
@@ -26,6 +25,7 @@ GUSTATIC= ${LOCALBASE}/lib/gnat_util/libgnat_util.a
post-extract:
@${REINPLACE_CMD} -e 's|OPSYS|ASISOPSYS|g' \
+ -e 's|(prefix)|(DESTDIR)$$(prefix)|g' \
${WRKSRC}/Makefile \
${WRKSRC}/Makefile.stub \
${WRKSRC}/common.gpr
diff --git a/lang/asis/distinfo b/lang/asis/distinfo
index d71a595a3da1..42f8ad90af6d 100644
--- a/lang/asis/distinfo
+++ b/lang/asis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asis-gpl-2011-src.tgz) = abce6aecf13a94bafcbaab363241878805898cb731d30dc0686a7079c96029a8
-SIZE (asis-gpl-2011-src.tgz) = 3132742
+SHA256 (asis-gpl-2013-src.tgz) = 5f900654ffe0a8a86bcea0c32f1777b039e261bc7ba0e262706cff9de003a23a
+SIZE (asis-gpl-2013-src.tgz) = 4728571
diff --git a/lang/asis/files/patch-Makefile b/lang/asis/files/patch-Makefile
deleted file mode 100644
index 6ae86c9c92c9..000000000000
--- a/lang/asis/files/patch-Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.orig 2013-07-17 18:11:51.000000000 +0000
-+++ Makefile
-@@ -1,21 +1,21 @@
-
- include Makefile.stub
-
--all: lib/libasis$(arext) asistant
-+all: lib/libasis$(arext) asistant tools
-
- BLD=prod
- tools = gnatstub gnatelim gnatmetric gnatpp gnatcheck
- gu_tools = aunitstub aunitglue
-
--I_BIN = $(prefix)/bin
--I_INC = $(prefix)/include/asis
--I_LIB = $(prefix)/lib/asis
--I_GPR = $(prefix)/lib/gnat
--I_DOC = $(prefix)/share/doc/asis
--I_GPS = $(prefix)/share/gps/plug-ins
--G_DOC = $(prefix)/share/doc/gnat
-+I_BIN = $(DESTDIR)$(prefix)/bin
-+I_INC = $(DESTDIR)$(prefix)/include/asis
-+I_LIB = $(DESTDIR)$(prefix)/lib/asis
-+I_GPR = $(DESTDIR)$(prefix)/lib/gnat
-+I_DOC = $(DESTDIR)$(prefix)/share/doc/asis
-+I_GPS = $(DESTDIR)$(prefix)/share/gps/plug-ins
-+G_DOC = $(DESTDIR)$(prefix)/share/doc/gnat
-
--install: install-lib install-asistant
-+install: install-lib install-asistant install-tools
-
- install-lib:
- $(RMDIR) $(I_INC)
-@@ -36,7 +36,6 @@ ifneq ($(ATTRIB),)
- cd $(I_LIB) && $(ATTRIB) +r '*.ali'
- cd $(I_LIB) && $(ATTRIB) +r 'libasis$(arext)'
- endif
-- $(INSTALL_FILES) gnat/*.ads gnat/*.adb $(I_INC)
- $(INSTALL_FILES) asis/*.ads asis/*.adb $(I_INC)
- $(INSTALL_FILES) asis/asis.gpr $(I_GPR)
- $(INSTALL_FILES) documentation/gps_index.xml $(I_GPS)/asis.xml
-@@ -45,8 +44,6 @@ endif
- -$(INSTALL_FILES) documentation/asis_*.info $(I_DOC)/info/
-
- lib/libasis$(arext): force
-- cd gnat && $(GNATMAKE) xsnamest && ./xsnamest \
-- && mv snames.ns snames.ads && mv snames.nb snames.adb
- $(GNATMAKE) -Pasis_bld -XBLD=$(BLD) -XASISOPSYS=$(ASISOPSYS)
-
- install-tools: $(tools:%=install-%)
diff --git a/lang/asis/files/patch-Makefile.stub b/lang/asis/files/patch-Makefile.stub
index 79a279ccff7b..a03898a816f5 100644
--- a/lang/asis/files/patch-Makefile.stub
+++ b/lang/asis/files/patch-Makefile.stub
@@ -1,4 +1,4 @@
---- Makefile.stub.orig 2013-07-16 23:01:45.000000000 +0000
+--- Makefile.stub.orig 2014-03-09 22:02:56.822564000 +0000
+++ Makefile.stub
@@ -3,8 +3,7 @@ host := $(shell gcc -dumpmachine)
diff --git a/lang/asis/files/patch-asis__bld.gpr b/lang/asis/files/patch-asis__bld.gpr
deleted file mode 100644
index 84fa6e46c7b7..000000000000
--- a/lang/asis/files/patch-asis__bld.gpr
+++ /dev/null
@@ -1,13 +0,0 @@
---- asis_bld.gpr.orig 2012-05-10 13:27:53.000000000 +0000
-+++ asis_bld.gpr
-@@ -1,8 +1,9 @@
-+with "gnat_util";
- with "common";
- project Asis_Bld is
-
- for Languages use ("ada");
-- for Source_Dirs use ("asis", "gnat");
-+ for Source_Dirs use ("asis");
- for Object_Dir use "obj";
- for Library_Name use "asis";
- for Library_Dir use "lib";
diff --git a/lang/asis/files/patch-asis_a4g-gnat__int.adb b/lang/asis/files/patch-asis_a4g-gnat__int.adb
new file mode 100644
index 000000000000..191f28bca66a
--- /dev/null
+++ b/lang/asis/files/patch-asis_a4g-gnat__int.adb
@@ -0,0 +1,52 @@
+--- asis/a4g-gnat_int.adb.orig 2013-04-16 14:49:49.000000000 +0000
++++ asis/a4g-gnat_int.adb
+@@ -231,44 +231,11 @@ package body A4G.GNAT_Int is
+ end if;
+
+ if Strong_Version_Check then
+- -- We check only the dates here!
+- First_A_Idx :=
+- Index (Source => ASIS_GNAT_V,
+- Pattern => "(") + 1;
+-
+- First_T_Idx :=
+- Index (Source => Tree_Version_String.all,
+- Pattern => "(") + 1;
+-
+- Last_A_Idx := Index (Source => ASIS_GNAT_V,
+- Pattern => ")") - 1;
+-
+- if Index (Source => ASIS_GNAT_V, Pattern => "-") /= 0 then
+- Last_A_Idx := Index (Source => ASIS_GNAT_V,
+- Pattern => "-") - 1;
+- end if;
+-
+- Last_T_Idx := Index (Source => Tree_Version_String.all,
+- Pattern => ")") - 1;
+-
+- if Index (Source => Tree_Version_String.all, Pattern => "-") /=
+- 0
+- then
+- Last_T_Idx :=
+- Index (Source => Tree_Version_String.all,
+- Pattern => "-") - 1;
+- end if;
+-
+- if ASIS_GNAT_V (First_A_Idx .. Last_A_Idx) /=
+- Tree_Version_String (First_T_Idx .. Last_T_Idx)
+- then
+- Close (Desc, File_Closed);
+- Ada.Exceptions.Raise_Exception
+- (Program_Error'Identity,
+- A_Name_Buffer (1 .. A_Name_Len) &
+- ": Inconsistent versions of GNAT [" & Tree_Version_String.all &
+- "] and ASIS [" & ASIS_GNAT_V & ']');
+- end if;
++ -- No need for any version check at all
++ -- FreeBSD Ports system ensures gnat_util is from same sources
++ -- as comiler building ASIS
++
++ null;
+
+ end if;
+
diff --git a/lang/asis/files/patch-asis_asis.gpr b/lang/asis/files/patch-asis_asis.gpr
deleted file mode 100644
index b2c6ca6b9f5a..000000000000
--- a/lang/asis/files/patch-asis_asis.gpr
+++ /dev/null
@@ -1,7 +0,0 @@
---- asis/asis.gpr.orig 2012-05-10 13:27:52.000000000 +0000
-+++ asis/asis.gpr
-@@ -1,3 +1,4 @@
-+with "gnat_util";
- project Asis is
- for Languages use ("ada");
- for Source_Dirs use ("../../include/asis");