aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-12-23 00:45:41 +0800
committermva <mva@FreeBSD.org>2014-12-23 00:45:41 +0800
commita621387a7c2f3144d942d9b9b30f04765036828e (patch)
tree581a02674c21611259a194e3d19aef1d4fd97f9c /lang
parentc9e68b905f3416292dc0518c9ccbacb0ab1a79db (diff)
downloadfreebsd-ports-gnome-a621387a7c2f3144d942d9b9b30f04765036828e.tar.gz
freebsd-ports-gnome-a621387a7c2f3144d942d9b9b30f04765036828e.tar.zst
freebsd-ports-gnome-a621387a7c2f3144d942d9b9b30f04765036828e.zip
- Revert the previous NIS check, since it does not help at all
PR: 196195 Submitted by: ache@ With hat: python@
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python32/Makefile2
-rw-r--r--lang/python33/Makefile2
-rw-r--r--lang/python34/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 12e441a694c3..911571edc87c 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -94,7 +94,7 @@ LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
.endif
# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
-.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
PLIST_SUB+= NO_NIS="@comment "
.else
PLIST_SUB+= NO_NIS=""
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 553f8471f050..86f719da55cb 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -92,7 +92,7 @@ CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
-.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
PLIST_SUB+= NO_NIS="@comment "
.else
PLIST_SUB+= NO_NIS=""
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 1e9b2e75ff67..9a04a006d473 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -86,7 +86,7 @@ CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
-.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
PLIST_SUB+= NO_NIS="@comment "
.else
PLIST_SUB+= NO_NIS=""
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index fc963260baf5..42795cd57191 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -101,7 +101,7 @@ CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
-.if defined(WITHOUT_NIS) || !exists(/usr/include/rpcsvc/yp_prot.h)
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
PLIST_SUB+= NO_NIS="@comment "
DISABLED_EXTENSIONS+= nis
.else