aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-05-11 04:13:56 +0800
committerdinoex <dinoex@FreeBSD.org>2001-05-11 04:13:56 +0800
commita92ac917b8504dab8aa7b7e57f737a6e4f9d81f5 (patch)
tree1022b75659258d0fb05f75249df5d5dffec1c77b /lang
parente7b15654621ea852e64c0435f3e3a08e9c6e6c8a (diff)
downloadfreebsd-ports-gnome-a92ac917b8504dab8aa7b7e57f737a6e4f9d81f5.tar.gz
freebsd-ports-gnome-a92ac917b8504dab8aa7b7e57f737a6e4f9d81f5.tar.zst
freebsd-ports-gnome-a92ac917b8504dab8aa7b7e57f737a6e4f9d81f5.zip
- Fix creation of tmpfiles, previous version cause tcl to fail.
PR: roam@FreeBSD.org Submitted by: Jaeho Kang <jhkang@isofree.net>, roam@FreeBSD.org
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl83/Makefile2
-rw-r--r--lang/tcl83/files/patch-tmpnam10
-rw-r--r--lang/tcl84/Makefile2
-rw-r--r--lang/tcl84/files/patch-tmpnam10
4 files changed, 10 insertions, 14 deletions
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index 9d4b733635ff..3e2e705f49e4 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl83
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_3
diff --git a/lang/tcl83/files/patch-tmpnam b/lang/tcl83/files/patch-tmpnam
index ef535617fe5d..535259b7af2c 100644
--- a/lang/tcl83/files/patch-tmpnam
+++ b/lang/tcl83/files/patch-tmpnam
@@ -1,8 +1,6 @@
---- tclUnixPipe.c Tue Apr 3 18:54:39 2001
-+++ tclUnixPipe.c Sat Apr 28 12:41:46 2001
-@@ -193,13 +193,10 @@
- /*
- * Linux says we should use mkstemp, but Solaris prefers tmpnam.
+--- tclUnixPipe.c.orig Wed Apr 4 00:54:39 2001
++++ tclUnixPipe.c Thu May 10 22:00:30 2001
+@@ -195,10 +195,8 @@
* We should also check against making more then TMP_MAX of these.
*/
@@ -10,8 +8,8 @@
- return NULL;
- }
- fd = open(fileName, O_RDWR|O_CREAT|O_EXCL, 0666); /* INTL: Native. */
++ strlcpy(fileName, "/var/tmp/tcltmp.XXXXXX", L_tmpnam);
+ fd = mkstemp(fileName); /* INTL: Native. */
if (fd == -1) {
return NULL;
}
- fcntl(fd, F_SETFD, FD_CLOEXEC);
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 9d4b733635ff..3e2e705f49e4 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl83
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_3
diff --git a/lang/tcl84/files/patch-tmpnam b/lang/tcl84/files/patch-tmpnam
index ef535617fe5d..535259b7af2c 100644
--- a/lang/tcl84/files/patch-tmpnam
+++ b/lang/tcl84/files/patch-tmpnam
@@ -1,8 +1,6 @@
---- tclUnixPipe.c Tue Apr 3 18:54:39 2001
-+++ tclUnixPipe.c Sat Apr 28 12:41:46 2001
-@@ -193,13 +193,10 @@
- /*
- * Linux says we should use mkstemp, but Solaris prefers tmpnam.
+--- tclUnixPipe.c.orig Wed Apr 4 00:54:39 2001
++++ tclUnixPipe.c Thu May 10 22:00:30 2001
+@@ -195,10 +195,8 @@
* We should also check against making more then TMP_MAX of these.
*/
@@ -10,8 +8,8 @@
- return NULL;
- }
- fd = open(fileName, O_RDWR|O_CREAT|O_EXCL, 0666); /* INTL: Native. */
++ strlcpy(fileName, "/var/tmp/tcltmp.XXXXXX", L_tmpnam);
+ fd = mkstemp(fileName); /* INTL: Native. */
if (fd == -1) {
return NULL;
}
- fcntl(fd, F_SETFD, FD_CLOEXEC);