aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-11-06 00:39:18 +0800
committerthierry <thierry@FreeBSD.org>2005-11-06 00:39:18 +0800
commitfe44c40a86cdc8abc471caf3733d2bd3dfab53ba (patch)
tree30e688c44fcde79ff24951e4c6c5858b2f1858ae /lang
parenta5c933d032bdf30740070e8f6faf5b86a6df9f22 (diff)
downloadfreebsd-ports-gnome-fe44c40a86cdc8abc471caf3733d2bd3dfab53ba.tar.gz
freebsd-ports-gnome-fe44c40a86cdc8abc471caf3733d2bd3dfab53ba.tar.zst
freebsd-ports-gnome-fe44c40a86cdc8abc471caf3733d2bd3dfab53ba.zip
Allow non standard $LOCALBASE.
Reported by: dosirak via Kris
Diffstat (limited to 'lang')
-rw-r--r--lang/gambas/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index 851effa76a8b..e0c2d0407529 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -26,6 +26,12 @@ LIBTOOLFLAGS= # none
USE_GMAKE= yes
CONFIGURE_ARGS= --with-conv-includes=${LOCALBASE}/include \
--with-conv-libraries=${LOCALBASE}/lib \
+ --with-intl-includes=${LOCALBASE}/include \
+ --with-intl-libraries=${LOCALBASE}/lib \
+ --with-conv-includes=${LOCALBASE}/include \
+ --with-conv-libraries=${LOCALBASE}/lib \
+ --with-gettext-includes=${LOCALBASE}/include \
+ --with-gettext-libraries=${LOCALBASE}/lib \
--with-moc=${X11BASE}/bin
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -42,6 +48,8 @@ SRC2FIX3= Makefile.in src/exec/gbx_project.c
CONFIGURE_ARGS+= --disable-mysql
PLIST_SUB+= MYSQL="@comment "
.else
+CONFIGURE_ARGS+= --with-mysql-includes=${LOCALBASE}/include/mysql \
+ --with-mysql-libraries=${LOCALBASE}/lib/mysql
USE_MYSQL= yes
PLIST_SUB+= MYSQL=""
.endif
@@ -59,6 +67,10 @@ PLIST_SUB+= SDL="@comment "
.if !defined(WITHOUT_XML)
USE_GNOME= libxml2 libxslt
PLIST_SUB+= XML=""
+CONFIGURE_ARGS+= --with-libxml-includes=${LOCALBASE}/include/libxml2 \
+ --with-libxml-libraries=${LOCALBASE}/lib \
+ --with-xslt-includes=${LOCALBASE}/include/libxml2 \
+ --with-xslt-libraries=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --disable-libxml --disable-xslt
PLIST_SUB+= XML="@comment "