aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-31 18:58:14 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-31 18:58:14 +0800
commit0c3453719656319b13787085c094f21f47783ec8 (patch)
treedc18b554801aab280cef1949a3235e707326283f /lang
parentfa023d89076a1061cfdfb65a3d8264a634bd5f5d (diff)
downloadfreebsd-ports-gnome-0c3453719656319b13787085c094f21f47783ec8.tar.gz
freebsd-ports-gnome-0c3453719656319b13787085c094f21f47783ec8.tar.zst
freebsd-ports-gnome-0c3453719656319b13787085c094f21f47783ec8.zip
- Clarify LICENSE
- Add LICENSE_FILE - Switch to options helpers
Diffstat (limited to 'lang')
-rw-r--r--lang/cparser/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/lang/cparser/Makefile b/lang/cparser/Makefile
index ce5149c5a346..9846def5da0a 100644
--- a/lang/cparser/Makefile
+++ b/lang/cparser/Makefile
@@ -9,11 +9,12 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= C99 compiler using libFIRM as backend
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfirm.so:${PORTSDIR}/devel/libfirm
-USES= pkgconfig gmake tar:bzip2
+USES= gmake pkgconfig tar:bzip2
PLIST_FILES= bin/cparser \
man/man1/cparser.1.gz
@@ -22,15 +23,11 @@ BUILDDIR= optimize
OPTIONS_DEFINE= DEBUG
-.include <bsd.port.options.mk>
+DEBUG_VARS= BUILDDIR=debug
-.if ${PORT_OPTIONS:MDEBUG}
-BUILDDIR= debug
-.else
-post-patch:
+post-patch-DEBUG-off:
@${REINPLACE_CMD} -e 's/^variant ?= debug/variant ?= optimize/' \
${WRKSRC}/Makefile
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/${BUILDDIR}/cparser ${STAGEDIR}${PREFIX}/bin