aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-07-16 23:23:22 +0800
committererwin <erwin@FreeBSD.org>2005-07-16 23:23:22 +0800
commit102a4032ab8558fcf571ba18a16108880c41c26b (patch)
tree8acbc781c07b9164d23c0ba2bef1f6bcf0b4ad90 /lang
parente25b7df5784e8866f511cbc81a18b30ec23a6b68 (diff)
downloadfreebsd-ports-gnome-102a4032ab8558fcf571ba18a16108880c41c26b.tar.gz
freebsd-ports-gnome-102a4032ab8558fcf571ba18a16108880c41c26b.tar.zst
freebsd-ports-gnome-102a4032ab8558fcf571ba18a16108880c41c26b.zip
Add p5-JavaScript-SpiderMonkey 0.11, perl interface to Mozilla
JavaScript implementation. PR: ports/82321 Submitted by: kappa@freebsd.org.ua
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/Makefile40
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/distinfo2
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/pkg-descr5
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 52de0cb62768..36d871d7172e 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -168,6 +168,7 @@
SUBDIR += p5-Error
SUBDIR += p5-Expect
SUBDIR += p5-F77
+ SUBDIR += p5-JavaScript-SpiderMonkey
SUBDIR += p5-List-MoreUtil
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Scalar-List-Utils
diff --git a/lang/p5-JavaScript-SpiderMonkey/Makefile b/lang/p5-JavaScript-SpiderMonkey/Makefile
new file mode 100644
index 000000000000..9083d31d26d2
--- /dev/null
+++ b/lang/p5-JavaScript-SpiderMonkey/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-JavaScript-SpiderMonkey
+# Date created: 25 February 2005
+# Whom: kappa@freebsd.org.ua
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript-SpiderMonkey
+PORTVERSION= 0.11
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JavaScript
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kappa@freebsd.org.ua
+COMMENT= Perl interface to Mozilla JavaScript implementation
+
+BUILD_DEPENDS= ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include
+INSTALL_TARGET= pure_install
+
+post-patch:
+ ${REINPLACE_CMD} -e 's~UNKNOWN";~${LOCALBASE}/lib";~' \
+ ${WRKSRC}/Makefile.PL
+
+MAN3= JavaScript::SpiderMonkey.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-JavaScript-SpiderMonkey/distinfo b/lang/p5-JavaScript-SpiderMonkey/distinfo
new file mode 100644
index 000000000000..248ca6ea163d
--- /dev/null
+++ b/lang/p5-JavaScript-SpiderMonkey/distinfo
@@ -0,0 +1,2 @@
+MD5 (JavaScript-SpiderMonkey-0.11.tar.gz) = 94a9a70c410f05dce56f47dce28d2356
+SIZE (JavaScript-SpiderMonkey-0.11.tar.gz) = 16175
diff --git a/lang/p5-JavaScript-SpiderMonkey/pkg-descr b/lang/p5-JavaScript-SpiderMonkey/pkg-descr
new file mode 100644
index 000000000000..88696c9c412e
--- /dev/null
+++ b/lang/p5-JavaScript-SpiderMonkey/pkg-descr
@@ -0,0 +1,5 @@
+JavaScript::SpiderMonkey is a Perl Interface to the SpiderMonkey
+JavaScript Engine. It is different from Claes Jacobsson's
+"JavaScript.pm" in that it offers more friendly, Perl-like API.
+
+WWW: http://search.cpan.org/dist/JavaScript-SpiderMonkey/
diff --git a/lang/p5-JavaScript-SpiderMonkey/pkg-plist b/lang/p5-JavaScript-SpiderMonkey/pkg-plist
new file mode 100644
index 000000000000..13096faa43cf
--- /dev/null
+++ b/lang/p5-JavaScript-SpiderMonkey/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/JavaScript/SpiderMonkey.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/SpiderMonkey/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/SpiderMonkey/SpiderMonkey.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/SpiderMonkey/SpiderMonkey.so
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/JavaScript 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/SpiderMonkey
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript 2>/dev/null || true