aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-01 11:45:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-01 11:45:12 +0800
commit186438d146a394b729a7b139b9ec68187245cbf3 (patch)
tree47a0ecc20682a7a4895cc432843a845b1c7f6905 /lang
parent3893119e13cf8350d8a3616ebffc77669eba37fe (diff)
downloadfreebsd-ports-gnome-186438d146a394b729a7b139b9ec68187245cbf3.tar.gz
freebsd-ports-gnome-186438d146a394b729a7b139b9ec68187245cbf3.tar.zst
freebsd-ports-gnome-186438d146a394b729a7b139b9ec68187245cbf3.zip
Remove BROKEN_FreeBSD_9
Approved by: portmgr (blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/beignet/Makefile2
-rw-r--r--lang/cint/Makefile1
-rw-r--r--lang/gnatdroid-armv7/Makefile2
-rw-r--r--lang/julia/Makefile2
-rw-r--r--lang/neko/Makefile2
-rw-r--r--lang/phantomjs/Makefile1
-rw-r--r--lang/pocl/Makefile1
-rw-r--r--lang/pure/Makefile2
-rw-r--r--lang/rust/Makefile2
9 files changed, 0 insertions, 15 deletions
diff --git a/lang/beignet/Makefile b/lang/beignet/Makefile
index 8478e52ef7e7..6db8ebafeb61 100644
--- a/lang/beignet/Makefile
+++ b/lang/beignet/Makefile
@@ -30,8 +30,6 @@ CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config${LLVMVER}
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= Beignet needs a graphics driver supported by the Intel KMS driver
-BROKEN_FreeBSD_9= Beignet is only supported on FreeBSD 10.1 and newer
-
# running tests from makefile doesn't work quite yet, so comment them out for now.
#OPTIONS_DEFINE= TESTS
#TESTS_DESC= Build and run the test suite
diff --git a/lang/cint/Makefile b/lang/cint/Makefile
index e96839bf19a9..4e2ea88d2d3f 100644
--- a/lang/cint/Makefile
+++ b/lang/cint/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= C/C++ interpreter
BROKEN_powerpc64= does not build
-BROKEN_FreeBSD_9= does not build (sigsegv during build)
BUILD_DEPENDS= bash:shells/bash
diff --git a/lang/gnatdroid-armv7/Makefile b/lang/gnatdroid-armv7/Makefile
index 1dc3f322cadd..5ce73282fabf 100644
--- a/lang/gnatdroid-armv7/Makefile
+++ b/lang/gnatdroid-armv7/Makefile
@@ -22,8 +22,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_LICENSES_INSTALL= yes
AUXPORT= gcc6-aux
-BROKEN_FreeBSD_9= BU 2.27 and F9 do not mix, try 2016Q3 branch
-
.include "${.CURDIR}/../${AUXPORT}/Makefile.common"
USES+= ada:6 gmake
diff --git a/lang/julia/Makefile b/lang/julia/Makefile
index 975decb8a04b..57ed6e79cddb 100644
--- a/lang/julia/Makefile
+++ b/lang/julia/Makefile
@@ -25,8 +25,6 @@ BUILD_DEPENDS= llvm-config38:devel/llvm38 \
ONLY_FOR_ARCHS= amd64
-BROKEN_FreeBSD_9= does not build (fatal error: 'cmath' file not found)
-
USES= gmake compiler:c++11-lib fortran
USE_LDCONFIG= yes
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index 4ba994c44e4b..ecf06bacd108 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -17,8 +17,6 @@ LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
libfontconfig.so:x11-fonts/fontconfig libfreetype.so:print/freetype2 \
libmysqlclient.so:databases/mysql56-client
-BROKEN_FreeBSD_9= does not build
-
USES= cmake pkgconfig sqlite:3
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index dcac20ebf74e..a2a00f35c811 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png
BROKEN_sparc64= does not link on sparc64
-BROKEN_FreeBSD_9_i386= does not build
USES= bison:build compiler:c++11-lang gmake gperf jpeg perl5 pkgconfig python:build zip
USE_PERL5= build
diff --git a/lang/pocl/Makefile b/lang/pocl/Makefile
index 995021ff7b85..8e01da317f1f 100644
--- a/lang/pocl/Makefile
+++ b/lang/pocl/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= llvm${LLVM_VERSION}>=0:devel/llvm${LLVM_VERSION}
CONFLICTS= freeocl[0-9]*
-BROKEN_FreeBSD_9= pocl is not supported on 9.x
BROKEN_FreeBSD_10= pocl is not supported on 10.x
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON_amd64= only tested on amd64
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index bd3738ef7c9b..1c921a3a8b18 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -19,8 +19,6 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libpcreposix.so:devel/pcre \
libLLVM-${LLVM_VERSION:C/./&./}.so:devel/llvm${LLVM_VERSION}
-BROKEN_FreeBSD_9= does not buld (/usr/local/lib/gcc49/include/c++/cstddef:51:11: error: '::max_align_t' has not been declared)
-
SUB_FILES= pkg-message
USES= gmake iconv pathfix pkgconfig
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 9fca66f20ed0..beeb3a8e83af 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -27,8 +27,6 @@ BUILD_DEPENDS= cmake:devel/cmake
ONLY_FOR_ARCHS?= amd64 i386
ONLY_FOR_ARCHS_REASON= requires prebuilt bootstrap compiler
-BROKEN_FreeBSD_9= Only compiles on FreeBSD 10 and later
-
DISTINFO_FILE?= ${MASTERDIR}/distinfo.${ARCH}
# FIXME: The bootstrapped rustc adds -L/usr/local/lib in front of