aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-02-17 17:18:33 +0800
committergahr <gahr@FreeBSD.org>2014-02-17 17:18:33 +0800
commit40ca0a02ddf52696f6d0758b747a2fc53484aa74 (patch)
tree1e05792c530d647761ae7d23b3efb2cf6bbcc54f /lang
parentc25c7cea590345f596de2d5bd81b9f27453c0896 (diff)
downloadfreebsd-ports-gnome-40ca0a02ddf52696f6d0758b747a2fc53484aa74.tar.gz
freebsd-ports-gnome-40ca0a02ddf52696f6d0758b747a2fc53484aa74.tar.zst
freebsd-ports-gnome-40ca0a02ddf52696f6d0758b747a2fc53484aa74.zip
- STAGE-clean
- Add LICENSE
Diffstat (limited to 'lang')
-rw-r--r--lang/clojure/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/clojure/Makefile b/lang/clojure/Makefile
index 49a07a4a6890..6f9e846ab8e1 100644
--- a/lang/clojure/Makefile
+++ b/lang/clojure/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://repo1.maven.org/maven2/org/clojure/clojure/${PORTVERSION}/
MAINTAINER= jan0sch@gmx.net
COMMENT= Dynamic programming language for the JVM
+LICENSE= EPL
+
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -23,7 +25,6 @@ JLINE_DESC= jline support for the REPL
PLIST_FILES= bin/clojure \
%%JAVAJARDIR%%/clojure.jar
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJLINE}
@@ -34,7 +35,7 @@ CLOJURE_JLINE_RUNNER=jline.ConsoleRunner
SUB_LIST+= CLOJURE_JLINE_RUNNER=${CLOJURE_JLINE_RUNNER}
do-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/clojure-bin ${PREFIX}/bin/clojure
- @${INSTALL_DATA} ${WRKSRC}/clojure-${PORTVERSION}.jar ${JAVAJARDIR}/clojure.jar
+ @${INSTALL_SCRIPT} ${WRKDIR}/clojure-bin ${STAGEDIR}${PREFIX}/bin/clojure
+ @${INSTALL_DATA} ${WRKSRC}/clojure-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/clojure.jar
.include <bsd.port.mk>