aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
committertijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
commit844eb16a686a8eaf36b88417fa047f2a37149374 (patch)
tree31bde26cde7c64937193d64587b12c96997aad8c /lang
parent475d84cbbcf4a6fe952d02d30a5c2201b7236bbd (diff)
downloadfreebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.gz
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.zst
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.zip
- Autodetect the installed linux_base port and use LINUX_DEFAULT only as
a last resort. - Construct a list of DISTFILES for every architecture (amd64, i386). Select one list for regular make and all lists for make makesum so linux ports can have one combined distinfo file. - Set DIST_SUBDIR?=centos so there's only one copy of common distfiles. - Use MASTER_SITES and DISTFILES groups so make fetch is a bit smarter. - Regenerate all distinfo files. - For linux_base-c6 (just like linux_base-c7 already does) turn bin, lib, lib64 and sbin into symbolic links to the same directory under usr. This fixes the problem where some programs/libraries exist under / on FreeBSD and /usr on Linux or vice versa and then depending on the order of search paths Linux programs may run/load FreeBSD programs/libraries and fail. - Turn usr/share/icons into a symbolic link to LOCALBASE/share/icons so Linux programs can find desktop theme icons. This eliminates the need for x11-themes/linux*-hicolor-icon-theme. - Rename pkg-plist.x86_64 to pkg-plist.amd64. - Regenerate all pkg-plist files. - Add @preexec to linux_base pkg-plist that moves existing files in bin, lib, lib64, sbin and icons to the new destination before the directories are turned into symbolic links. - Remove several empty directories from linux_base ports. - Sweep over all linux ports: use consistent style, remove old CONFLICTS, remove unused pkg-descr files, add NLS option,... - Remove old linux arts, esound and openssl-compat ports.
Diffstat (limited to 'lang')
-rw-r--r--lang/linux-c6-tcl85/Makefile7
-rw-r--r--lang/linux-c6-tcl85/distinfo7
-rw-r--r--lang/linux-c6-tcl85/distinfo.i3865
-rw-r--r--lang/linux-c6-tcl85/distinfo.x86_647
-rw-r--r--lang/linux-c6-tcl85/pkg-plist.amd64 (renamed from lang/linux-c6-tcl85/pkg-plist.x86_64)6
-rw-r--r--lang/linux-c6-tcl85/pkg-plist.i3866
-rw-r--r--lang/linux-c7-tcl85/Makefile5
-rw-r--r--lang/linux-c7-tcl85/distinfo (renamed from lang/linux-c7-tcl85/distinfo.x86_64)0
-rw-r--r--lang/linux-c7-tcl85/pkg-plist.amd64 (renamed from lang/linux-c7-tcl85/pkg-plist.x86_64)0
9 files changed, 17 insertions, 26 deletions
diff --git a/lang/linux-c6-tcl85/Makefile b/lang/linux-c6-tcl85/Makefile
index 810473219704..f49b67e3e885 100644
--- a/lang/linux-c6-tcl85/Makefile
+++ b/lang/linux-c6-tcl85/Makefile
@@ -10,15 +10,12 @@ PKGNAMESUFFIX= 85
MAINTAINER= emulation@FreeBSD.org
COMMENT= Tool Command Language (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-f10-tcl85-[0-9]*
-
+DATADIR= ${PREFIX}/usr/share/tcl${PORTVERSION:R}
+DESCR= ${.CURDIR}/../${PORTNAME}${PKGNAMESUFFIX}/pkg-descr
RPMVERSION= 6.el6
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
USE_LINUX_RPM_BAD_PERMS= yes
-DATADIR= ${PREFIX}/usr/share/tcl${PORTVERSION:R}
-DESCR= ${.CURDIR}/../${PORTNAME}${PKGNAMESUFFIX}/pkg-descr
-
.include <bsd.port.mk>
diff --git a/lang/linux-c6-tcl85/distinfo b/lang/linux-c6-tcl85/distinfo
new file mode 100644
index 000000000000..ab40aecdba80
--- /dev/null
+++ b/lang/linux-c6-tcl85/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1485611859
+SHA256 (centos/tcl-8.5.7-6.el6.i686.rpm) = 2f1e77463e3875822811fc5cd972a1792e9c4b3c3ac8b92719698f1a8087a0cc
+SIZE (centos/tcl-8.5.7-6.el6.i686.rpm) = 2012712
+SHA256 (centos/tcl-8.5.7-6.el6.x86_64.rpm) = 4b5384f02b1c2641af9d20e15cc547027e945acc08d07ff939f7332d41affc14
+SIZE (centos/tcl-8.5.7-6.el6.x86_64.rpm) = 2007772
+SHA256 (centos/tcl-8.5.7-6.el6.src.rpm) = cf38cc7fafeb8aaa69be738008a12e36812d5c297aadad51156116dd6531392b
+SIZE (centos/tcl-8.5.7-6.el6.src.rpm) = 4417400
diff --git a/lang/linux-c6-tcl85/distinfo.i386 b/lang/linux-c6-tcl85/distinfo.i386
deleted file mode 100644
index a7689ffbd785..000000000000
--- a/lang/linux-c6-tcl85/distinfo.i386
+++ /dev/null
@@ -1,5 +0,0 @@
-TIMESTAMP = 1466256710
-SHA256 (rpm/i686/centos/6.8/tcl-8.5.7-6.el6.i686.rpm) = 2f1e77463e3875822811fc5cd972a1792e9c4b3c3ac8b92719698f1a8087a0cc
-SIZE (rpm/i686/centos/6.8/tcl-8.5.7-6.el6.i686.rpm) = 2012712
-SHA256 (rpm/i686/centos/6.8/tcl-8.5.7-6.el6.src.rpm) = cf38cc7fafeb8aaa69be738008a12e36812d5c297aadad51156116dd6531392b
-SIZE (rpm/i686/centos/6.8/tcl-8.5.7-6.el6.src.rpm) = 4417400
diff --git a/lang/linux-c6-tcl85/distinfo.x86_64 b/lang/linux-c6-tcl85/distinfo.x86_64
deleted file mode 100644
index 598483663df1..000000000000
--- a/lang/linux-c6-tcl85/distinfo.x86_64
+++ /dev/null
@@ -1,7 +0,0 @@
-TIMESTAMP = 1466257022
-SHA256 (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.x86_64.rpm) = 4b5384f02b1c2641af9d20e15cc547027e945acc08d07ff939f7332d41affc14
-SIZE (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.x86_64.rpm) = 2007772
-SHA256 (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.i686.rpm) = 2f1e77463e3875822811fc5cd972a1792e9c4b3c3ac8b92719698f1a8087a0cc
-SIZE (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.i686.rpm) = 2012712
-SHA256 (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.src.rpm) = cf38cc7fafeb8aaa69be738008a12e36812d5c297aadad51156116dd6531392b
-SIZE (rpm/x86_64/centos/6.8/tcl-8.5.7-6.el6.src.rpm) = 4417400
diff --git a/lang/linux-c6-tcl85/pkg-plist.x86_64 b/lang/linux-c6-tcl85/pkg-plist.amd64
index 2fa833644616..292314131e05 100644
--- a/lang/linux-c6-tcl85/pkg-plist.x86_64
+++ b/lang/linux-c6-tcl85/pkg-plist.amd64
@@ -2,9 +2,9 @@ usr/bin/tclsh
usr/bin/tclsh8.5
usr/lib/libtcl8.5.so
usr/lib64/libtcl8.5.so
-usr/share/doc/tcl-8.5.7/README
-usr/share/doc/tcl-8.5.7/changes
-usr/share/doc/tcl-8.5.7/license.terms
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/changes
+%%PORTDOCS%%%%DOCSDIR%%/license.terms
usr/share/man/man1/tclsh.1.gz
usr/share/man/man3/TCL_MEM_DEBUG.3.gz
usr/share/man/man3/Tcl_Access.3.gz
diff --git a/lang/linux-c6-tcl85/pkg-plist.i386 b/lang/linux-c6-tcl85/pkg-plist.i386
index b8cd787f5cde..adcf5cb3297f 100644
--- a/lang/linux-c6-tcl85/pkg-plist.i386
+++ b/lang/linux-c6-tcl85/pkg-plist.i386
@@ -1,9 +1,9 @@
usr/bin/tclsh
usr/bin/tclsh8.5
usr/lib/libtcl8.5.so
-usr/share/doc/tcl-8.5.7/README
-usr/share/doc/tcl-8.5.7/changes
-usr/share/doc/tcl-8.5.7/license.terms
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/changes
+%%PORTDOCS%%%%DOCSDIR%%/license.terms
usr/share/man/man1/tclsh.1.gz
usr/share/man/man3/TCL_MEM_DEBUG.3.gz
usr/share/man/man3/Tcl_Access.3.gz
diff --git a/lang/linux-c7-tcl85/Makefile b/lang/linux-c7-tcl85/Makefile
index 7838d971f883..0705ace3c312 100644
--- a/lang/linux-c7-tcl85/Makefile
+++ b/lang/linux-c7-tcl85/Makefile
@@ -12,13 +12,12 @@ COMMENT= Tool Command Language (Linux CentOS ${LINUX_DIST_VER})
CONFLICTS= linux-c6-${PORTNAME}${PKGNAMESUFFIX}-[0-9]*
+DATADIR= ${PREFIX}/usr/share/tcl${PORTVERSION:R}
+DESCR= ${.CURDIR}/../${PORTNAME}${PKGNAMESUFFIX}/pkg-descr
RPMVERSION= 8.el7
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
USE_LINUX_RPM_BAD_PERMS= yes
-DATADIR= ${PREFIX}/usr/share/tcl${PORTVERSION:R}
-DESCR= ${.CURDIR}/../${PORTNAME}${PKGNAMESUFFIX}/pkg-descr
-
.include <bsd.port.mk>
diff --git a/lang/linux-c7-tcl85/distinfo.x86_64 b/lang/linux-c7-tcl85/distinfo
index 0f2c7a6bb23e..0f2c7a6bb23e 100644
--- a/lang/linux-c7-tcl85/distinfo.x86_64
+++ b/lang/linux-c7-tcl85/distinfo
diff --git a/lang/linux-c7-tcl85/pkg-plist.x86_64 b/lang/linux-c7-tcl85/pkg-plist.amd64
index 4371216b7284..4371216b7284 100644
--- a/lang/linux-c7-tcl85/pkg-plist.x86_64
+++ b/lang/linux-c7-tcl85/pkg-plist.amd64